본문 바로가기
KERD
논문KCI 등재

FMC 단말에서의 Cross-Layer 시그날링 프레임웍 연구

Cross-layer Signaling Framework of FMC Terminals

3

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

유무선 통합서비스를 제공함에 있어 이기종망간의 핸드오프를 위한 이동성 관리와 멀티미디어 응용 서비스를 위한 QoS 보장은 가장 중요한 이슈이다. 본 논문에서는 이러한 문제를 해결하기 위한 방안으로 유무선 통합 단말에서의 cross-layer 시그날링 프레임웍을 제시하였다. FMC 서비스에서 요구되는 WLAN과 이동전화망간 IP 이동성 서비스 제공을 위해 FMIPv6를 사용하고, 신속한 핸드오프 서비스를 위해 IEEE802.21의 MIH 기술을 기본 기술로 사용하였다. 본 논문에서 제안한 유무선 통합 단말의 cross-layer 프레임웍은 FMIPv6, MIH 및 SIP와의 연동을 위한 인터페이스를 가지며, 무선링크의 상태관리, 네트워크 환경 및 QoS 요구에 근거한 핸드오프 결정과 실질적인 핸드오프 관리 기능을 수행하게 된다. 특히, cross-layer 시그날링을 위한 각 엔터티들은 다양한 무선망으로의 확장이 가능하며, 각 계층 프로토콜 스택과의 인터페이스를 통해 서비스 품질 향상을 위한 다양한 방안들을 효과적으로 수용할 수 있는 기본적인 프레임웍 역할을 수행할 수 있다.

Abstract

In wire and wireless convergence services, the most important issues is guaranteeing the Quality of Service(QoS) for mobility management and a multimedia application during handoff between heterogeneous networks. This article suggests some of solution to this matter by providing cross-layer signaling framework for fixed mobile convergence terminal. We used FMIPv6 and IEEE 802.21 MIH function to provide IP mobility service and fast handoff in FMC environment. The cross-layer framework of FMC terminals consist with interface between FMIPv6, MIH and SIP for its inter-communication, wireless link quality management and substantial handoff management base on network environment and QoS requirements. In particular, the main feature of suggested cross-layer framework is scalability to extend its entity to variety of wireless networks. Also, its interface with protocol stack can serve as one of the effective method and fundamental structure for the service quality improvements.

참고문헌 (15)

  1. "3GPP, ''3GPP system to Wireless Local Area Network(WLAN) interworking; System Description(Release 6),'' 3GPP TS 23.234", ~
  2. "3GPP, ''Handover Requirements between UTRAN and GERAN or other Radio System(Release 6),'' 3GPP TS 25.129", ~
  3. Network Mobility (NEMO) Basic Support Protocol, "V. Devarapali", ~, pp.IETF RFC 3963 (2005)
  4. Fast Handovers for Mobile IPv6, "R. Koodli", ~, pp.IETF RFC 4608 (2006)
  5. "IEEE 802.21 WG, ''Standard and Metropolitan Area Networks: Media Independent Handover Services''", ~ (2006)
  6. Y. Y. An, "Reduction of Handover Latency Using MIH Services in MIPv6", Proc. AINA 2006, 통권 : 2, pp.229~234 (2006)
  7. Q. B. Mussabbir, "Optimized FMIPv6 Using IEEE 802.21 MIH Services in Vehicular Network", IEEE Trans. on Vehicular Technology, 56(6), pp.3397~3407 (2007)
  8. I. Haratcherev, "Optimized Video Streaming over 802.11 by Cross-Layer Signaling", IEEE Comm. Magazine, pp.115~121 (2006)
  9. S. Shakkottai, "Cross-Layer Design for Wireless Networks", IEEE Comm. Magazine, pp.74~80 (2003)
  10. M. Fiorenzi, "Enhaching TCP over HSDPA by Cross-Layer Signalling", Globecom 2007, pp.5362~5366 (2007)
  11. Z. Li, "Seamless IP Multimedia Service Continuity in Inter-worked UMTS and WLAN", PIMRC 2007, pp.1~5 (2007)
  12. "3GPP, ''3GPP System to Wireless Local Area Network(WLAN) Interworking; User Equipment(UE) to Network Protocols(Release 6),'' 3GPP TS 24.234", ~
  13. J. Rosenberg, "''SIP: Session Initiation Protocol,'' IETF RFC 3261", ~ (2002)
  14. Q.Wang, "Mobility Management Architectures Base on Joint Mobile IP and SIP Protocols", IEEE Wireless Communications, 13(6), pp.68~76 (2006)
  15. M.Chiang, "Balancing Transport and Physical Layers in Wireless Multihop Networks : Jointly Optimal Congestion Control and Power Control", IEEE JSAC, 23(1), pp.104~116 (2005)

관련 논문AI추천

이 간행물의 다른 논문 (15건)