MOFI: Future Internet Architecture with Address-free Hosts for Mobile Environments
2
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
It is envisioned that mobile users will become the key driver toward future Internet. We propose a future Internet architecture for mobile-oriented Internet environments, named Mobile-Oriented Future Internet (MOFI), which is based on address-free hosts with host identifier (HID) and network locator (LOC). The MOFI is featured by the HID-based communication with LOC-based routing and the support of heterogeneous access networks. We present the MOFI architecture and describe the relevant procedures for data transport and mobility control. By numerical analysis, we see that the proposed scheme can significantly improve the packet delivery cost and handover delay, compared to the existing mobility protocols.
Abstract
It is envisioned that mobile users will become the key driver toward future Internet. We propose a future Internet architecture for mobile-oriented Internet environments, named Mobile-Oriented Future Internet (MOFI), which is based on address-free hosts with host identifier (HID) and network locator (LOC). The MOFI is featured by the HID-based communication with LOC-based routing and the support of heterogeneous access networks. We present the MOFI architecture and describe the relevant procedures for data transport and mobility control. By numerical analysis, we see that the proposed scheme can significantly improve the packet delivery cost and handover delay, compared to the existing mobility protocols.
참고문헌 (13)
- D. Johnson, "Mobility Support in IPv6", IETF RFC 3775, ~ (2004)
- S. Gundavelli, "Proxy Mobile IPv6", IETF RFC 5213, ~ (2008)
- "eMobility Project"[URL]
- "4WARD Project"[URL]
- "Future Internet Design(FIND)"[URL]
- "AKARI"[URL]
- D. Meyer, "Report from the IAB Workshop on Routing and Addressing", IETF RFC 4984, ~ (2007)
- "Mobile Oriented Future Internet(MOFI)homepage"[URL]
- "IEEE 802.21,Media Independent Handover(MIH)Services"[URL]
- R. Moskowitz, "Host Identity Protocol (HIP)", IETF RFC 5201, ~ (2008)
- D. Farinacci, "Locator", ID Separation Protocol (LISP), 2011
- S. Krishnan, "Localized Routing for Proxy Mobile IPv6", IETF Internet Draft, draft-ietf-netext-pmip-lr- 01.txt, ~ (2010)
- 한연희, "Mobility management for all-IP mobile networks: Mobile IPv6 vs. Proxy Mobile IPv6", IEEE WIRELESS COMMUNICATIONS, 15(2), pp.36~45
