본문 바로가기
KERD
논문KCI 등재

A Comparative Analysis of Centralized and Distributed Mobility Management in IP-Based Mobile Networks

4

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

The Mobility Management (MM) is one of the crucial requirements for future mobile networks. The current MM schemes, such as Mobile IP and Proxy Mobile IP, are based on a centralized mobility anchor for mobility control and data delivery. However, it is reported that such a Centralized MM (CMM) approach tends to give a couple of drawbacks, which include non-optimal data route, injection of unwanted data traffics into core networks, and increased cost of network engineering. Recently, some proposals on Distributed MM (DMM) architectures have been discussed so as to overcome limitations of the centralized MM approach, which can be divided into Partially Distributed MM (P-DMM) and Fully Distributed MM (F-DMM). In this paper, we conduct a comparative study on the three MM approaches in terms of total delay and traffic overhead. From numerical results, we see that F-DMM and P-DMM can give better performance than CMM in terms of control/data traffic overhead. However, in terms of total delay, it seems that CMM is preferred to P-DMM and F-DMM in the mesh-like networks, whereas P-DMM and F-DMM is preferred to CMM in the tree-like networks.

Abstract

The Mobility Management (MM) is one of the crucial requirements for future mobile networks. The current MM schemes, such as Mobile IP and Proxy Mobile IP, are based on a centralized mobility anchor for mobility control and data delivery. However, it is reported that such a Centralized MM (CMM) approach tends to give a couple of drawbacks, which include non-optimal data route, injection of unwanted data traffics into core networks, and increased cost of network engineering. Recently, some proposals on Distributed MM (DMM) architectures have been discussed so as to overcome limitations of the centralized MM approach, which can be divided into Partially Distributed MM (P-DMM) and Fully Distributed MM (F-DMM). In this paper, we conduct a comparative study on the three MM approaches in terms of total delay and traffic overhead. From numerical results, we see that F-DMM and P-DMM can give better performance than CMM in terms of control/data traffic overhead. However, in terms of total delay, it seems that CMM is preferred to P-DMM and F-DMM in the mesh-like networks, whereas P-DMM and F-DMM is preferred to CMM in the tree-like networks.

참고문헌 (19)

  1. "Morgan Stanley Report, Internet trends" (2013)[URL]
  2. J. Saltzer, "On the naming and binding of network destinations, IETF RFC 1498" (1993)
  3. C. Perkins, "IP Mobility Support for IPv4, IETF RFC 3344" (2002)
  4. D. Johnson, "Mobility Support in IPv6, IETF RFC 3775" (2004)
  5. S. Gundavelli, "Proxy Mobile IPv6, IETF RFC 5213" (2008)
  6. H. Chan, "Requirements for Distributed Mobility Management, IETF RFC 7333" (2014)
  7. D. Liu, "Distributed Mobility Management: Current Practices and Gap Analysis, IETF RFC 7429" (2015)
  8. P. Jokela, "Host Identity Protocol, IETF RFC 5201" (2008)
  9. ID Separation Protocol, IETF RFC 6830, "Locator", pp.2013, D. Farinacci
  10. ID Separation Protocol - Alternative Topology (LISP+ALT), IETF RFC 6836, "Locator", pp.2013, V. Fuller
  11. V. Fuller, "LISP Map Server Interface, IETF RFC 6833" (2013)
  12. RJ Atkinson, "Identifier-Locator Network Protocol (ILNP) Architecture Description, IETF RFC 6740" (2012)
  13. M. Gohar, "Network-based Distributed Mobility Control in Localized Mobile LISP Networks", IEEE Communications Letters, 16, pp.104~107 (2012)
  14. F. Qiu, "A Distributed Mobility Management Scheme in Networks with the Locator", Identifier Separation, 2014, pp.27, 1874~1893
  15. L. Mathy, "LISP-DHT: Towards a DHT to Map Identiers onto Locators", Conference of ReArch 08 (2008)
  16. S. Nov?czki, "Micromobility Support in HIP", Conference of IEEE MELECON (2006)
  17. D. Farinacci, "LISP Mobile Node, IETF Internet Draft, draft-meyer-lisp-mn-12", ~ (2015)
  18. M. Gohar, "Distributed Mapping Management of Identifiers and Locators in LISP-based Mobile Networks", Wireless Personal Communications, 72(1), pp.565~579 (2013)
  19. URCP: Universal Rate Control Protocol for Real-Time Communication Applications, "D. Xie", Microsoft Research Technical, ~, pp.Microsoft Research Technical Report, MSR-TR-2013- 64 (2013)

관련 논문AI추천

이 간행물의 다른 논문 (12건)