본문 바로가기
KERD
논문KCI 등재

Partial Bicasting with Buffering for Proxy Mobile IPv6 Handover in Wireless Networks

2

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

This paper addresses the Proxy Mobile IPv6 (PMIP) handover using bicasting in mobile/wireless networks. The bicasting scheme can be used to support the PMIP handover, which tends to waste the network resources of wireless links and incurs data losses during handover. We propose an enhanced scheme of PMIP handover, called the partial bicasting with buffering for PMIP (PBB-PMIP). In the PBB-PMIP handover, the bicasting is performed in the “partial” region between the Local Mobility Anchor (LMA) and the Mobile Access Gateway (MAG), when a mobile node is in the handover area. The data packets are buffered at the new MAG during handover to reduce data losses and are then forwarded to mobile nodes after handover. By ns-2 simulations, the proposed PBB-PMIP scheme is compared with the existing schemes of PMIP and PMIP with bicasting. The proposed scheme can benefit from the reduction of handover delay and packet loss, and the effective use of the network resources of wireless links, as compared to the existing handover schemes.

Abstract

This paper addresses the Proxy Mobile IPv6 (PMIP) handover using bicasting in mobile/wireless networks. The bicasting scheme can be used to support the PMIP handover, which tends to waste the network resources of wireless links and incurs data losses during handover. We propose an enhanced scheme of PMIP handover, called the partial bicasting with buffering for PMIP (PBB-PMIP). In the PBB-PMIP handover, the bicasting is performed in the “partial” region between the Local Mobility Anchor (LMA) and the Mobile Access Gateway (MAG), when a mobile node is in the handover area. The data packets are buffered at the new MAG during handover to reduce data losses and are then forwarded to mobile nodes after handover. By ns-2 simulations, the proposed PBB-PMIP scheme is compared with the existing schemes of PMIP and PMIP with bicasting. The proposed scheme can benefit from the reduction of handover delay and packet loss, and the effective use of the network resources of wireless links, as compared to the existing handover schemes.

참고문헌 (7)

  1. "IETF RFC 5213, Proxy Mobile IPv6", ~ (2008)
  2. "IETF RFC 5949, Fast Handovers for Proxy Mobile IPv6", ~ (2010)
  3. "IETF RFC 4068, Fast Handovers for Mobile IPv6", ~ (2005)
  4. Mortaza S. Bargh, "Reducing handover latency in future IP-based wireless networks: Proxy Mobile IPv6 with Simultaneous Bindings", Proceeding of WoWMoM 2008 (2008)
  5. "IEEE 802.21, Media Independent Handover Services", ~
  6. "IETF RFC 6058, Transient Binding for Proxy Mobile IPv6", ~ (2011)
  7. "NS-2 Network Simulator"[URL]

관련 논문AI추천

이 간행물의 다른 논문 (10건)