본문 바로가기
KERD
논문KCI 등재

Fast Tree Join for Seamless Multicast Handover in FMIPv6-based Mobile Networks

4

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

This paper proposes a fast tree join scheme to provide seamless multicast handover in the mobile networks using the Fast Mobile IPv6 (FMIPv6). In the existing FMIPv6-based multicast handover schemes, the bi-directional tunnelling or the remote subscription is employed with the packet buffering at the new access router (AR). In general, the remote subscription approach is preferred to the bi-directional tunnelling, since in the remote subscription scheme we can exploit an optimized multicast path from a multicast source to many mobile receivers. However, in the remote subscription scheme, if the tree joining operation takes a long time, a significant amount of data packets will be buffered at the new AR, and thus it may result in the buffering overhead that may induce the buffer overflow and packet losses. In this paper, we propose a fast join to multicast tree so as to reduce the handover delay and the associated buffering overhead. In the proposed scheme, the new AR will join the multicast tree as soon as the associated handover event is detected. This ensures that the new multicast data packets can arrive at the new AR as fast as possible, which is helpful to reduce the packet buffering overhead as well as the handover delay. From the ns-2 simulations, it is shown that the proposed scheme can give better performance than the existing FMIPv6-based multicast handover schemes in terms of handover delay and buffering overhead

Abstract

This paper proposes a fast tree join scheme to provide seamless multicast handover in the mobile networks using the Fast Mobile IPv6 (FMIPv6). In the existing FMIPv6-based multicast handover schemes, the bi-directional tunnelling or the remote subscription is employed with the packet buffering at the new access router (AR). In general, the remote subscription approach is preferred to the bi-directional tunnelling, since in the remote subscription scheme we can exploit an optimized multicast path from a multicast source to many mobile receivers. However, in the remote subscription scheme, if the tree joining operation takes a long time, a significant amount of data packets will be buffered at the new AR, and thus it may result in the buffering overhead that may induce the buffer overflow and packet losses. In this paper, we propose a fast join to multicast tree so as to reduce the handover delay and the associated buffering overhead. In the proposed scheme, the new AR will join the multicast tree as soon as the associated handover event is detected. This ensures that the new multicast data packets can arrive at the new AR as fast as possible, which is helpful to reduce the packet buffering overhead as well as the handover delay. From the ns-2 simulations, it is shown that the proposed scheme can give better performance than the existing FMIPv6-based multicast handover schemes in terms of handover delay and buffering overhead

참고문헌 (17)

  1. D. H. Kwon, "Design and implementation of an efficient multicast support scheme for FMIPv6", Proceeding of INFOCOMM2006, pp.1~12 (2006)
  2. Nicolas Montavont, "Handover Management for Mobile Nodes in IPv6 Networks", IEEE Communication Magazine, 40(8), pp.38~43 (2002)
  3. D. Johnson, "Mobility Support in IPv6", IETF RFC 3775, ~ (2004)
  4. R. Koodli, "Mobile IPv6 Fast Handovers", IETF RFC 5268, ~ (2008)
  5. W. Fenner, "Internet Group Management Protocol", IETF RFC 2236, ~ (1997)
  6. B. Cain, "Internet Group Management Protocol", IETF RFC 3376, ~ (2002)
  7. S.Deering, "Multicast Listener Discovery (MLD) for IPv6", IETF RFC 2710, ~ (1999)
  8. R. Vida, "Multicast Listener Discovery Version 2 (MLDv2) for IPv6", IETF RFC 3810, ~ (2004)
  9. T.Pusateri, "Protocol Independent Multicast - Sparse Mode (PIM-SM)", IETF RFC 4602, ~ (2006)
  10. H. Holbrook, "Source-Specific Multicast for IP", IETF RFC 4607 (2006)
  11. I. Romdhani, "IP mobile multicast: challenges and solutions", IEEE Communications, 6(1), pp.18~41 (2004)
  12. T. Harrison, "Mobile multicast (MoM) protocol: multicast support for mobile hosts", Proceeding of ACM, 1997, 151~160
  13. Y.-J. Suh, "An efficient multicast routing protocol in wireless mobile networks", ACM Wireless Networks, 7(5), pp.443~453 (2001)
  14. C. R. Lin, "Mobile multicast support in IP networks", IEEE INFOCOM 2000, 1664~1672 (2000)
  15. J. Park, "A Timer-based mobile multicast routing protocol in mobile network", Computer Communications, 26(17), pp.1965~1974 (2003)
  16. S. Yoo, "Fast Handover Mechanism for Seamless Multicasting Services in Mobile IPv6Wireless Networks", Wireless Personal Communications, 42, pp.509~526 (2007)

관련 논문AI추천

이 간행물의 다른 논문 (11건)