미래 인터넷에서의 식별자-위치 지시자 분리 아키텍처 연구 동향
A Survey on Identifier-Locator Separation Architecture in Future Internet
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
현재 인터넷의 문제점을 극복할 수 있는 새로운 인터넷을 설계하고자 하는 미래 인터넷 연구가 전세계적으로 활발히 진행되고 있다. 라우팅/주소 체계 연구, 이동성 지원, 보안성/확장성 제공과 관련하여 많은 미래 인터넷 연구가 진행되고 있는데 그 중 IP 주소가 가지고 있는 식별자 (Identifier: ID)와 위치 지시자 (Locator)의 역할을 분리하기 위한 아키텍처 연구는 이동성/멀티호밍 지원, 확장성있는 라우팅 등을 위해 필수적인 기술로 간주되고 있다. 본 고에서는 이러한 식별자-위치 지시자 분리 아키텍처 설계를 위한 요구사항을 파악하고 현재 논의되고 있는 네트워크 또는 단말기 기반의 분리 아키텍처를 비교, 분석한다. 그런 다음 IETF, ITU-T에서 진행되고 있는 표준화 동향을 살펴본 뒤 향후 연구 방향을 정리한다.
Abstract
Research on Future Internet focuses on a revolutionary approach to overcome problems in the current Internet, e.g., scalability, security, mobility, and reconfigurability. Among different research issues, the addressing architecture in Future Internet is perceived as one of the most important fundamental issues. Especially, since identifier and locator coupling in the current IP addressing architecture can lead to a variety of drawbacks in terms of scalable routing, mobility, and multi-homing support, how to separate identifier and locator has been actively investigated in the literature. In this article, we first identify key requirements and design issues for the identifier-locator separation architecture. After that, we compare and analyze representative identifier-locator separation architectures, which are classified into network-based and terminal-based approaches. We also summarize recent standardization activities in Internet Engineering Task Force (IETF) and International Telecommunications Union-Telecommunications (ITU-T) and present future research directions.
참고문헌 (13)
- Report from the IAB Workshop on Routing and Addressing, "D. Meyer", ~, pp.RFC 4984 (2007)
- "BGP routing table analysis report"[URL]
- Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation Plan, "V. Fuller", ~, pp.RFC 4632 (2006)
- "68th IETF Meeting materials"[URL]
- Internet Protocol, Version 6 (IPv6) Specification, "S. Deering", ~, pp.RFC 2460 (1998)
- D. Farinacci, "Locator", ID Separation Protocol (LISP), draft-farinacci-lisp-07.txt, 2008
- "Host Identity Protocol (HIP)"[URL]
- M. O'Dell, "GSE - An Alternate Addressing Architecture for IPv6, -ietf-ipngwg-gseaddr-00.txt", ~ (1997)
- "72nd IETF meeting"[URL]
- "Site Multihoming by IPv6 Intermediation (shim6)"[URL]
- C. Vogt, "Six", One: A Solution for Routing and Addressing in IPv6, draft-vogt-rrg-six-one-00.txt, 2008
- "69th IETF meeting materials"[URL]
- "ITU-T SG13"[URL]
