IPv4/IPv6 전환기술 비교 분석
Comparison and Analysis of IPv4/IPv6 Transition Technologies
1
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
본 논문에서는 IPv4 주소 자원 공유 기술을 포함하여 IPv4/IPv6 전환(Transition) 기술에 대해서 연구 시기를 기준으로 ‘1세대’와 ‘2세대’로 나누어 연구 동향을 살펴보고 이를 비교 분석하고자한다. 첫 번째로, 1세대, 즉 IPv6 기본 기술과 관련 기술의 연구 개발이 본격적으로 진행되었던 1990년대 후반부터 2000년대 초반에 연구 개발된 IPv4/IPv6 전환 기술을 듀얼스택(Dual-stack) 기술, 터널링(Tunneling) 기술, 주소변환(Translation)로 분류하여 분석한다. 두 번째로, 2세대, 즉 최근 2010년 전후로 유ㆍ무선 통합 서비스 제공, 스마트 기기 보급 확산 등에 따른 무선 인터넷 서비스 활성화로 전 세계적으로 IP 주소 수요는 급격하게 증가하였고, 이와 맞물려 ICANN은 물론 APNIC이 주소 고갈을 선언하면서 IPv6 도입에 대한 필요성이 다시금 대두되게 되었다. 즉, 1세대에서 기 연구 개발된 세 가지 기술을 개선하고자 최근 연구 개발된 IPv4/IPv6 전환 기술은 물론 IPv4 주소 부족을 해결하기 위해 개선된 주소 자원 공유 기술에 대해서 다룬다. 마지막으로, 2세대에서 연구 개발된 전환 기술에 대해서 다양한 측면에서 비교분석을 수행한다.
Abstract
In this paper, IPv4/IPv6 transition technologies including IP address sharing are surveyed, categorized, and analyzed according to the time of the research, 1st generation and 2nd generation. For the 1st generation, from the late 1990s to the early 2000s, when IPv6 related researches and developments are at an early stage, IPv4/IPv6 transition technologies are surveyed and described with the classification of dual-starck, tunneling and translation. Secondly, the 2nd generation is considered as around 2010. Around this time, IPv4 address is rapidly depleting due to the fast growing number of Internet-enabled mobile and smart devices. In addition, ICANN as well as APNIC have raised officially the impending exhaustion of the IPv4 address. These situations encourage IPv6 to be adopted as a solution. Hence, alternative IPv4/IPv6 transition technologies and IP address sharing technologies are surveyed and described, which have been researched and developed in order to modify and enhance exiting 1st generation technologies. Finally, these 2nd generation technologies are compared and analyzed from a variety of views.
참고문헌 (39)
- P. Roberts, "World IPv6 Launch: The Future is Forever", IETF Journal, 8(1), pp.12~ (2012)
- T. Tsou, "Exploring IPv6Deployment in the Enterprise: Experiences of the IT Department of Futurewei Technologies", IETF Journal, 8(1), pp.13~17 (2012)
- L. Smith, "Free Pool of IPv4 Address Space Depleted", Number Resource Organization, ~ (2011)
- 이희철, "IPv6 전환기술동향및과제", 인터넷정보학회지, 4(4), pp.77~83 (2003), 한국인터넷정보학회
- 이재용, "IPv4", IPv6 전환기술의 최근 동향 및 분석, 2011, 547~548
- IPv6 단계적 적용시 보안성 강화방안 연구, , 한국인터넷진흥원, ~ (2011)
- A. Hamarsheh, "Assuring Interoperability Between Heterogeneous (IPv4", IPv6) Networks Without using Protocol Translation, 2012, pp.29(2), 114~132
- A. Hamarsheh, "Decoupling Application IPv4", IPv6 Operation from the Underlying IPv4, Journal of Scientific Research, pp.2011, (14)[DOI]
- P. Wu, "Transition from IPv4 to IPv6: A State-of-the-Art Survey", IEEE Communications Surveys & Tutorials, 15(3), pp.1407~1424 (2013)
- A. Johnson, "IPv6 Transition Tehcnologies", APRICOT 2014 (2014)
- K. Egevang, "The IP Network Address Translator (NAT)", IETF RFC 1631, ~ (1994)
- S. Jiang, "An Incremental Carrier-Grade NAT (CGN) for IPv6 Transition", IETF RFC 6264, ~ (2012)
- I. Yamagata, "NAT444", IETF Draft, draft-shirasakinat444-06, ~ (2012)
- C. Donley, "Assessing the Impact of Carrier-Grade NAT on Network Applications", IETF Draft, draft-donleynat444-impacts-06, ~ (2013)
- A. Durand, "Dual-Stack Lite Broadband Deployments Following IPv4 Exhaustion", IETF RFC 6333, ~ (2011)
- Y. Cui, "Public IPv4 over IPv6 Access Network", RFC 7040, ~ (2013)
- Y. Cui, "Lightweight 4over6: An Extension to the DSLite Architecture", IETF Draft, draft-ietf-softwirelw4over6-08, ~ (2014)
- A. Conta, "Generic Packet Tunneling in IPv6 Specification", IETF RFC 2473, ~ (2001)
- A. Barbir, "Basic Transition Mechanisms for IPv6 Hosts and Routers", IETF RFC 1993, April 1996 (Obsoleted by IETF RFC 2893, Aug. 2000, Obsoleted by IETF RFC 4213, Oct. 2005), ~ (2005)
- A. Durand, "IPv6Tunnel Broker", IETF RFC 3053, ~ (2001)
- B. Carpenter, "Connection of IPv6 Domains via IPv4 Clouds", IETF RFC 3056, ~ (2001)
- B. Carpenter, "Transmission of IPv6over IPv4 Domains without Explicit Tunnels", IETF RFC 2529, ~ (1999)
- F. Templin, "Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)", IETF RFC 4214. (Obsoleted by IETF RFC 5214 at Mar. 2008), ~ (2008)
- C. Huitema, "Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)", IETF RFC 4380, ~ (2006)
- J. Wu, "4over6Transit Solution Using IP Encapsulation and MP-BGP Extensions", IETF RFC 5747, ~ (2010)
- R. Despres, "IPv4 Residual Deployment via IPv6 - Unified Solution (4rd)", IETF Draft, draft-despres-softwire-4rd-u-06, ~ (2012)
- R. Despres, "IPv4 Residual Deployment via IPv6- A Stateless Solution (4rd)", IETF Draft, draft-ietfsoftwire-4rd-07, ~ (2014)
- W. Townsley, "IPv6 Rapid Deployment on IPv4 Infrastructures", IETF RFC 5969, ~ (2010)
- E. Nordmark, "Stateless IP", ICMP Translation Algorithm (SIIT), 2000
- G. Tsirtsis, "Network Address Translation - Protocol Translation (NAT-PT)", IETF RFC 2766, ~ (2000)
- C. Aoun, "Reasons to Move the Network Address Translator - Protocol Translator (NAT-PT) to Historic Status", IETF RFC 4966, ~ (2007)
- K. Tsuchiya, "Dual Stack Hosts using the 'Bump-In-the-Stack' Technique (BIS)", IETF RFC 2767, ~ (2000)
- S. Lee, "Dual Stack Hosts Using ''Bump-in-the-API'' (BIA)", IETF RFC 3338, ~ (2002)
- C. Bao, "IPv6 Addressing of IPv4", IPv6 Translators, 2010
- X. Li, "The China Education and Research Network (CERNET) IVI Translation Design and Deployment for the IPv4", IPv6Coexistence and Transition, 2011
- F. Baker, "Framework for IPv4", IPv6 Translation, 2011
- X. Li, "IP", ICMP Translation Algorithm, 2011
- M. Bagnulo, "Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 Servers", IETF RFC 6146, ~ (2011)
- M. Bagnulo, "DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 Servers", IETF RFC 6147, ~ (2011)
