차세대 인터넷 서비스를 위한 DSTM의 IPv4 over IPv6 터널 구현
The Implementation of an IPv4 over IPv6 Tunnel of the DSTM for Next-Generation Internet Service
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
본 논문은 DSTM (Dual Stack Transition Mechanism) 서비스를 제공하기 위해 필요한 구성 요소 중에서 DTI (Dynamic Tunnel Interface)를 통한 IPv4 over IPv6 터널에 대해 분석한 후 요소기술 및 기능들을 정의하여 적합한 모듈을 설계하여 구현하였다. 그리고 구현된 IPv4 over IPv6 터널이 실제 서비스될 수 있는지를 확인하기 위해 다양한 환경에서 기존의 6over4 서비스와 IPv4 트래픽과의 성능 비교 분석을 위한 실험 후 결과를 제시하였다. 제시된 결과는 IPv6 터널 헤더에서의 checksum 계산의 불필요성에 따른 지연 감소 등으로 6over4 서비스보다는 우수한 성능을 나타내었다.
Abstract
In this paper, we propose an efficient algorithm that assigns single temporary IPv4 address and port number to improve efficiency of IPv4 address that is allocated in DSTM service. And, we have analyzed the elementary functions for DSTM and have designed the functional modules. Also, we have implemented the DTI interface for encapsulation and decapsulation of IPv6 packets. The performance analysis and comparison are investigated whether the appropriate interworking service is possible or not. Our observation results show that the performance of IPv4 over IPv6 tunneling is suitable to DSTM service due to the reduction of delay by eliminating checksum calculations in the header of IPv6 tunneling.
참고문헌 (14)
- D. C. Lee, "The next generation of the internet: aspects of the internet protocol version 6", IEEE Network Magazine, 12(1), pp.28~33 (1998)
- C. Huiteman, "Teredo: tunneling IPv6 over UDP through , IETF draft-huitema-v6ops-teredo -05", ~
- 이승민, "IPv4", IPv6 프로토콜 및 주소변환 기능의요소기술 분석 및 설계, 2003, pp.30(1), 117~125[DOI]
- G. Tsirtsis, "Network address translation – Protocol translation (NAT-PT) ,IETF RFC 2766", ~ (2000)
- E.Nordmark, "Stateless IP", ICMP translation a Algorithm(SIIT) ,IETF RFC 2765, 2000
- J. Bound, "Dual stack IPv6 dominant transition mechanism(DSTM) , IETF draft-bound-dstm-exp-04.txt", ~ (2005)
- D. Waddington, "Realizing the transition to IPv6", IEEE Comm. Magazine, 40(6), pp.138~148 (2002)
- E. Nordmark, "Basic transition mechanism for IPv6 hosts and routers , IETF RFC 4213", ~ (2005)
- IP Illustrated vol. 1, "TCP", pp.1993, W. Stevens
- IP Illustrated vol. 2, "TCP", pp.IP Illustrated vol. 2, W. Stevens
- IP Illustrated vol. 3, "TCP", pp.1996, W. Stevens
- A. Miller, "Implementing IPv6" (2000), Implementing IPv6
- "Tcpdump"[URL]
- "Ethereal, Ethereal User's Guide"[URL]
