IPv6 환경에서 해쉬 함수 기반 강건한 주소 생성 및 검증 기법
A Strong Address Generation and Verification Scheme using Hash Functions in the IPv6 Environments
0
조회
0
다운로드
1
인용
0
참고문헌
초록
IPv6 프로토콜은 네트워크에 참여하는 노드가 별도의 관리자 작업 없이 자동으로 주소를 생성하는 방법을 제공하며, 생성된 주소는 사용되기 전에 유일성 검증을 위하여 Duplication Address Detection(DAD) 메커니즘을 수행한다. 하지만 검증 과정에서 악의적인 노드의 공격에 의해 이미 사용하고 있는 주소로 판단되어 주소 생성이 실패할 가능성이 존재한다. 따라서 본 논문에서는 해쉬 함수를 기반으로 주소를 생성하고 검증함으로써, 빠르고 강건한 주소 생성과 및 검증 메커니즘을 보인다. 이 기법은 공항, 터미널, 회의실과 같이 많은 노드들의 무선 네트워크 참여가 빈번한 공공장소에서 SEND 메커니즘보다 더욱 효과적으로 주소 생성 및 검증을 할 수 있다.
Abstract
The IPv6 protocol provides the method to automatically generate an address of a node without additional operations of administrators, Before the generated address is used, the duplicate address detection (DAD) mechanism is required in order to verify the address. However, during the process of verification of the address, it is possible for a malicious node to send a message with the address which is identical with the generated address, so the address can be considered as previously used one; although the node properly generates an address, the address cannot be used. In this paper, we present a strong scheme to perform the DAD mechanism based on hash functions in IPv6 networks. Using this scheme, many nodes, which frequently join or separate from wireless networks in public domains like airports, terminals, and conference rooms, can effectively generate and verify an address more than the secure neighbor discovery (SEND) mechanism.
참고문헌 (10)
- T. Narten, "RFC 2461" (1998)
- J. Arkko, "Securing IPv6 neighbor and router discovery,"", pp.77~86 (2002)
- J. Arkko, "RFC 3971" (2005)
- S. Thomson, "RFC 2462" (1998)
- T. Aura, "RFC 3972" (2005)
- 박기태, "IPv6의 보안기능을 강화하는 Secure ND Protocol의 구현", 2(1)
- P. Nikander, "RFC 3756" (2004)
- G. Kedem, "Brute Force Attack on UNIX Passwords with SIMD Computer", pp.93~98
- C. P. Pfleeger, "Security in Computing" (2002), Prentice Hall PTR
- C. Adams, "Profiles and Protocols for the Internet Public-Key Infrastructure", pp.220~224
