보안 이웃 탐색 프로토콜 성능 향상 기법에 관한 연구
A Study on the Performance Improvementin SEcure Neighbor Discovery (SEND) Protocol
0
조회
0
다운로드
0
인용
0
참고문헌
초록
이웃 탐색(Neighbor Discovery) 프로토콜은 IPv6 프로토콜 사용 환경에서 동일 링크에 연결된 노드 사이에 이웃 노드에 관한 정보를 교환하는데 사용되는 프로토콜이다. 처음으로 제안되었던 IPsec 프로토콜의 인증 헤더(Authentication Header)를 이용한 이웃 탐색 프로토콜 보호 방법은 키 교환 프로토콜을 사용할 수 없고 수동적 키 분배의 어려움이 있는 문제점이 있었다. 그 후 모든 이웃 탐색 메시지를 디지털 서명(Digital Signature)으로 보호하는 보안 이웃 탐색(SEND) 프로토콜이 제안되었다. 그렇지만 공개키 암호화 시스템을 기반으로 한 디지털 서명 기술은 일반적으로 고비용이 드는 것으로 알려져 있어 가용성 측면에서 상당한 성능 저하가 있을 것으로 예상된다. 본 논문에서는 보안 이웃 탐색 프로토콜의 가용성을 개선시키기 위해 CGA(Cryptographically Generated Addresses) 주소 생성 과정에서 해시 함수 입력에 MAC(Media Access Control) 주소를 추가하는 Modified CGA 기법과 캐시를 활용하는 방법을 제안하였으며, 실험을 통해 기존 방법과의 성능 차이를 비교하였다.
Abstract
Neighbor Discovery(ND) protocol is used to exchange an information of the neighboring nodes on the same link in the IPv6 protocol environment. For protecting the ND protocol, firstly utilizing Authentication Header(AH) of the IPsec protocol was proposed. But the method has some problems-uses of key exchange protocol is not available and it is hard to distribute manual keys. And then secondly the SEcure Neighbor Discovery(SEND) protocol which protects all of the ND message with digital signature was proposed. However, the digital signature technology on the basis of public key cryptography system is commonly known as requiring high cost, therefore it is expected that there is performance degradation in terms of the availability. In the paper, to improve performance of the SEND protocol, we proposed a modified CGA(Cryptographically Generated Address) which is made by additionally adding MAC(Media Access Control) address to the input of the hash function. Also, we proposed cache mechanism. We compared performance of the methods by experimentation.
참고문헌 (18)
- S. Deering, "Internet Protocol, Version 6 (IPv6) Specification”, RFC 2460", ~ (1998)
- R. Hinden, "IP Version 6 Addressing Architecture”, RFC 4291", ~ (2006)
- T. Narten, "Neighbor Discovery for IP Version 6 (IPv6)”, RFC 2461", ~ (1998)
- S. Thomson, "IPv6 Stateless Address Autoconfiguration”, RFC 2462", ~ (1998)
- A. Conta, "Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification”, RFC4443", ~ (2006)
- S. Kent, "IP Authentication Header”, RFC4302", ~ (2005)
- S. Kent, "IP Encapsulating Security Payload (ESP)”, RFC4303", ~ (2005)
- S. Kent, "Security Architecture for the Internet Protocol”, RFC4301", ~ (2005)
- C. Kaufman, "Internet Key Exchange (IKEv2) Protocol”, RFC4306", ~ (2005)
- T. Aura, "Cryptographically Generated Addresses (CGA)”. RFC 3972", ~ (2005)
- J. Arkko, "SEcure Neighbor Discovery (SEND)”, RFC 3971", ~ (2005)
- RSA Laboratories, "RSA Encryption Standard, Version 2.1" (2002), PKCS
- P.Nikander, "IPv6 Neighbor Discovery (ND) Trust Models and Threats”, RFC 3756", ~ (2004)
- "RDTSC--Read Time-Stamp Counter"[URL]
- "Intel Software Network-RDTSC Latency"[URL]
- 경계현, "IPv6 환경에서 해쉬 함수 기반 강건한 주소 생성 및 검증 기법", 정보보호학회논문지, 17(1), pp.115~120 (2007), 한국정보보호학회
- 안개일, "IPv6 네트워크에서 SEND 프로토콜의 구현", 한국통신학회논문지B, 32(7B), pp.403~410 (2007), 한국통신학회
