본문 바로가기
KERD
논문KCI 등재

일반화된 계층적 MIPv6 환경에서의 안전한 바인딩 업데이트 및 Fast Handover를 위한 인증 메커니즘

Authentication Mechanism for Secure Binding Update and Fast Handover in the Generalized Hierarchical MIPv6

0

조회

0

다운로드

0

인용

0

참고문헌

주제분류컴퓨터학

초록

본 논문에서는 일반화된 계층적 MIPv6 환경에서의 안전하고 효율적인 바인딩 업데이트 및 핸드오버 프로토콜을 제안한다. 기존의 계층적 MIPv6 환경에서의 바인딩 업데이트는 보편적으로 foreign network가 소규모 MAP 도메인으로 구성된다. 하지만, 제안 프로토콜에서는 다수의 MAP들이 계층적으로 구성되어지는 대규모 네트워크 환경에서의 안전하고 신속한 이동성 지원을 위한 메커니즘을 소개한다. 또한 다양한 공격 시나리오를 통해 제안 메커니즘의 안전성을 분석한다.

Abstract

In this paper, a secure and efficient binding update protocol as well as a handover protocol are proposed in the generalized hierarchical MIPv6 environment. Contrary to the conventional hierarchical MIPv6 environment where a foreign network is a small-scaled MAP domain, a large-scaled MAP domain consisting of several MAPs which are connected hierarchically is considered in the proposed protocol for the mechanism to support fast and secure mobility. It is also analyzed the security of the proposed protocol under the various attack scenarios.

참고문헌 (10)

  1. A. Jari, "Mobility Support in IPv6, RFC 3775", ~ (2004)
  2. B. Ludovic, "Hierarchical Mobile IPv6, RFC 4140" (2005)
  3. K. Rajeev, "Fast Handovers for Mobile IPv6, RFC 4068" (2005)
  4. H. Kang, "MIPv6 Binding Update Protocol Secure Against Both Redirect and DoS Attacks. CISC", Lecture Notes in Computer Science, 3822, pp.407~418 (2005), Springer-Verlag
  5. H. Wassim, "Combining Cryptographically Generated Address and Crypto-Based Identifiers to Secure HMIPv6, Internet Draft, draft-haddad-mipshop-hmipv6-security-06", ~ (2006)
  6. K. James, "Bootstrapping a Symmetric IPv6 Handover Key from SEND, Internet Draft, draft-kempf-mobopts-handover-key-01.txt. 2005", ~
  7. 김민경, "HMIPv6 환경에서의 안전한 Fast Handover를 위한 인증 메커니즘", 정보보호학회논문지, 17(3), pp.91~100 (2007), 한국정보보호학회
  8. C. Jaejuck, "Access Authentication Protocol in FMIPv6, Internet Draft, draft-jung- mipshop-access-auth-00.txt," (2006)
  9. S. Dmitry, "On the Performance of Enhanced Hierarchical Mobile IPv6", IEEE 16th International Symposium on Personal, Indoor and Mobile Radio Communications (2005)
  10. H. Mahtab, "A Handover Management Scheme for Mobile IPv6 Networks", IEEE Computer Communications and Networks, 2005 (2005)

관련 논문AI추천

이 간행물의 다른 논문 (7건)