본문 바로가기
KERD
논문KCI 등재

고속의 안전한 Proxy Mobile IPv6 인증 메커니즘

The Fast and Secure Authentication Mechanism for Proxy Mobile IPv6

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

Proxy Mobile IPv6(PMIPv6)의 이동성 지원을 위한 시그널링 메시지에 대한 적절한 보호대책 없이는 Mobile IPv6 (MIPv6)에서와 마찬가지로 리다이렉트(redirect) 공격, MITM(Man-In-The-Middle) 공격, 재생(replay) 공격, DoS(Denial of Service) 공격 등과 같은 다양한 보안공격에 노출된다. 본 논문에서는 PMIPv6와관련한 기존의 인증기법에 대한 연구의 문제점을 지적하고, PMIPv6에 적용가능한 신속하고 안전한 인증 메커니즘을 새로이 제안한다. 또한 제안기법과 기존연구의 비교를 통해 제안기법이 안전성과 효율성 측면에서 우수함을 보인다.

Abstract

Without a proper protection mechanism for the signaling messages to be used for the mobility support in the Proxy Mobile IPv6 (PMIPv6), it is also vulnerable to several security attacks such as redirect attack, MITM (Man-In-The-Middle) attack,replay attack and DoS (Denial of Service) attack as in Mobile IPv6. In this paper, we point out some problems of previous authentication mechanisms associated with PMIPv6, and also propose a new fast and secure authentication mechanism applicable to PMIPv6. In addition, it is also shown that the proposed one is more efficient and secure than the previous ones.

참고문헌 (19)

  1. D. Johnson, "Mobility support in IPv6", RFC 3775, ~ (2004)
  2. S. Gundavelli, "Proxy MobileIPv6", Internet Draft, draft-ietf-netlmmproxymip6-10.txt, IETF, ~ (2008)
  3. T. Aura, "Mobile IP security, security protocols, The 10th Int'l Workshop", LNCS, 2845, pp.17~19 (2002)
  4. T. Aura, "Securityof internet location management", InProc. of the 18th Annual Computer SecurityApplications Conference, pp.78~90 (2002)
  5. P. Nikander, "MobileIP version 6 route optimization securitydesign background", RFC 4225, ~ (2005)
  6. C. Vogt, "Security threats to network-based localized mobility management(NETLMM)", RFC 4832, ~ (2007)
  7. H. Zhou, "An authenticationmethod for proxy mobileIPv6 and performance analysis", Securityand Communication Networks, 2, pp.445~454 (2008)
  8. 문영성, "A Scheme to Reduce Packet Loss during PMIPv6 Handover considering Authentication", The 2008 International Conference on Computational Science and Its Applications (ICCSA 2008), pp.47~51 (2008), IEEE CS
  9. J.H. Lee, "Ticket-based authentication mechanismfor proxy Mobile IPv6 environment", The Third International Conference onSystems and Networks Communications2008, pp.304~309 (2008)
  10. J.W. Song, "One-time keyauthentication protocol for PMIPv6", Third 2008 International Conference onConvergence and Hybrid InformationTechnology, pp.1150~1153 (2008)
  11. J.H. Lee, "A traffic analysisof authentication methods for proxyMobile IPv6", 2008 International Conferenceon Information Security and Assurance, pp.512~517 (2008)
  12. H. Zhou, "A proxy Mobile Ipv6based global mobility management architectureand protocol", Mobile Networksand Applications (MONET), 15(4), pp.530~542 (2010)
  13. H. Krawczyk, "HMAC : keyed-hashing for message authentication", RFC 2104, ~ (1997)
  14. S.M. Baek, "A localized authentication,authoriza tion, and accounting (AAA)protocol for mobile hotspots", In Proceedingsof IEEE, 2006, 144~153
  15. R. Koodli, "Fast handovers for MobileIPv6", RFC 4068, ~ (2005)
  16. H. Yokota, "Fast handovers for proxyMobile IPv6", Internet Draft, draft-ietf-mipshop-pfmipv6- 14.txt, ~ (2010)
  17. "Web page of Krb Working Group"[URL]
  18. J. Laganier, "Interface between a proxyMIPv6 mobility access gateway and a mobilenode", Internet Draft, draft-ietf-netlmm-mn-ar-if-03, ~ (2008)
  19. W. Wang, "Intersystemlocation update and paging schemes formultitier wireless networks", In Proceedingsof International conference onMobile computing and networking (Mobi-Com), pp.99~109 (2000)

관련 논문AI추천

이 간행물의 다른 논문 (6건)