NARA: Network Architecture with Recursive Addressing
2
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
Abstract A network architecture based on recursive addressing is proposed. The Internet is modeled as a network of autonomous sites, each being a collection of nodes. Each site is named by a site address drawn from a global number space while each node is named by a node address drawn from a number space local to each site. Routing among sites depends solely on site addresses while that among nodes within each site on node addresses. Flat routing to render inherent mobility and cached routing as well as virtual routing to additionally cope with the table size are proposed. The model can recursively repeat itself both outwards and inwards in the network, enabling its applicability, for example, to inter-planetary as well as body area networks.
Abstract
Abstract A network architecture based on recursive addressing is proposed. The Internet is modeled as a network of autonomous sites, each being a collection of nodes. Each site is named by a site address drawn from a global number space while each node is named by a node address drawn from a number space local to each site. Routing among sites depends solely on site addresses while that among nodes within each site on node addresses. Flat routing to render inherent mobility and cached routing as well as virtual routing to additionally cope with the table size are proposed. The model can recursively repeat itself both outwards and inwards in the network, enabling its applicability, for example, to inter-planetary as well as body area networks.
참고문헌 (16)
- D. Meyer, "Report from the IAB Workshop on Routing and Addressing, RFC 4984, Sep. 2007", ~ (2007)
- A. Hinchley, "Issues in the Interconnection of Datagram Networks, IEN-1, Jul. 1977", IEN-1, ~ (1977)
- J. Shoch, "Inter-network Naming, Addressing, and Routing, IEN-19, Jan. 1978", ~ (1978)
- J. Saltzer, "On the Naming and Binding of Network Destinations, RFC 1498, Aug. 1993", ~ (1993)
- R. Moskowitz, "Host Identity Protocol( HIP) Architecture, RFC 4423, May 2006", ~ (2006)
- GSE - An Alternate Addressing Architecture for IPv6, "M. O'Dell", ~, pp.draft-ietf-ipngwg-gseaddr -00 (1997)
- R. Atkinson, "ILNP Architectural Description, RFC 6740, Nov. 2012", ~ (2012)
- V. Kafle, "An ID", locator Split Architecture for Future Networks, 2010, pp.48, 134~144
- D. Farinacci, "Locator", ID Separation Protocol (LISP), RFC 6830, Jan. 2013, 2013
- F. Templin, "The Internet Routing Overlay Network (IRON), RFC 6197, Mar., 2011", ~ (2011)
- Ivip (Internet Vastly Improved Plumbing) Architecture, "R. Whittle", ~, pp.draft-whittle-ivip-arch-04 (2010)
- R. Hinden, "New Scheme for Internet Routing and Addressing (ENCAPS) for IPNG, RFC 1955, Jun. 1996", ~ (1996)
- P. Frejborg, "Hierarchical IPv4 Framework, RFC 6306, Jul. 2011", ~ (2011)
- Network Architecture with Recursive Addressing, "D. Y. Kim", ~, pp.draftdykim-nara-03 (2014)
- M. Buddhikot, "MobileNAT: A New Technique for Mobility across Heterogeneous Address Spaces", Mobile Networks and Applications, 10(3), pp.289~302 (2005)
- A. Ford, "Architectural Guidelines for Multipath TCP Development, RFC 6182, Mar. 2011", ~ (2011)
