Design for Proximity Voice Chat System in Multimedia Environments
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
본 연구에서는 멀티미디어 환경에서 상호작용 시스템 중 하나인, 음성 대화 기술에 대하여 근접 음성 대화 시스템을 적용하는 솔루션을 제안한다. 사용자 아바타들 간 거리에 따라 음성의 볼륨을 조절하고, 가청 거리를 벗어난 사용자에게는 음소거를 적용하는 방식으로 멀티미디어 공간에서 여러 사용자 간의 음성 대화 방식을 설계하였다. 본 연구의 가장 큰 특징은 경제적인 개발을 위해, 거리를 기반으로 먼 거리에 있는 사용자에게는 저음질의 음성을 전달하고, 비 가청 지역에 들어선 사용자에게는 음성 데이터를 전송하지 않게 하는, reliable UDP 기반 능동적 서버 시스템에 있다. 제안 시스템은 사전에 완성하였던 유니티 게임 엔진 기반 프로젝트에서 성능을 측정하였으며, 본 연구에서 제안한 시스템을 메타버스 콘텐츠, 실시간 대전 액션 게임과 같이 여러 사용자 간 상호작용을 제공하는 환경에서 적극적으로 이용되는 것을 기대할 수 있다.
Abstract
In this paper, we propose a solution to apply a proximity voice dialog system to voice dialog technology, one of the interaction systems in multimedia environments. A voice dialog between multiple users in a multimedia space is designed by adjusting the volume of the voice according to the distance between the user avatars and muting the user who is beyond the audible distance. The main feature of this research is a reliable UDP-based active server system that delivers low-quality voice data to users who are far away based on distance and does not transmit voice data to users who enter the inaudible area for economic development. The performance of the proposed system was measured in a previously completed project based on the Unity game engine, and it is expected that the system proposed in this research will be actively used in environments that provide interaction between multiple users such as met averse content and real-time battle action games.
참고문헌 (12)
- Opus Codec, "Valin, J.M.", Internet Engineering Task Force, ~, pp.RFC 6716 (2012)
- Johnston, J.D., "Transform Coding of Audio Signals Using Perceptual Noise Criteria", IEEE Journal on Selected Areas in Communications, 6(2), pp.314~323 (1988)
- "Among Us: Enhancing Social Play with Proximity Voice Chat", Game Developer Conference (2021)
- "ITU-T Recommendation G.711. Pulse code modulation (PCM)of voice frequencies", International Telecommunication Union, ~ (1988)
- Perkins, C., "A Survey of Packet Loss Recovery Techniques for Streaming Audio", IEEE Network, 12(5), pp.40~48 (1998)
- Block-Wise Transfers in the Constrained Application Protocol(CoAP), "Bormann, C.", Internet Engineering Task Force, ~, pp.RFC 7959 (2016)
- Boutremans, C., "Adaptive Joint Playout Buffer and FEC Adjustment for Internet Telephony", INFOCOM 2003. Twenty-Second Annual Joint Conference of the IEEE Computer and Communications, 3, pp.652~662 (2003), IEEE Societies
- SIP : Session Initiation Protocol, "Salsano, S.", Internet Engineering Task Force, ~, pp.RFC 3261 (2002)
- WebRTC project, "WebRTC 1.0: Real-time Communication Between Browsers", W3C, ~ (2021)
- Among Us, "Among Us: A Study on Proximity Voice Chat Impact on Online Games", InnerSloth, ~ (2020)
- H. -N. Lee, "Analysis of Technical Trend for Scientific Networks", Proceedings of the Korea Information Processing Society Conference, pp.100~101 (2013)
- "OPUS"[URL]
