고속의 이동 IPv6를 위한 보안 프로토콜 연구
State of Art on Security Protocols for Fast Mobile IPv6
0
조회
0
다운로드
1
인용
0
참고문헌
키워드
초록
With the help of various Layer 2 triggers, Fast Handover for Mobile IPv6 (FMIPv6) considerably reduces the latency and the signaling messages incurred by the handover. Obviously, if not secured, the protocol is exposed to various security threats and attacks. In order to protect FMIPv6, several security protocols have been proposed. To our best knowledge, there is lack of analysis and comparison study on them though the security in FMIPv6 is recognized to be important. Motivated by this, we provide an overview of the security protocols for FMIPv6, followed by the comparison analysis on them. Also, the security threats and requirements are outlined before the protocols are explored. The comparison analysis result shows that the protocol presented by You, Sakurai and Hori is more secure than others while not resulting in high computation overhead. Finally, we introduce Proxy MIPv6 and its fast handover enhancements, then emphasizing the need for a proper security mechanism for them as a future work.
Abstract
With the help of various Layer 2 triggers, Fast Handover for Mobile IPv6 (FMIPv6) considerably reduces the latency and the signaling messages incurred by the handover. Obviously, if not secured, the protocol is exposed to various security threats and attacks. In order to protect FMIPv6, several security protocols have been proposed. To our best knowledge, there is lack of analysis and comparison study on them though the security in FMIPv6 is recognized to be important. Motivated by this, we provide an overview of the security protocols for FMIPv6, followed by the comparison analysis on them. Also, the security threats and requirements are outlined before the protocols are explored. The comparison analysis result shows that the protocol presented by You, Sakurai and Hori is more secure than others while not resulting in high computation overhead. Finally, we introduce Proxy MIPv6 and its fast handover enhancements, then emphasizing the need for a proper security mechanism for them as a future work.
참고문헌 (18)
- D. Johnson, "Mobility Support in IPv6", IETF RFC 3775, ~ (2004)
- R. Koodli, "Mobile IPv6 Fast Handovers", IETF RFC 5268, ~ (2008)
- H.Soliman, "Hierarchical Mobile IPv6(HMIPv6)Mobility Management", IETF RFC 5380, ~ (2008)
- J. Arkko, "Enhanced Route Optimization for Mobile IPv6", IETF RFC 4866, ~ (2007)
- R.H.Deng, "Defending against redirect attacks in mobile IP", Proc.of the 9th ACM conference on Computer and Communications Security, pp.59~67 (2002)
- I. You, "A Security Analysis on Kempf-Koodli's Security Scheme for Fast Mobile IPv6", IEICE Transaction on Communications, E92-B(06), pp.2287~2290 (2009)
- J. Kempf, "Distributing a Symmetric Fast Mobile IPv6 (FMIPv6) Handover Key Using SEcure Neighbor Discovery (SEND)", IETF RFC 5269, ~ (2008)
- W.Haddad, "Authenticating FMIPv6 Handovers", IETF Internet Draft,draft-haddad-mipshopfmipv6-auth-02, ~ (2006)
- V. Narayanan, "Establishing Handover Keys using Shared Keys", IETF Internet Draft, draft-vidya-mipshop-handover-keys-aaa-04, ~ (2007)
- I.You, "An Enhanced Security Protocol for Fast Mobile IPv6", IEICE Transaction on Information & Systems, E92-D(10), pp.1979~1982 (2009)
- J.Arkko, "SEcure Neighbor Discovery(SEND)", IETF RFC 3971, ~ (2005)
- T.Aura, "Cryptographically Generated Addresses(CGA)", IETF RFC 3972, ~ (2005)
- F.Dupont, "AAA for mobile IPv6", IETF Internet Draft,draft-dupont-mipv6-aaa-01, ~ (2001)
- S.Kiriyama, "Context Reflector for Proxy Mobile IPv6", Proc.of 2009 International Conference on Complex,Intelligent and Software Intensive Systems, pp.588~594 (2009)
- S.Gundavelli, "Proxy Mobile IPv6", IETF RFC 5213, ~ (2009)
- H.Yokota, "Fast Handovers for Proxy Mobile IPv6", IETF Internet Draft,draft-ietf-mipshop-pfmipv6-12, ~ (2009)
- Y. Han, "A Fast Handover Scheme in Proxy Mobile IPv6", IETF Internet Draft, draft-han-netlmm-fast-pmipv6-00, ~ (2008)
- C.Vogt, "Security Threats to Network-Based Localized Mobility Management(NETLMM)", IETF RFC 4832, ~ (2007)
