고속 다중 경로 네트워크에서 동적 대역폭 인식혼잡제어(DBAC)를 통한 전송 효율 최적화
Optimizing Transmission Efficiency with Dynamic Bandwidth Aware Congestion Control (DBAC) in High-Speed Multipath Networks
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
본 논문은 다중 경로를 사용해야 하는 현대 네트워크 환경에서 데이터 전송 효율을 향상시키기 위한 새로운 혼잡 제어 알고리즘인 동적 대역폭인식 혼잡 제어(DBAC)를 제안한다. 전통적인 단일 경로 TCP는 한계가 있어 다중 경로 TCP(MPTCP)가 여러 경로를 동시에 활용하여 대역폭을극대화하고 전송 신뢰성을 향상시키지만, MPTCP는 경로 특성의 비대칭성으로 인해 고속 장거리 네트워크에서 성능 저하를 겪는다. 이를 해결하기위해 DBAC는 BDP가 큰 경로에는 TCP CUBIC을, 일반 경로에는 LIA를 결합하여 자원 활용과 공정성을 최적화한다. 실험 결과, DBAC는 자원활용과 전송 성능을 크게 향상시켜, 기존 LIA가 20% 미만의 대역폭을 사용하는 것에 비해 높은 BDP 경로에서 80% 이상의 대역폭을 효과적으로사용하는 것으로 나타났다
Abstract
This paper proposes a new congestion control algorithm, Dynamic Bandwidth Aware Congestion Control (DBAC), to enhance datatransmission efficiency in modern network environments that require the use of multiple paths. Traditional single-path TCP has limitationsthat are addressed by Multipath TCP (MPTCP), which can utilize multiple paths simultaneously to maximize bandwidth and improvetransmission reliability. However, MPTCP suffers performance degradation in high-speed, long-distance networks due to path characteristicasymmetry. To overcome this, DBAC combines TCP CUBIC for paths with high BDP and LIA for regular paths, optimizing resource utilizationand fairness. Experimental results show that DBAC significantly improves resource utilization and transmission performance, effectivelyusing over 80% of the bandwidth on high BDP paths, compared to less than 20% with traditional LIA.
참고문헌 (10)
- V. Jacobsen, "Congestion avoidance and control", ACM CCR, 18(4), pp.314~329 (1995)
- T. Henderson, "The NewReno modification to TCP’s fast recovery algorithm", RFC 6582, Internet Engineering Task Force, ~ (2012)
- A. Ford, "TCP extensions for multipath operation with multiple addresses", RFC 6824, Internet Engineering Task Force, ~ (2013)
- C. Raiciu, "Coupled congestion control for multipath transport protocols", RFC 6356, Internet Engineering Task Force, ~ (2011)
- R. Khalili, "Opportunistic linkedincreases congestion control algorithm for MPTCP" (2014), IETF
- I. Rhee, "CUBIC for fast long-distance networks", RFC 8312, Internet Engineering Task Force, ~ (2018)
- N. R. Thakur, "IOT with Smart Systems. Smart Innovation, Systems and Technologies, Vol.312" (2023), Springer
- L. Chao, "A brief review of multipath TCP for vehicular networks", Sensors, 21(8), pp.2793~ (2021)
- M. Aljubayri, "Reduce delay of multipath TCP in IoT networks", Wireless Netw, 27, pp.4189~4198 (2021)
- M. Chen, "A multi-parameter comprehensive optimized algorithm for MPTCP networks", Electronics, 10(16), pp.1942~ (2021)
