NGN에서의 QoS 정보요소 매핑 및 Rs/Rw 인터페이스의 자원제어 프로토콜 구현
Mapping of QoS Information Elements and Implementation of Rs/Rw Interface Resource Control Protocols in NGN
0
조회
0
다운로드
1
인용
0
참고문헌
키워드
초록
NGN은 QoS가 지원되는 광 대역 전달 망에서 세션 및 비-세션 서비스를 지원하기 위한 패킷 기반의 융합 망이다. NGN에서 네트워크 사용자에 따라 차별화된 서비스를 제공하기 위해서는 QoS 기반 자원제어가 이루어져 한다. 본 논문에서는 DIAMETER를 이용하는 Rs 인터페이스의 자원제어 프로토콜을 설계 및 구현하였으며 NGN에서 QoS 기반 자원제어를 위하여 DIAMETER 정보요소와 세션제어 프로토콜인 SIP의 SDP 속성들의 매핑방안을 제시하였다. Rs 인터페이스와의 연동 용이성과 다양한 기능성을 고려하여 ITU-T에서 제시한 자원제어 프로토콜 중에서 Rw 인터페이스는 DIAMETER를 이용하는 자원제어 프로토콜을 구현하였다. 또한, 서비스 층에서 전송 층으로 자원제어를 위하여 Rs와 Rw 인터페이스 사이의 메시지 및 정보요소의 매핑방안을 제시하였다. 본 논문에서 제시한 QoS 정보요소의 매핑 방안과 Rs와 Rw 인터페이스의 연동 방안을 이용하여 차별화된 전송 서비스를 제공하는 NGN 자원제어 테스트-베드를 구축하였다.
Abstract
NGN is a packet-based converged network to support session and non-session services in QoS-enabled broadband transport network. QoS based resource control must be defined to support differentiated services for various network users in NGN. We designed and implemented DIAMETER protocol as the Rs interface, and also defined mapping rules between DIAMETER information elements and SDP(Session Description Protocol) attributes for QoS based resource control in NGN. We selected and implemented DIAMETER protocol among alternate resource control protocols in ITU-T as the Rw interface because of simple interworking method with Rs interface and adequate AAA functionality. We defined mapping rules of messages and information elements between Rs and Rw interfaces for resource control from a service layer to a transport layer. Based on the mapping rule of QoS information elements and the interworking method between Rs and Rw interfaces, we built up a test-bed that support differentiated delivery services.
참고문헌 (22)
- Keith, Knightson, "NGN Architecture: Generic Principles, Functional Architecture, and Implementation", IEEE Communications Magazine, 43(10), pp.49~56 (2005)
- 신상철, "BcN 동향 2004" (2004), 한국전산원
- "ITU-T Draft Document, TD 161 (PLEN", 11) “WP 2, pp.2008, ~
- P. Calhoun, "“Diameter Base Protocol,” IETF RFC 3588, September 2003", ~ (2003)
- "ITU-T Draft Document, “Initial draft Recommendation Q.3301.1 Rs version 2, Protocol at the interface between service control entities and the Policy Decision Physical Entity (PD-PE) (Rs interface),” Geneva, 23-27 April 2007", ~ (2007)
- "ITU-T Draft Document, “Draft Recommendation Q.3303.1, Protocol at the interface between a Policy Decision Physical Entity (PD-PE) and a Policy Enforcement Physical Entity (PE-PE) (Rw interface):COPS Alternative,” Geneva, 23-27 April 2007", ~ (2007)
- "ITU-T Draft Document, “Draft Recommendation Q.3303.2, Protocol as the interface between a Policy Decision Physical Entity (PD-PE) and Policy Enforcement Physical Entity (PE-PE) (Rw interface):H.248 Alternative,” Geneva, 23-27 April 2007", ~ (2007)
- "ITU-T Draft Document, “Draft Recommendation Q.3303.3, Protocol as the interface between a Policy Decision Physical Entity (PD-PE) and Policy Enforcement Physical Entity (PE-PE) (Rw interface):Diameter Alternative,” Seoul, 16-23 January 2008", ~ (2008)
- M. Handley, "SIP : Session Initiation Protocol,” IETF RFC 2543, March 1999", ~ (1999)
- J. Rosenberg, "SIP : Session Initiation Protocol,” IETF RFC 3261, June 2002", ~ (2002)
- M. Handley, "“SDP : Session Description Protocol,”IETF RFC 4566, July 2006", ~ (2006)
- SBLAKE, "“An Architecture for Differentiated Service”, RFC2475, December 1998", ~ (1998)
- ,” Geneva, 17-28 July 2006, , 2006
- "ITU-T Draft Document, “Draft Recommendation Y.RACF (Y.2111) Release2 (Version 0.4.0),” Beijing, 10-21 September 2007", ~ (2007)
- "ETSI TISPAN NGN Document, ETSI TS 183 017: “Telecommunications and Internet Converged Services and Protocols for Advanced Networking (TISPAN); Resource and Admission Control: DIAMETER protocol for session based policy set up information exchange between the Application Function (AF) and the Service Policy Decision Function (SPDF);Protocol specification”, in WG 3", ~
- 이동규, "NGN 기반의 엑세스 망에서 자원제어 시스템 구현", 대한전자공학회 하계종합학술대회 논문집 I, 통권 : 30, pp.167~168 (2007)
- TaeMan, Han, "Management Information Model And High-Speed Resource Control Mechanism For Next Generation Network" (2007), CSN
- "3GPP TS 29.208 V6.7.0 (Release 6), “End-to-end Quality of Service (QoS) signaling flow,” June 2007", ~ (2007)
- "ITU-T Recommendation Y.1541, “Network performance objectives for IP-based services,” February, 2006", ~ (2006)
- 박승철, "광대역 접속망에서 SIP QoS 지원 방안", 정보과학회논문지 : 정보통신, 34(1), pp.73~80 (2007), 한국정보과학회
- [URL]
