본문 바로가기
KERD
논문KCI 등재

차세대네트워크 환경에서 서비스 등급 및 사용자 환경에 따른 차별화된 QoS를 지원하는 오버레이 멀티캐스트

Overlay Multicast Mechanism Supporting Differentiated QoS According to Service Level and User Environment over NGN

0

조회

0

다운로드

1

인용

0

참고문헌

키워드

주제분류공학

초록

차세대네트워크(Next Generation Network, NGN)은 하부의 전송 매체와 상관없이 데이터 전송의 품질을 보장하는 광대역망으로 NGN에서 주요 서비스로 대두되고 있는 실시간 방송 서비스 등은 멀티캐스트 기법을 필요로 하고 있다. 그러나 기존의 IP 멀티캐스트는 실제로 적용되기에는 많은 제약점을 지니고 있다. 이를 해결하기 위한 오버레이 멀티캐스트는 IP 멀티캐스트를 대신해 유연성과 확장성을 제공하여 효과적인 멀티미디어 멀티캐스트 전송을 가능하게 하는 기술로 활발히 연구 중에 있는 가상 네트워크다. 본 연구에서는 각 수신자가 속해있는 목적지 네트워크에 에이전트를, 미디어 서버가 위치한 소스 네트워크에는 전체 오버레이 멀티캐스트 토폴로지를 관리하는 매니저를 설계하였다. 매니저와 에이전트는 서로 통신하면서 네트워크의 자원 상태를 기반으로 한 서비스 제공을 수행하는 역할을 담당한다. 이렇게 함으로써 NGN 환경에서 QoS를 보장하는 멀티캐스트 환경을 제공할 수 있으며 이는 NGN 구조의 품질관리 기능인 RACF(Resource and Admission Control Functions)를 기반으로 한다.

Abstract

NGN(Next Generation Network) is a communication network which can make use of broadband and QoS-enabled transport technologies. One of the main service issues over NGN is a multimedia service, such as IPTV, using a multicast method. And overlay multicast technology is one of the promising solutions instead of traditional multicast technology which has a few problems, and supports flexibility and scalability for multicast services. Also, the main controversial topic in NGN and overlay multicast is QoS. In the present paper, we designed an agent in each receiver’s network, and a manager which is in a source network and which manages the whole multicast network. Both of them are communicating with each other and applying resource policies to their multicast network. This mechanism enables overlay multicast to support QoS, focusing on RACF(Resource and Admission Control Functions) in NGN QoS architecture.

참고문헌 (20)

  1. "ITU-T, Y.2111 “Resource and Admission Control Functions”", ~
  2. 송종태, "“자원 및 수락 제어를 중심으로 본 NGN QoS 제어 기술동향”, IPTV + NGN 컨버전스 특집, pp.65-70, 2006 9", ~ (2006)
  3. T. Murase, "“Overlay Network Technologies for QoS Control,” IEICE TRANS. COMMUN., VOL.E89–B, NO.9, SEPTEMBER, 2006", ~ (2006)
  4. Yunxi Sherlia Shi, "Design of Overlay Networks for Internet Multicast" (2002), Dissertation presented to the Sever Institute of Washington University
  5. Z. Li, "Hostcast: A new overlay multicasting protocol", Proceeding of IEEE International Conference on Communications (2003)
  6. "한국인터넷진흥원 IPv6 포탈, http:", pp.0000, ~
  7. Heiko, Schwarz, "Overview of the Scalable H.264", MPEG-AVC Extension, 2007, pp.17(9), 1103~1120
  8. Cheon-Seog, Kim, "Quality Metric for H.264", AVC Scalable Video Coding with Full Scalability, 2007, pp.통권 : 6492, 64921~
  9. R. Presuhn, "“Management Information Base (MIB) for the Simple Network Management Protocol (SNMP),” RFC3418, IETF, December, 2002", ~ (2002)
  10. 이호영, "IPv6 오버레이 멀티캐스트 시스템", 한국 컴퓨터종합학술대회 논문집, 33(1(D),), pp.10~12 (2006)
  11. E. Park, "“Scalable and Reliable Overlay Multicast Network for Live Media Streaming,” Lecture Notes in Computer Science of Springer (LNCS3768), Vol.2, pp.48-58, November, 2005", ~ (2005)
  12. D. Awduche, "“Requirements for Traffic Engineering Over MPLS,” RFC 2702, September, 1999", ~ (1999)
  13. G. Almes, "“A One-way Packet Loss Metric for IPPM,” RFC2680, IETF, September, 1999", ~ (1999)
  14. G. Almes, "“A One-way Delay Metric for IPPM,” RFC2679, IETF, September, 1999", ~ (1999)
  15. H. Schulzrinne, "“RTP: A Transport Protocol for Real-Time Applications,” RFC3550, IETF, July, 2003", ~ (2003)
  16. 이철희, "IPTV 서비스의 E2E QoE", OSIA standards & technology review, 27(1)통권 : 65, pp.66~70 (2007)
  17. 한국정보사회진흥원, "“BcN 환경에서의 자원관리 기능을 활용한 품질 측정 방안 연구”, NIA II-PER-06041, 2006, 10", ~ (2006)
  18. "광대역통합네트워크"[URL]
  19. "OMNeT++ version 3.3"[URL]
  20. "PSNR 뷰어"[URL]

관련 논문AI추천

이 간행물의 다른 논문 (14건)