IP 방송 환경을 고려한 MMT기반 효율적 콘텐츠 전송 및 소비 플랫폼 구현
Development of Contents Delivery and Consumption Platform Using MMT in IP Broadcasting Environments
1
조회
0
다운로드
2
인용
0
참고문헌
키워드
초록
방송 서비스의 방식이 아날로그 방송 서비스에서 디지털 방송 서비스로 전환되어짐에 따라 디지털 방송 미디어 전송기술로 국제표준 기구인 MPEG에서 개발한 MPEG-2 TS가 사용되어 왔다. 이와 더불어, 통신망의 디지털화 및 최근 스마트폰의 보급화에 따라 IP망을 통한 서비스가 급증하게 되었다. 이와 같은 방송과 통신 서비스의 디지털화와 IP 기반 전송 환경의 확대에 따라, 통신 및 방송 서비스를 함께 사용하는 하이브리드 서비스가 새롭게 주목받고 있다. 그러나, 방송 서비스에서 활용하는 MPEG-2 TS는 방송 서비스에 최적화 되어있기 때문에 IP 환경에 적용하기에는 비효율적인 측면이 다수 존재하고 있기에, 하이브리드 전송 환경에 적합한 새로운 전송기술 표준이 요구되었다. MPEG Media Transport (MMT)는 방송망 및 IP 기반의 통신망을 활용하여 미디어 데이터를 기존의 방식보다 효율적으로 전송하고 저장 및 소비 할 수 있게 하기 위해 MPEG에서 개발 중인 표준이다. MMT에서는 방송프로그램을 하나의 Package로 정의하고, 해당 Package에서는 비디오, 오디오 및 데이터를 포함한 다양한 구성요소를 각각의 Asset으로 정의하고 있으며, 각 Asset은 재생 및 저장의 최소단위인 MPU (Media Processing Unit) 파일들의 논리적 집합으로 구성되어 있다. 또한, MPU파일을 전송하기 위하여 고유의 전송 프로토콜인 MMTP(MMT Protocol)을 정의하였으며, 해당 파일 또는 Package의 구성 정보를 Signaling을 통해 전송하도록 고안되었다. 본 논문에서는 MMT에서 정의한 규격을 기반으로 보다 효율적으로 콘텐츠를 생성하고 이를 전송 및 소비하는 플랫폼을 제안하고 검증하였다.
Abstract
Since a broadcasting system was changed from analog broadcasting system to digital one, MPEG-2 TS has been used for digital broadcasting media transportation. Furthermore, as communication networks are digitalized and smartphones are becoming widespread, IP network-based services are rapidly increased. This situation brings up a new hybrid broadcasting service, which combines broadcast and communication into a new service framework as a next generation of the multimedia delivery system. However, the MPEG-2 TS was optimized only for the broadcast services, not for a hybrid delivery. Recently, ISO/IEC SC29 WG11 has published the new standard called as “MPEG Media Transport (MMT)” for media delivery and encapsulation to full-fill the requirement of hybrid digital broadcasting environment. MMT allows broadcasters to move to IP environment without losing the major advantages of MPEG-2 TS. MMT defines one broadcasting program as a Package, which includes an Asset which is composed of various media components such as video, audio, data. Also, each Asset is a logical set of MPU files, which is a minimum unit of decoding and storage. MMT also defines a protocol called as MMTP to delivery MPU files, and defines signalling messages to transmit a file or Package composition informations. In this paper we present the multimedia platform for the efficient content generation, delivery and consumption which were defined by the MMT.
참고문헌 (13)
- 권호영, "IPTV의등장으로인한유료방송시장의 변화", 한국방송영상진흥원, ~ (2008)
- "ISO", IEC 13818-1, Information Technology - Generic Coding of Moving Pictures and Associated Audio Information : Part 1 Systems, 2007
- 임영권, "MMT, 차세대 방송 및 인터넷멀티미디어 전송 서비스를 위한 새로운 대안", 한국통신학회지(정보와 통신), 30(5), pp.7~ (2013)
- "ISO", IEC 14496-12, Information technology-Coding of audio-visual objects-Part 12: ISO base media file format, 2008
- "ISO", IEC 14496-14: Information technology -Coding of audio visual objects - Part 14: MP4file format, 2003
- "ISO", IEC 23009-1: Dynamic Adaptive Streaming over HTTP, 2011
- H. Schulzrinne, "Real-time transport protocol", IETF RFC 3550, IETF, Jul. 2003, ~ (2003)
- H. Schulzrinne, "Real Time Streaming Protocol (RTSP)", IETF RFC 2326, ~ (1998)
- R. Fielding, "IETF RFC 2616: Hypertext Transfer Protocol -HTTP", 1.1, 1999
- "Uses Cases for MPEG Media Transport (MMT)", ISO, SC29, pp.WG11, N11542[DOI]
- "Context and Objectives on MPEG Media Transport (MMT)", ISO, SC29, pp.WG11, N11539[DOI]
- "Requirements on MPEG Media Transport (MMT)", ISO, SC29, pp.WG11, N11540[DOI]
- "ISO", IEC JTC1, WG11 Text of ISO, pp.IEC FDIS 23008-1 MPEG Media Transport, ISO, IEC JTC1[DOI]
