본문 바로가기
KERD
논문KCI 등재

A Technique to Enable the Corruption-aware Transport Protocols in Realistic Networks

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

The traditional reliable transport protocols are originally designed for the wired networks, which regard any packet losses as the indication of network congestion and halve their congestion windows to alleviate the traffic overload of network. However, unlike in wired networks, non-congestion losses will severely degrade the performance of traditional transport protocols in wireless networks. Thus some corruption-aware transport protocols have been proposed to overcome the performance degradation caused by corruption. Unfortunately, the corruption-aware transport protocols cannot work in realistic networks up to now since the corrupted packets have been discarded by the link layer checksum mechanisms before they are delivered to transport layer. This paper proposes a technique to overcome this problem without disabling the link layer checksum mechanisms. Simulation results show that the performance of corruption-aware transport protocols are still far better than that of traditional ones while the proposed scheme is applied.

Abstract

The traditional reliable transport protocols are originally designed for the wired networks, which regard any packet losses as the indication of network congestion and halve their congestion windows to alleviate the traffic overload of network. However, unlike in wired networks, non-congestion losses will severely degrade the performance of traditional transport protocols in wireless networks. Thus some corruption-aware transport protocols have been proposed to overcome the performance degradation caused by corruption. Unfortunately, the corruption-aware transport protocols cannot work in realistic networks up to now since the corrupted packets have been discarded by the link layer checksum mechanisms before they are delivered to transport layer. This paper proposes a technique to overcome this problem without disabling the link layer checksum mechanisms. Simulation results show that the performance of corruption-aware transport protocols are still far better than that of traditional ones while the proposed scheme is applied.

참고문헌 (16)

  1. W. R. Stevens, "TCP Slow Start, Congestion Avoidance, Fast Retransmit, and Fast Recovery Algorithms", IETF, RFC 2001 (1997)
  2. Stream control transmission protocol, "R. Stewart", ~, pp.IETF, RFC 2960 (2000)
  3. D. Aguayo, "Link-level Measurements from an 802.11b Mesh Network", Proceedings of the SIGCOMM 2004 (2004)
  4. O. Tickoo, "LT-TCP: End-to-End Framework to Improve TCP Performance over Networks with Lossy Channels", Proceedings of the 13th IEEE International Workshop on Quality of service (IWQoS) (2005)
  5. R. K. Balan, "TCP HACK: TCP Header Checksum Option to Improve Performance over Lossy Links", Proceedings of the IEEE INFOCOM 2001, 1, pp.309~318 (2001)
  6. L. Cui, "Adaptive Increase and Adaptive Decrease Algorithm for Wireless TCP", in Proceedings of the ICNC2007, 2, pp.392~398 (2007)
  7. ''Datagram Congestion Control Protocol, "E. Kohler", ~, pp.IETF, RFC 4340 (2006)
  8. C. P. Fu, "''TCP Veno: TCP Enhancement for Transmission Over Wireless Access Networks" (2003), IEEE Journal on Selected Areas in Communications
  9. "TCP - Modules for ns2 from"[URL]
  10. A. Leon-Garcia, "Communication Networks: Fundamental Concepts and Key Architectures" (2000), McGraw-Hill
  11. Bakre, "I-TCP: Indirect TCP for Mobile Hosts", pp.136~143 (1995), Proceedings of the ICDCS
  12. E. Amir, "Efficient TCP over Networks with Wireless Links", Proceedings of the 5th Workshop on Hot Topics in Operating Systems, pp.35~41 (1995)
  13. H. Balakrishnan, "Explicit loss notification and wireless web performance" (1998), in Proceedings of the IEEE Globecom Internet Mini-Conference
  14. T. Goff, "Freeze- TCP: A True End-to-end TCP Enhancement Mechanism for Mobile Environments", Proceedings of the IEEE INFOCOM, pp.1537~1545 (2000)
  15. S. Mascolo, "TCP Westwood: End-to-end bandwidth estimation for efficient transport over wired and wireless networks", Proceedings of the ACM Mobicom 2001, pp.287~297 (2001)
  16. R. Ferorelli, "Live Internet Measure-ments Using Westwood+ TCP Congestion Control", Proceedings of the IEEE GLOBECOM 2002, 통권 : 3, pp.2583~2587 (2002)

관련 논문AI추천

이 간행물의 다른 논문 (13건)