A Cross-layer Approach for Throughput Enhancement of Unsteady Satellite Networks
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
As a feasible mechanism against link-layer errors, Forward Error Correction (FEC) scheme has been suggested for satellite channel. However, the existing FEC scheme cannot lead to the optimal throughput gain of TCP when a satellite link is in an unsteady state. In particular, if FEC applies a larger amount of redundancy to recover the most corrupted packets, too much bandwidth has to be consumed to send the overlarge redundant information. On the contrary, if FEC uses a lower amount of redundancy in order to fully utilize the available bandwidth to send the more user data, a higher residual packet loss rate will be incurred. This paper introduces an effective cross-layer approach to overcome the drawbacks of the existing scheme. In the scheme, a maximum header scope is defined to cover all protocols’ headers of every MAC frame, and the FEC decoder only identifies the integrity of the header scope and leaves the validation of frame payload to TCP. Thus a lower amount of redundancy can be used to significantly reduce the residual packet loss rate as well as the unnecessary consumption of the available bandwidth. Simulation result shows that the proposed scheme can significantly reduce the throughput jitter of TCP while the satellite link is in an unsteady state or when a non-optimal amount of redundancy is applied by FEC, compared to the existing approaches.
Abstract
As a feasible mechanism against link-layer errors, Forward Error Correction (FEC) scheme has been suggested for satellite channel. However, the existing FEC scheme cannot lead to the optimal throughput gain of TCP when a satellite link is in an unsteady state. In particular, if FEC applies a larger amount of redundancy to recover the most corrupted packets, too much bandwidth has to be consumed to send the overlarge redundant information. On the contrary, if FEC uses a lower amount of redundancy in order to fully utilize the available bandwidth to send the more user data, a higher residual packet loss rate will be incurred. This paper introduces an effective cross-layer approach to overcome the drawbacks of the existing scheme. In the scheme, a maximum header scope is defined to cover all protocols’ headers of every MAC frame, and the FEC decoder only identifies the integrity of the header scope and leaves the validation of frame payload to TCP. Thus a lower amount of redundancy can be used to significantly reduce the residual packet loss rate as well as the unnecessary consumption of the available bandwidth. Simulation result shows that the proposed scheme can significantly reduce the throughput jitter of TCP while the satellite link is in an unsteady state or when a non-optimal amount of redundancy is applied by FEC, compared to the existing approaches.
참고문헌 (16)
- Zhu, J, "Performance modelling of TCP enhancements in terrestrial-satellite hybrid networks", IEEE, 2006, pp.14(4), 753~766
- Xu K, "TCP-Jersey for wireless IP communications", IEEE Journal on Selected Areas in Communications, 22(4), pp.747~756 (2004)
- M. Allman, "''Enhancing TCP Over Satellite Channels using Standard Mechanisms,'' RFC 2488, Jan", ~ (1999)
- R. Ferorelli, "Live Internet Measure-ments Using Westwood+ TCP Congestion Control", proceeding of GLOBECOM '02. IEEE, 통권 : 3, pp.2583~2587 (2002)
- M. Mathis, ""TCP selective acknowledgment and options," RFC 2018, IETF, Oct", ~ (1996)
- I. F. Akyildiz, "TCPPeach: A new congestion control scheme for satellite IP networks", IEEE, 2001, 307~321
- C. Barakat, "Bandwidth tradeoff between TCP and link-level FEC", Computer Networks, 39(5), pp.133~150 (2002)
- B. Liu, "TCP-cognizant adaptive forward error correction in wireless networks", proceeding of IEEE GLOBECOM'02, 통권 : 3, pp.17~21 (2002)
- "Network Simulator (ns-2)"[URL]
- Balan, R.K., "TCP HACK: TCP Header Checksum Option to Improve Performance over Lossy Links", Proc. IEEE INFOCOM 2001, 통권 : 1, pp.309~318 (2001)
- L. Cui, "Adaptive Increase and Adaptive Decrease Algorithm for Wireless TCP", The 3rd International Conference on Natural Computation (ICNC'07), 통권 : 2, pp.392~398 (2007)
- A quantitative measure of fairness and discrimination for resource allocation in shared computer systems, "R. Jain", ~, pp.DEC, Res. Rep.TR-301 (1984)
- K. K. Ramakrishnan, "LT-TCP: End-to-End Framework to Improve TCP Performance over Networks with Lossy Channels", proceedings of IEEE 13th International Workshop on Quality of service (IWQoS), pp.21~23 (2005)
- K.K. Ramakrishnan, ""The Addition of Explicit Congestion Notification (ECN) to IP," IETF RFC 3168, Sep", ~ (2001)
- C. Barakat, "Analysis of link-level hybrid FEC", ARQ-SR for wireless links and long-lived TCP traffic, 2004, pp.57(4), 423~500
- L. Baldantoni, "Adaptive End-to-End FEC for Improving TCP Performance over Wireless Links", proceeding of ICC 2004 (2004)
