본문 바로가기
KERD
논문KCI 등재

트래픽관리 성능측정 방법론 분석

An Analysis of Benchmarking Methodology for Traffic Management

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

IETF BMWG 워킹그룹에서는 인터네트워킹, 네트워크 장치, 시스템, 서비스 등의 품질특성, 측정과 관련된다수의 권고안들을 제정하고 있다. RFC 7640에서는 네트워크 장비들의 트래픽관리 기능에 대한 성능시험 방법에 대하여 정의하고 다루고 있으며, 또한 트래픽 분류, 폴리싱, 큐잉/스케쥴링, 쉐이핑 기능의 성능에 대하여 규정하고 트래픽관리 기능들의 시험평가에 대한 프레임워크와 파라미터, 시험절차들에 대하여 제시하고있다.

Abstract

The Benchmarking Methodology Working Group (BMWG in IETF) will continue to produce a series of recommendations concerning the key performance characteristics of internetworking technologies, or benchmarks for network devices, systems, and services. RFC 7640 discusses and defines a practical methodology for benchmarking the traffic management capabilities of networking devices. Also, it defines the methods to characterize the capacity of the following traffic management features in network devices: classification, policing, queuing/scheduling, and traffic shaping. It provides a framework to conduct repeatable traffic management benchmarks for devices and systems. And, this framework can also be used as a test procedure to assist in the tuning of traffic management parameters of benchmark for devices and systems.

참고문헌 (17)

  1. "IETF WG introduction" (2015)[URL]
  2. Bradner, S., "Benchmarking Methodology for Network Interconnect Devices", RFC 2544, ~ (1999)
  3. Mandeville, R., "Benchmarking Methodology for LAN Switching Devices", RFC 2889, ~ (2000)
  4. Popoviciu, C, "IPv6 Benchmarking Methodology for Network Interconnect Devices", RFC 5180, ~ (2008)
  5. Dunn, "Methodology for ATM Benchmarking", RFC 3116, ~ (2001)
  6. Hickman, "Benchmarking Methodology for Firewall Performance", RFC 3511, ~ (2003)
  7. Stopp, "Methodology for IP Multicast Benchmarking", RFC 3918, ~ (2004)
  8. Manral, "Benchmarking Basic OSPF Single Router Control Plane Convergence", RFC 4061, ~ (2005)
  9. Akhter, "MPLS Forwarding Benchmarking Methodology for IP Flows", RFC 5695, ~ (2009)
  10. Poretsky, "Benchmarking Methodology for Link-State IGP Data-Plane Route Convergence", RFC 6413, ~ (2011)
  11. C. Davids, "Methodology for Benchmarking Session Initiation Protocol (SIP) Devices:Basic Session Setup and Registration", RFC 7502, ~ (2015)
  12. B. Constantine, "Traffic Management Benchmarking", RFC 7640, ~ (2015)
  13. L. Avramov, "Data Center Benchmarking Methodology", Internet Draft, ~ (2015)
  14. T.Kim, "Considerations for Benchmarking High Availability of NFV Infrastructure", Internet Draft, ~ (2015)
  15. Anton Basil, "Benchmarking Methodology for SDN Controller Performance", Internet Draft, ~ (2015)
  16. A. Morton, "Considerations for Benchmar -king Virtual Network Functions and Their Infrastructure", Internet Draft, ~ (2015)
  17. "3rd Generation Partnership Project 2, “cdma2000 Evaluation Methodology”, Version 1.0, Revision A" (2009)[URL]

관련 논문AI추천

이 간행물의 다른 논문 (3건)