본문 바로가기
KERD
논문KCI 등재

RFC 3511방화벽 성능측정 방법론 분석

Analysis of Benchmarking Methodology for Firewall Performance(RFC 3511)

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

IETF에서는 여러 영역으로 나누고 주제별로 WG과 BOF를 구성하여 인터넷 표준규격을 개발하여 배포하고 있다. BMWG 워킹그룹에서는 인터네트워킹, 네트워크 장치, 시스템, 서비스 등의 품질특성, 측정과 관련된다수의 권고안들을 제정하고 있다. RFC 3511은 4개(전송, 접속, 지연, 필터링)영역에서 10개의 방화벽 성능시험 항목을 다루고 있으며, 해당표준(RFC 3511)은 방화벽 성능측정시 가이드 라인으로 활용할 수 있다. 본 논문에서는 RFC 3511을 시험방법들을 분석하고, IP throughput, concurrent connection, connection throughput 항목에 대하여 시험을 실시하고 결과를 분석하였다.

Abstract

The Internet Engineering Task Force (IETF) develops and promotes Internet standards(a guideline, standards specification, etc). The IETF is organized into a large number of working groups and informal discussion groups (BoF)s, each dealing with a specific topic. The Benchmarking Methodology Working Group (BMWG) will continue to produce a series of recommendations concerning the key performance characteristics of internetworking technologies, or benchmarks for network devices, systems, and services. RFC 3511 discusses and defines a number of tests that may be used to describe the performance characteristics of firewalls. It covers ten items in four areas: forwarding, connection, latency and filtering. We can use this standard as a guideline to make an objective evaluation for the performance of firewalls. In this paper, we discussed testing methodologies of RFC 3511. And then examined the IP throughput and the concurrent connections for Firewall. We also tested TCP connection throughput.

참고문헌 (20)

  1. "IETF WG introduction"[URL]
  2. Bradner, S, "Benchmarking Methodology for Network Interconnect Devices", RFC 2544, ~ (1999)
  3. Mandeville, R, "Benchmarking Methodology for LAN Switching Devices", RFC 2889, ~ (2000)
  4. Popoviciu, C, "IPv6 Benchmarking Methodology for Network Interconnect Devices", RFC 5180, ~ (2008)
  5. Dunn, "Methodology for ATM Benchmarking", RFC 3116, ~ (2001)
  6. Hickman, "Benchmarking Methodology for Firewall Performance", RFC 3511, ~ (2003)
  7. Stopp, "Methodology for IP Multicast Benchmarking", RFC 3918, ~ (2004)
  8. Manral, "Benchmarking Basic OSPF Single Router Control Plane Convergence", RFC 4061, ~ (2005)
  9. Akhter, "MPLS Forwarding Benchmarking Methodology for IP Flows", RFC 5695, ~ (2009)
  10. Poretsky, "Benchmarking Methodology for Link-State IGP Data-Plane Route Convergence", RFC 6413, ~ (2011)
  11. Bradner, "RFC 2544 Applicability Statement: Use on Production Networks Considered Harmful", Internet Draft, ~ (2011)
  12. Hamilton, "Benchmarking Meth odology for Content-Aware Network Devices", Internet Draft, ~ (2011)
  13. Jan Novak, "IP Flow Information Accounting and Export Benchmarking Methodology", Internet Draft, ~ (2011)
  14. Papneja, "Methodology for benchmarking MPLS protection mechanisms", Internet Draft, ~ (2011)
  15. "네트워크 보안 장비에 대한 성능 측정 방법", TTAS.KO-12.0044, ~ (2006)
  16. Newman, D, "Benchmarking Terminology for Firewall Devices", RFC 2647, ~ (1999)
  17. Bradner, S, "Benchmarking Terminology for Network Interconnection Devices", RFC 1242, ~ (1991)
  18. Product Certification Report, , NSS labs, ~ (2008)
  19. Test Summary, "Secui.com NXG2000", Tolly Group, ~ (2005)
  20. Cisco IOS Firewall, , ~

관련 논문AI추천

이 간행물의 다른 논문 (7건)