사물인터넷과 모바일 IP의 융합을 위한 효율적 인증 메커니즘
Efficient Authentication for Convergence of IoT and Mobile IP
0
조회
0
다운로드
1
인용
0
참고문헌
키워드
초록
본 논문은 제한된 컴퓨팅 파워와 자원을 갖는 IoT 와 Mobile IPv6 (MIPv6) 환경에서, 모바일 기기와 홈에이전트/대응노드 간의 바인딩 업데이트 메시지에 효율적이고 안전한 쌍방향 인증 프로토콜 제안한다. 이 프로토콜은 MIPv6의 메시지 교환에 기반으로 하여 최소한의 수정으로 통신주체 양쪽에 대하여 최적화된 인증과 공개키 교환을 동시에 만족한다. 최소한의 메시지교환으로 쌍방향 인증이 가능하며, 인증을 위한 교환 메시지 수를 최소화하였고, ECC 공개키 기반 키쌍을 사용으로 각각 노드에서의 연산양이 적으며 교환되는 메시지 크기가 작아서 네트워크 부담도 기존의 연구들에 비해 상대적으로 적다. 향후에는 본 논문에서 제안하는 프로토콜을 구체적으로 구현하여 성능분석 연구를 진행할 예정이다.
Abstract
This paper proposes efficient and secure two-way authentication protocol for binding update messages between mobile devices and home agents / correspondent nodes in IoT and Mobile IPv6 (MIPv6) environments with limited computing power and resources. Based on the MIPv6 message exchange, the proposed protocol satisfies both the authentication and the public key exchange optimized for both sides of the communication with minimum modification. In the future, we will carry out a performance analysis study by implementing the proposed protocol in detail.
참고문헌 (11)
- C. Perkins, "Mobility support in IPv6", IETF RFC 6275, ~ (2011)
- M. B. Yassein, "Mobility Management of Internet of Things:Protocols, Challenges and Open Issues", IEEE ICEMIS 2017 (2017)
- Julien Montavont, "Mobile IPv6 in Internet of Things: Analysis, experimentations and optimizations", Ad Hoc Networks, 14, pp.15~25 (2014), Elsevier BV[DOI]
- Sang-Il Choi, "Use of Proxy Mobile IPv6 for Mobility Management in CoAP-Based Internet-of-Things Networks", IEEE Communications Letters, 20(11), pp.2284~2287 (2016), Institute of Electrical and Electronics Engineers (IEEE)[DOI]
- "IPSec : Security Architecture for the Internet Protocol", IETF RFC 4301, ~
- "Internet Key Exchange (IKEv2) Protocol", IETF RFC 4306, ~
- "Mobile IPv6 Security Issues and Solutions"[URL]
- M. Chuang, "SPAM: A secure password authentication mechanism for seamless handover in proxy mobile IPv6 networks", IEEE Systems Journal, 7(1), pp.102~113 (2013)
- J. Lee, "Secure authentication with dynamic tunneling in distributed IP mobility management", IEEE Wireless Communications, 23(5), pp.38~43 (2016)
- G. O’shea, "Child-proof Authentication for MIPv6 (CAM)", ACM Computer Couunications Review, 31(2), pp.4~8 (2001)
