A Performance Enhanced Privilege Verification Cache for Authorization in Ubiquitous Service Environment
2
조회
0
다운로드
0
인용
0
참고문헌
초록
In an attempt to achieve an efficient and secure communication in ubiquitous computing environment, we found that a proper selection of compression and encryption algorithms is a challenging issue. Compression can be beneficial to reduce the number of bits transmitted. If the energy required to compress data is less than the energy required to send it, there is a net energy savings and an increase in battery life for portable computers. On the other hand, encryption is essential operations to provide a secure communication. However, the mobile devices, usually with very limited resources and battery power, are subject to the problem of energy consumption due to compression and encryption algorithms. They consume a significant amount of computing resources such as CPU time, memory, and battery power. In this paper, we present the results of DEVS-based evaluation with symmetric key algorithms (AES, RC4) and compression algorithms (Zlib, LZO, Bzip) that are commonly suggested in terms of processing time and consumed energy.
Abstract
In an attempt to achieve an efficient and secure communication in ubiquitous computing environment, we found that a proper selection of compression and encryption algorithms is a challenging issue. Compression can be beneficial to reduce the number of bits transmitted. If the energy required to compress data is less than the energy required to send it, there is a net energy savings and an increase in battery life for portable computers. On the other hand, encryption is essential operations to provide a secure communication. However, the mobile devices, usually with very limited resources and battery power, are subject to the problem of energy consumption due to compression and encryption algorithms. They consume a significant amount of computing resources such as CPU time, memory, and battery power. In this paper, we present the results of DEVS-based evaluation with symmetric key algorithms (AES, RC4) and compression algorithms (Zlib, LZO, Bzip) that are commonly suggested in terms of processing time and consumed energy.
참고문헌 (13)
- "ITU-T Rec. X.509 The Directory: Public-kiy and attribute cretificate frameworks", ~ (2005)
- "ITU-T Rec. X.812 Security Frameworks for open systems: Acceess control framework", ~ (1995)
- D. W. Chadwick, "The PERMIS X.509 Role Based Privilege Managemint Infrastructure", 7th ACM Symposium On Access Control Models And Technologies (SACMAT 2002),, pp.135~140 (2002)
- S. Farrell, "An Internet Attrivute Certificate Profile for Authorization. RFC3281", ~ (2002)
- T. Freeman, "Server-based Certificate Profile for Authorization. RFC3281", ~ (2002)
- R. Housley, "Internet X.509 Public Key Infrastructure Certificate and CRL Profile. RFC2459", ~ (1999)
- S. Knight, "Scalability Issues in PMI Delegation", Proceedings of NIST 1st Annual PKI Research Workshop (2002)
- J. Lee, "A Ubiquitous Fashionable Computer with an i-Throw Device on a Location-Based Service Environment", AINAW '07: Proceedings of the 21st International Conference on Advanced Information Networking and Applications Workshops, pp.59~65 (2007), IEEE Computer Society
- J. Li, "Denial of Service Attacks and Defenses in Decentralized Trust Management", Securecom and Workshops, pp.1~12 (2006)
- M. Myers, "X.509 Internet Public Key Infrastructure Online Certificate Status Protocol-OCSP. RFC2560", ~ (1999)
- K. H. Park, "U-TOPIA: Campus-wide Advanced Ubiquitous Computing Environment", Conference on Next Generation Computing, pp.5~16 (2007)
- D. Pinkas, "Delegated Path Validation and Delegated Path Discovery Protocol Requirement. RFC3379", ~ (2002)
- W. Wahl, "Lightweight directory access protocol. RFC2251", ~ (1997)
