본문 바로가기
KERD
논문KCI 등재

프록시 모바일 네트워크를 위한 계층적 인증 기법

A Hierarchical Authentication for Proxy Mobile IPv6 Networks

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

본 연구에서는 프록시 모바일 IPv6 환경에서의 인증 지연시간을 최소화하기 위하여 계층적인 인증 기법을 제시한다. AAA 서버의 인증 기능을 LMA와 MAG에 분산하여 해당 LMA 또는 MAG가 모바일 노드에 관한 정보를 가지고 있는 경우 AAA 서버를 거치지 않고 빠르게 인증을 하여 인증 지연 시간을 줄일 수 있는 기법을 제시한다. AAA서버는 인증을 위한 모든 것을 담당하고 있기 때문에 AAA 서버에 서비스 거부 공격 등으로 인한 단일 고장점 문제가발생할 경우 모바일 노드는 더 이상 프록시 모바일 IPv6 네트워크에 접속할 수 없는 문제가 발생한다. LMA와MAG에 인증 기능을 분산함으로써 이러한 단일 고장점 문제에 대응하고 보다 가까운 네트워크 장비에서 보다 가벼운인증을 수행함으로써 인증 지연시간을 줄일 수 있다.

Abstract

In this paper, a hierarchical authentication protocol is proposed to minimize authentication delay in proxy mobile IPv6networks. The authentication function of the AAA server is distributed to the LMAs and the MAGs. If the LMAs or theMAGs have authentication information of the MNs, they authenticate the MN on behalf of the AAA servers. Therefore, theauthentication delay is reduced. The AAA server is vulnerable to denial-of-service attack. If the AAA server is down, MNscannot access the proxy mobile IPv6 network until they are authenticated. The proposed scheme reduces the load on the AAAserver by distributing the authentication function to the LMAs and the MAGs.

참고문헌 (7)

  1. C. Perkins, "Mobility support in IPv6", IETF RFC:6275, ~ (2011)
  2. S. Gundavelli, "Proxy mobile IPv6", RFC 5213, ~ (2008)
  3. J. Arkko, "Improved extensible authentication protocol method for 3rd generation authentication and key agreement", RFC 5448, ~ (2009)
  4. H. Kim, "Diffie-Hellman key based authentication in proxy mobile IPv6", Mobile Information Systems, pp.107~121 (2010)
  5. Y. Chen, "A secure relay-Assisted handover protocol for proxy mobile IPv6 in 3GPP LTE systems", Wireless Pers Communications, pp.629~656 (2011)
  6. J. Salowey, "Specification for the Derivation of Root Keys from an Extended Master Session Key (EMSK)", RFC 5247, ~ (2008)
  7. J. Arkko, "Extensible authentication protocol method for 3rd generation authentication and key agreement (EAP-AKA)", RFC 4187, ~ (2006)

관련 논문AI추천

이 간행물의 다른 논문 (23건)