본문 바로가기
KERD
논문KCI 등재

이중토큰을 이용한 효율적인 Wi-Fi 보안 프로토콜

Efficient Wi-Fi Security Protocol Using Dual Tokens

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

WPA2-PSK[1,2]는 클라이언트와 AP가 공유비밀키에 기반하여 4-way 핸드쉐이크 프로토콜을 이용하여 보안세션을 설정하는 방식을 사용하고 있다. 이 방식은 도청공격 등 여러 가지 보안 문제점들이 제기되고 있으며 또한효율성 측면에서도 클라이언트와 AP간에 여러번의 상호작용을 요구하여 보안세션 설정과정이 비효율적이다. WPA2의 보안 문제점을 해결하기 위하여 최근 WPA3[3] 표준이 제안되고 있지만 근본적으로는 동일한 4-way 핸드쉐이크 방법론을 사용하는 소규모 개선이다. OAuth 2.0[4,5,6] 토큰인증 기술은 한 번 인증이 확인된 클라이언트에게 서버가 토큰을 발급하여 인증상태를 오랜 기간 효율적으로 유지시킬 수 있는 인증유지 기술로 웹에서 널리사용되고 있다. 이 논문에서는 OAuth 2.0 기술을 개선한 이중토큰을 이용하는 난수화토큰인증[11,12] 기술을Wi-Fi 보안 프로토콜에 결합 적용함으로써, 초기인증과 보안세션설정을 구분하여 효율성을 개선한 새로운 Wi-Fi보안 프로토콜을 제시한다. 즉, 한 번 초기인증에 성공한 클라이언트에게는 AP가 이중토큰을 발급하고 이후에는 이것을 이용하여 한 번의 평문 메시지 교환만으로 빠르게 보안세션을 생성할 수 있도록 성능을 개선하였다.

Abstract

WPA2-PSK[1,2] uses a 4-way handshake protocol based on a shared secret to establish a secure session between a clientand an AP. It has various security problems such as eavesdropping attacks and the secure session establishment process isinefficient because it requires multiple interactions between client and AP. The WPA3[3] standard has recently beenproposed to solve the security problem of WPA2, but it is a small improvement using the same 4-way handshakemethodology. OAuth 2.0 token authentication[4,5,6] is widely used on the web, which can be used to keep an authenticatedstate of a client for a long time by using tokens issued to an authenticated client. In this paper, we apply the dual-tokenbased randomized token authentication[11,12] technology to the Wi-Fi security protocol to achieve an efficient Wi-Fi securityprotocol by dividing initial authentication and secure session establishment. Once a client is authenticated and equipped withdual tokens issued by AP, it can establish secure session using them quickly with one message exchange over a non-securechannel.

참고문헌 (13)

  1. "The Evolution of 802.11 Wireless Security, UNLV Informatics" (2010)[URL]
  2. "Wi-Fi Protected Access II (WPA2)", IEEE 802.11i-2004, ~ (2004)
  3. "WPA3"[URL]
  4. Michael B. Jones, "The OAuth 2. 0 authorization framework : bearer token usage", RFC 6750, ~ (2012)
  5. Michael B. Jones, "JSON web token (JWT)", RFC 7519, ~ (2015)
  6. "OAuth 2.0 message authentication code (MAC) tokens" (2014)[URL]
  7. Eric Rescorla, "HTTP over TLS", RFC 2818, ~ (2000)
  8. Dan Harkins, "Simultaneous Authentication of Equals: A Secure, Password-Based Key Exchange for Mesh Networks", 2008 Second International Conference on Sensor Technologies and Applications (sensorcomm 2008), pp.839~844 (2008)
  9. Dan Harkins, "Opportunistic Wireless Encryption", RFC 8110, ~ (2017)
  10. Mathy Vanhoef, "Key Reinstallation Attacks: Forcing Nonce Reuse in WPA2", Proceedings of the 2017 ACM SIGSAC Conference on Computer and Communications Security, pp.1313~1328 (2017)
  11. 이병천, "시간기반 난수화를 이용한 토큰인증의 강화", 보안공학연구논문지, 14(2), pp.103~114 (2017), 보안공학연구지원센터[DOI]
  12. 이병천, "OAuth 2.0 MAC 토큰인증의 효율성 개선을 위한 무상태 난수화토큰인증", 정보보호학회논문지, 28(6), pp.1343~1354 (2018), 한국정보보호학회[DOI]
  13. Scott Fluhrer, "Weaknesses in the Key Scheduling Algorithm of RC4", Lecture Notes in Computer Science, 2259, pp.1~24 (2001)

관련 논문AI추천

이 간행물의 다른 논문 (16건)