OAuth 2.0 MAC 토큰인증의 효율성 개선을 위한 무상태 난수화토큰인증
Stateless Randomized Token Authentication for Performance Improvement of OAuth 2.0 MAC Token Authentication
0
조회
0
다운로드
3
인용
0
참고문헌
키워드
초록
표준 인증유지기술로 널리 사용되고 있는 OAuth 2.0 Bearer 토큰[1,2], JWT(JSON Web Token)[3,4] 기술은 고정된 토큰을 반복 전송하는 방식을 이용하고 있어서 네트워크 공격자에 의한 도청공격에 취약하기 때문에HTTPS[6] 보안통신 환경에서 사용해야 한다는 제약이 있다. 평문통신 환경에서도 사용할 수 있는 인증유지기술로제안된 OAuth 2.0 MAC 토큰[5] 기술은 서버가 인증된 클라이언트에게 공유된 비밀키를 발급하고 인증요청시 이를 이용하여 MAC 값을 계산하여 제시하는 방식을 사용하는데 서버는 사용자별 공유비밀키를 관리해야 하므로 무상태(stateless) 인증을 제공할 수 없다는 단점이 있다. 이 논문에서는 서버측에서 사용자별 공유비밀키를 관리하지않고도 무상태 MAC 토큰 인증을 수행할 수 있도록 개선된 난수화 토큰인증 프로토콜을 제시한다. 전체 인증과정에서 HTTPS를 사용할 필요가 없도록 하기 위하여 서버인증서를 이용한 초기인증보안, 인증서토큰을 이용한 전자서명 간편로그인 등의 기술을 난수화 토큰인증 기술과 결합하여 적용함으로써 완전한 무상태형 인증서비스를 제공할수 있도록 설계하였으며 그 구현 사례를 제시한다.
Abstract
OAuth 2.0 bearer token[1,2] and JWT(JSON web token)[3,4], current standard technologies for authentication andauthorization, use the approach of sending fixed token repeatedly to server for authentication that they are subject toeavesdropping attack, thus they should be used in secure communication environment such as HTTPS[6]. In OAuth 2.0MAC token[6] which was devised as an authentication scheme that can be used in non-secure communication environment,server issues shared secret key to authenticated client and the client uses it to compute MAC to prove the authenticity ofrequest, but in this case server has to store and use the shared secret key to verify user’s request. Therefore, it’s hard toprovide stateless authentication service. In this paper we present a randomized token authentication scheme which canprovide stateless MAC token authentication without storing shared secret key in server side. To remove the use of HTTPS,we utilize secure communication using server certificate and simple signature-based login using client certificate together withthe proposed randomized token authentication to achieve the fully stateless authentication service and we provide animplementation example.
참고문헌 (8)
- Dick Hardt, "The OAuth 2. 0 authorization framework", RFC 6749, ~ (2012)
- Michael B. Jones, "The OAuth 2. 0 authorization framework : bearer token usage", RFC 6750, ~ (2012)
- Michael B. Jones, "JSON web token (JWT)", RFC 7519, ~ (2015)
- "JWT"[URL]
- "OAuth 2. 0 message authentication code (MAC)tokens" (2014)[URL]
- Eric Rescorla, "HTTP over TLS", RFC 2818, ~ (2000)
- 이병천, "시간기반 난수화를 이용한 토큰인증의 강화", 보안공학연구논문지, 14(2), pp.103~114 (2017), 보안공학연구지원센터[DOI]
- 명희원, "안전한 HTML5 로컬스토리지 구현에 대한 연구", 인터넷정보학회논문지, 13(4), pp.83~93 (2012), 한국인터넷정보학회[DOI]
