자원제약적 임베디드 환경에서 종단간 보안을 지원하는 수정된 MQTT-SN
Modified MQTT-SN Protocol for End-to-End Security in a Constrained Embedded Environment
0
조회
0
다운로드
1
인용
0
참고문헌
키워드
초록
MQTT-SN(Message Queuing Telemetry Transport – Sensor Network) 프로토콜은 센서 기반의IoT(Internet of Things)환경에서 사용되는 메시지 전송 프로토콜이다. 이 MQTT-SN 프로토콜은 메시지 전송중간에 중개자(Broker)를 둔 발행-구독 모델(Publish-Subscribe Model)로 각 IoT 장치들이 메시지를 전달 할때 반드시 중개자를 통해 메시지를 주고 받는 모델이다. 하지만 MQTT-SN 프로토콜은 메시지 보안, 상호 인증, 접근 제어, 중개자 보안등을 만족하는 보안 관련된 기능을 제공하고 있지 않다. 이에 따라 최근 다양한 보안 문제가발생하고 있으며, 보안이 필요한 상황이 대두되고 있다. 본 논문에서는 MQTT-SN의 보안 요구사항을 다시 한번살펴보고, 이 프로토콜이 적용되는 IoT의 자원이 제한된 환경에서의 제약 조건을 만족하면서 보안을 향상시키는 수정된 프로토콜을 제안한다. 제안 프로토콜은 기존과 다르게, 보안 필드와 인증 서버가 추가되었으며 이를 통해 보안요구사항을 만족시키도록 한다. 더불어 제안된 프로토콜을 실제 구현 및 테스트하고 에너지 소모 관점에서 제안된프로토콜이 실제 사용이 가능한지 평가하도록 한다.
Abstract
The MQTT-SN (Message Queuing Telemetry Transport-Sensor Network) protocol is a message transmission protocol usedin a sensor-based Internet of Things (IoT) environment. This MQTT-SN protocol is a publish-subscribe model with a brokerin the middle of message transmission, and each IoT device sends and receives messages through an intermediary whendelivering messages. However, the MQTT-SN protocol does not provide security-related functions such as message security,mutual authentication, access control, and broker security. Accordingly, various security problems have recently occurred, anda situation in which security is required has emerged. In this paper, we review the security requirements of MQTT-SN onceagain, and propose a modified protocol that improves security while satisfying the constraints in the environment where theresource of IoT to which this protocol is applied is limited. Unlike the existing protocol, the security field and authenticationserver have been added to satisfy the security requirements. In addition, the proposed protocol is actually implemented andtested, and the proposed protocol is evaluated for practical use in terms of energy consumption.
참고문헌 (21)
- D. Miorandi, "Internet of things:Vision applications and research challenges", Ad Hoc Networks, 10(7), pp.1497~1516 (2012)
- G. Wu, "M2M:From mobile to embedded internet", IEEE Communications Magazine, 49(4), pp.36~43 (2011)
- A. Banks, "MQTT Version 3.1.1", OASIS Standard, ~ (2014)
- G. Perrone, "The Day After Mirai: A Survey on MQTT Security Solutions After the Largest Cyberattack Carried Out through an Army of IoT Devices", Proc. Int’l Conf. on Internet of Things, Big Data and Security, pp.246~253 (2017)
- MQTT for Sensor Networks (MQTT-SN): Protocol Specification, version 1.2, "A. Stanford-Clark", IBM, ~ (2013)
- Lesjak, Christian, "Securing smart maintenance services:Hardware-security and TLS for MQTT", 2015 IEEE 13th international conference on industrial informatics (INDIN) (2015), IEEE
- -Rescorla, E., "The Transport Layer Security (TLS) Protocol Version 1.3", RFC 8446, DOI 10.17487, 2018
- M. Singh, "Secure MQTT for Internet of Things (IoT)", 2015 Fifth International Conference on Communication Systems and Network Technologies, pp.746~751 (2015)
- V. Goyal, "Attribute-based Encryption for Fine-grained Access Control of Encrypted Data", Proc. ACM Conf. on Computer and Communications Security, pp.89~98 (2006)
- A. Niruntasukrat, "Authorization mechanism for MQTT-based Internet of Things", 2016IEEE International Conference on Communications Workshops (ICC), pp.290~295 (2016)
- S. H. Shin, "Efficient Augmented Password-Only Authentication and Key Exchange for IKEv2", IETF RFC 6628, Experimental, ~ (2012)
- S. Shin, "A security framework for MQTT", 2016IEEE Conference on Communications and Network Security (CNS), pp.432~436 (2016)
- Dinculeană, "Vulnerabilities and Limitations of MQTT Protocol Used between IoT Devices", Appl. Sci., pp.848~ (2019)
- C. Park, "A Secure and Efficient ECQV Implicit Certificate Issuance Protocol for the Internet of Things Applications", IEEE Sensors Journal, 17(7), pp.2215~2223 (2017)
- "ECC Certificate Guide"[URL]
- Koren, T., "IP Header Compression over PPP", RFC 3544, ~ (2003)
- Carlson, R., "Guidelines for Next Hop Client (NHC) Developers, RFC 2583, DOI 10.17487", RFC2583, May 1999, 1999
- Classification and Security Requirements based on IoT Device Capabilities (TTAK.KO-12.0298), "TTA", ~ (2016)
- A. Dunkels, "Contiki - a lightweight and flexible operating system for tiny networked sensors", 29th Annual IEEE International Conference on Local Computer Networks, pp.455~462 (2004)
- "Really Small Message Broker" (2014)[URL]
