본문 바로가기
KERD
논문KCI 등재

스마트 IoT 디바이스를 위한 경량 암호기반 종단간 메시지 보안 프로토콜

A Study of End-to-End Message Security Protocol Based on Lightweight Ciphers for Smart IoT Devices

1

조회

0

다운로드

2

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

IoT 시장은 전 세계에서 지속적으로 성장하고 있지만, IoT 환경에서 증가하는 보안 위협에 대한 고려는 여전히미흡한 실정이다. 특히 자원이 한정적인 IoT 디바이스에 기존 IP 보안 기술을 적용하기 어렵기 때문에, 이기종 사물 네트워크 간 통신 과정에서 발생할 수 있는 정보 변조·유출과 같은 보안 위협에 대응하기 위한 디바이스 종단간신뢰 통신 보안 대책이 필요하다. 이에 본 논문에서는 저성능의 IoT 디바이스 간 통신에서 보안성은 늘리며 보안 오버헤드는 줄일 수 있는 경량 암호기반 종단간 메시지 보안 프로토콜을 제안한다. 실행 시간 성능 시뮬레이션을 통해제안 프로토콜이 기존의 AES 기반의 프로토콜을 적용한 경우보다 성능이 더 우수함을 검증하였다.

Abstract

Although the IoT market is steadily growing, there is still a lack of consideration for increasing security threats in theIoT environment. In particular, it is difficult to apply existing IP security technology to resource-constrained devices. Therefore, there is a demand for reliable end-to-end communication security measures to cope with security threats such asinformation tampering and leakage that may occur during communication between heterogeneous networks do. In this paper,we propose an end-to-end message security protocol based on lightweight cipher that increases security and lowers securityoverhead in resource-constrained IoT device communication. Through simulation of processing time, we verified that theproposed protocol has better performance than the existing AES-based protocol.

참고문헌 (17)

  1. The internet of things (IoT)information protection roadmap, "MSIP", Ministry of Science ICT and Future Planning, ~ (2014)
  2. Rob van der Meulen, "Gartner says 8.4 billion connected 'Things' will be in use in 2017, up 31 percent from 2016", Gartner, ~ (2017)
  3. Brussels Center, "Application and development prospects of 'Internet of Things (IoT)' in industry sector", BMI, ~ (2017)
  4. Chris Middleton, "Gartner : IoT security spend hitting $1. 5 billion –but strategy poor", Internet of Business, ~ (2018)
  5. Namseoul University, "In the 'Internet of Things', a research of actual cases and analysis of factors infringing privacy", Personal Information Protection Commission, ~ (2015)
  6. Zhi-Kai Zhang, "IoT security:ongoing challenges and research opportunities", 2014 IEEE 7th International Conference on IEEE, pp.230~234 (2014)
  7. T. Dierks, "The Transport Layer Security (TLS)Protocol Version 1.2", NWG RFC 5246, ~ (2008)
  8. "TLS protocol stack"[URL]
  9. "About cipher suite of TLS"[URL]
  10. E. Rescorla, "Datagram Transport Layer Security Version 1.2", IETF RFC 6347, ~ (2012)
  11. Heer, T, "Security Challenges in the IP-based Internet of Things", Wireless Personal Communications, 61(3), pp.527~542 (2011)
  12. ISO, "Information technology --Message Queuing Telemetry Transport (MQTT) v3.1.1, ISO", IEC 20922:2016, 2016
  13. "Facebook messanger using MQTT"[URL]
  14. Andrew Banks, "MQTT Version 3.1.1 Plus Errata 01", OASIS Standard Incorporating Approved Errata 01, ~ (2015)
  15. Zach Shelby, "The Constrained Application Protocol(CoAP)", IETF RFC 7252, ~ (2014)
  16. Beaulieu, R, "The SIMON and SPECK lightweight block ciphers", Design Automation Conference(DAC), 2015 52nd ACM, IEEE, pp.2015[DOI]
  17. K. Maletsky, "RSA vs ECC Comparison for Embedded Systems", Security ICs White Paper, ~ (2015)

관련 논문AI추천

이 간행물의 다른 논문 (25건)