본문 바로가기
KERD
논문KCI 등재

Smart Grid를 위한 필드형 가상사설망(VPN) 게이트웨이의 구현

A Study on the Implementation of outdoor type Virtual Private Network Gateway for Smart Grid

0

조회

0

다운로드

4

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

우리나라의 전력분야 제어시스템은 보안에 우수한 폐쇄형 네트워크로 운영되고 있어 보안피해의 심각성을 대체로 인지하지 못하고 있다. 앞으로 스마트그리드 사업이 지속적으로 확대되면 스마트미터에서부터 발전소에 이르기까지 다양한 형태의 사이버공격이 이루어질 수 있다. 향후 스마트미터를 통해 발전소에서 가정집까지의 전체 전력망이 연결되면 보안은 더욱 중요한 요소가 될 것이다. 본 연구에서는 스마트그리드 환경 즉, 외부의 혹독한 환경과 전국적인 망에서의 안정적 데이터 전송과 외부로부터의 침입방지를 위해 필요한 가상사설망(VPN) Gateway 구조를 설계 및 구현하였다. 본 연구를 통해 완성된 시제품으로 기 운영 중인 상용제품과 다양한 방식으로 연동 테스트를 시행하였으며, IPSec 방식의 터널링과 ARIA 암호화 알고리즘을 통한 암호화를 통해 전력선통신(PLC) 저압원격검침 분야에 시범 설치되어 보안이 강화된 데이터통신을 하고 있다.

Abstract

The vulnerabilities existed in Korean electricity control systems is unexposed because it is being operated in a closed network with superior security. The threat will become greater once the closed network develops into a smart grid environment with superior intelligence. Security will have a greater impact once each household will be connected to the power plant via the smart meter. This research focuses on stable data transfer in harsh external environment and whole-nation coverage network, and suggested standardized and optimized Virtual Private Network (VPN) Gateway architecture to support Power Line Communication (PLC). The functionality and stability of the prototype has been verified with field tests. For implementation of outdoor type VPN device for smart grid, we adopted PLC low voltage remote-meter-net for data communication. Also, IPSec type tunneling and ARIA algorithm based encryption of data collected by PLC low voltage remote meter is transmitted.

참고문헌 (13)

  1. 이건희, "스마트그리드와 사이버 보안", 정보와통신, 27(4), pp.23~25 (2010), 한국통신학회
  2. 윤인하, "미국 동부지역의 정전사태와 미국 전력산업의 문제점", 쟁점과 연구, 통권 : 140, pp.23~27 (2003), 한양대학교 아태지역연구센터
  3. 시병권, "알기 쉬운 스마트그리드 해설", 조명,전기설비학회 눈문지, 23(6), pp.71~78 (2009), 한국조명전기설비학회
  4. 문승일, "스마트그리드 개념", 정보와 통신: 한국통신학회지, 27(4), pp.3~9 (2010), 한국통신학회
  5. "Smart Grid may be vulnerable to hackers" (2009)[URL]
  6. 도윤미, "스마트그리드 기술동향 : 전력망과 정보통신의 융합기술", 전자통신동향분석, 24(5), pp.74~86 (2009), 한국전자통신연구원
  7. 유남철, "스마트그리드 추진 동향 및 구현 방안", 주간기술동향, 통권 : 1426 (2009), 정보통신산업진흥원
  8. 주성호, "AMI기반 에너지 관리시스템", 2010년도 하계학술대회 논문집, pp.109~110 (2010), 전력전자학회
  9. Kory Hamzeh, "Point-to-Point Tunneling Protocol(PPTP)", Internet Society, RFC 2637, ~ (1997)
  10. S. Kent, "Security Architecture for the internet protocol", Internet Society, RFC 2401, ~ (1998)
  11. S. Kent, "IP Authentication Header(AH)", Internet Society, RFC 2402, ~ (1998)
  12. S. Kent, "IP Encapsulation Security Payload(ESP)", Internet Society, RFC 2406, ~ (1998)
  13. 한국정보통신기술협회, "정보통신 표준화백서 2008", pp.302~303 (2008), 한국정보통신기술협회

관련 논문AI추천

이 간행물의 다른 논문 (6건)