본문 바로가기
KERD
논문KCI 등재

MPLS망에서의 확장성을 갖는 RSVP-TE 프로토콜 현을 위한 메시지 부하의 영향 분석

Evaluation on Effect of Message Overhead for Implementing a Scalable RSVP-TE Protocol in MPLS Networks

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류공학

초록

인터넷의 고품질 서비스를 제공하기 위한 기술로 MPLS 트래픽 엔지니어링 기술이 대두되고 있다. MPLS 망에서 트래픽 엔지니어링은 서비스 품질을 보장할 수 있는 경로를 계산하고 MPLS 신호 프로토콜을 이용하여 망 자원을 예약하는 기능을 수행한다. MPLS 신호 프로토콜의 하나인 RSVP-TE 프로토콜은 플로우 기반으로 설정된 경로의 연결 상태 관리를 위해 주기적으로 Refresh 메시지를 송수신한다. 이러한 주기적인 메시지의 송수신은 프로토콜 메시지 처리 부하를 증가시키기 때문에 많은 수의 경로 설정 능력을 제한하는 문제점을 유발한다. 본 논문은 이러한 RSVP-TE 프로토콜의 Refresh 메시지의 부하를 줄이기 위하여 제시된 Refresh Reduction 기법의 영향에 대하여 분석한다. 또한, 확장성을 갖는 RSVP-TE 프로토콜을 구현하기 위해서 메시지 부하가 적은 기법을 제안한다.

Abstract

For providing high quality-guaranteed services over Internet, traffic engineering based on an MPLS technology is being introduced. MPLS traffic engineering performs the computation on the path guaranteeing service’s quality and the reservation on network resources by an MPLS signaling protocol. As one of MPLS signaling protocols, RSVP-TE protocol transmits and receives periodic refresh messages for maintaining the path of a traffic flow. Such characteristic gives a heavy processing overhead to routers for maintaining states of large number of paths. In this paper, we propose a scalable implementation approach for RSVP-TE without dramatically increasing processing overhead. And we evaluate the processing overhead on periodic messages by implementing the RSVP-TE protocol and the reduction mechanism of periodic messages.

참고문헌 (11)

  1. "RSVP-TE:Extensions to RSVP for LSP TunnelsIETF RFC3209" (2001)
  2. "Resource ReSerVation Protocol (RSVP)-Version 1 Functional Specification" IETF RFC 2205" (1997)
  3. "RSVP Refresh Overhead Reduction Extensions^" (2001)
  4. "Supporting Real-Time Applications in an Integrated Services Packet Network:Architecture and Mechanism" (1992)
  5. "A Consideration of IX Architecture Using MPLS based on Router Performance and QoS Requirements", e86-b(2), pp.498~505 (2003)
  6. "Constraint-based LSP Setup Using LDPIETF RFC3212" (2002)
  7. "Dynamic RSVP", pp.pp.130~-135 (2003)
  8. "Traffic Engineering with MPLS", Cisco Press.
  9. "An Evaluation on RSVP Transport Mechanismraft-pan-nsis-rsvp-transport- 01.txtinternet draft" (2003)
  10. "Multiprotocol Label Switching ArchitectureIETF RFC3031" (2001)
  11. "A New Resource ReSerVation Protocol^", pp.116~127 (2002)

관련 논문AI추천

이 간행물의 다른 논문 (37건)