RSVP-라우터간 가용자원 이동을 통해자원 이용 효율을 높이는 자원예약 방식
A Resource Reservation Method with Available Resource Migration between RSVP-Capable Routers to Improve the Resource Utilization
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
서비스의 요구 품질을 보장하기 위해서 서비스의 트래픽 흐름 수용에 필요한 네트워크 자원을 예약해야 하며, 이를 위해 자원예약 프로토콜(RSVP)이 도입되었다. 그러나 경로상의 임의 RSVP-라우터가 자원부족으로 트래픽 흐름을 수락할 수 없으면 다른 RSVP-라우터에 아무리 여유자원이 많이 있다 해도 그 흐름을 수용할 수 없다. 이러한 문제를 해결하기 위해 본 논문에서 RSVP-라우터간 가용자원 이동을 통해 자원 이용 효율을 높이는 자원예약 방식을 제안한다. 제안방식에서 RSVP-라우터는 최근에 연구된 최적 레이턴시 기반 공정 패킷 스케줄러를 사용한다. 평가 네트워크에 제안된 자원예약 방식을 적용한 결과 기존 방식에 비해 수용 흐름의 수를 최대 165%까지 개선할 수 있음을 확인하였다.
Abstract
Providing Quality-of-Service (QoS) guarantee requires the reservation of resource needed to accommodate the traffic flow of service for which resource reservation protocol (RSVP) was introduced. However, if any RSVP-capable router on the path fails to accommodate the traffic flow due to lack of resource, the flow is not allowed no matter how much surplus resources other routers on the path have. In order to solve this problem, this paper proposes a resource reservation method with available resource migration between RSVP-capable routers in which the routers use the recently developed latency optimized fair queuing scheduler. The results of the simulation applying the proposed method to an evaluation network show that it may yield the gain of up to 165% compared to that in the original one in terms of the number of admitted flows.
참고문헌 (20)
- X. Xiao, "Internet QoS: A Big Picture", IEEE Network, 13(2), pp.8~18 (1999)
- R. Braden, "Resource ReSerVation Protocol (RSVP) – version 1 functional specification, RFC 2205, 1997", ~ (1997)
- S. Shenker, "Specification of Guaranteed Quality of Service, RFC 2212, 1997", ~ (1997)
- A.K. Parekh, "A Generalized Processor Sharing Approach to Flow Control in Integrated Services Networks", pp.1992
- A. Demers, "Design and analysis of a fair queuing algorithm", Proc. ACM SIGCOMM’89, pp.1~12 (1989)
- M. Baldi, "Efficiency of Packet Voice with Deterministic Delay", IEEE Comm. Mag, pp.170~177 (2000)
- A. Francini, "Weighted Fair Queuing Scheduler with Decoupled Bandwidth and Delay Guarantees for the Support of Voice Traffic", Proc. GLOBECOM, 3 (2001)
- T. J. Kim, "Weighted Fair Queuing with optimal rate and delay allocation", Proc. GLOBECOM (2006)
- 김태준, "최적 레이턴시 기반 공정 큐잉 방식의 개선에 관한 연구", 멀티미디어학회논문지, 10(1), pp.83~93 (2007), 한국멀티미디어학회
- M. Karsten, "Experimental Extensions to RSVP – Remote Client and One-Pass Signalling", Proc. IWQoS’01, pp.269~274 (2001)
- X. Fu, "Towards RSVP Lite: Light-weight RSVP for Generic Signaling", Proc. AINA’03, pp.619~622 (2003)
- Y.Xia, "Extending RSVP for Quality of Security Service", IEEE Internet Computing, pp.51~57 (2006)
- N.F. Huang, "RSVP extensions for real time services in hierarchical mobile IPv6 in: Mobile Networks and Applications 8", pp.625~634, Kluwer Academic
- G.S. Kuo, "Dynamic RSVP protocol", IEEE Communications Mag, pp.130~135 (2003)
- Q. Huang, "Dynamic RSVP extension for wireless mobile IP networks", Proc VTC’04, pp.2683~2687 (2004)
- 김태준, "자원 예약에 있어 대역폭 이용 효율을 높일 수 있는 RSVP-라우터", 멀티미디어학회논문지, 11(7), pp.997~1006 (2008), 한국멀티미디어학회
- A. Terzis, "RSVP Diagnostic Messages, RFC 2745, 2000", ~ (2000)
- M. H. MacDougall, "Simulating Computer Systems in: Techniques and Tools" (1987), MIT Press
- "인터넷전화 서비스 정책 시행계획, 정보통신부, 2004. 10", ~ (2004)
- 배성룡, "E-모델 기반 통화품질 분석을 통한 VoIP Planning 및 평가", 박사, pp.2004
