본문 바로가기
KERD
논문KCI 등재

이동 네트워크(NEMO)에서 HMIPv6를 적용한 AAA 인증 방안 연구

An Authentication and Handoff Mechanism using AAA and HMIPv6 on NEMO Environment

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류공학

초록

Mobile IPv6는 시그널 양이 단말과 비례한다는 점에서 대역폭 낭비가 심하며 또한, 무선 이동 네트워크 분야에서는 바인딩 시그널 양과 트래픽, 효과적인 이동성을 지원할 수 있는 점이 강화되어야 한다. 이에 따라, Mobile IPv6를 확장한 NEMO(NEtwork MObility)에 대한 연구가 이루어지고 있다. NEMO는 여러 이동 단말과 하나 이상의 이동 라우터를 이동 네트워크라는 단위로 묶어 이동성을 제공한다. 이때 노드들은 이동 라우터를 통해 인터넷에 접속하기 때문에 이동 시 별도의 작업이 필요없는 투명성을 제공받고, 그만큼 바인딩 시그널이 줄어 바인딩 스톰 문제를 해결할 수 있다. NEMO는 이동성 지원을 통해 여러 네트워크들이 계층적으로 이루어 질 수 있는 다양한 이동 구조를 갖게 되고, 이동 시 상위 네트워크 혹은 하위 네트워크들 간의 인증을 통해 안전성과 보안성을 향상되어야 함이 필수적이다. 또한, 안전한 인증 뿐만 아니라 빠른 핸드오프가 이루어져서 이동성에 따라 수반되는 효율성을 향상시킬 수 있는 방안에 관한 연구가 무엇보다 필요한 실정이다. 본 논문에서는 이를 위해 다양한 NEMO 이동 시나리오를 7가지로 정리하고, 각 시나리오별 AAA인증과 F+HMIPv6를 적용하여 안전한 인증과 빠른 핸드오프를 통한 인증 및 핸드오프 시 발생하는 시그널링 양과 패킷 지연률을 효과적으로 감소할 수 있는 방안을 제시한다.

Abstract

Mobile IPv6 spends considerable bandwidth considering that its signal volume is proportional to the mobile and also it should be strengthened to support the binding signal volume, the traffic, and effective mobility. So, the study in NEMO(Network Mobility), an extended version of Mobile IPv6, has been conducted. NEMO provides its mobility by putting several mobiles and more than one portable router into one unit called as mobile network. Because nodes access Internet via the portable router at this time, it receives transparency without any additional work and that much reduces binding signal while solving binding storm. By supporting mobility, NEMO is able to have various mobile structures which realize several networks hierarchically and it is necessary to improve its safety and security by authenticating among the upper networks or the lower ones while moving. Also, it is extremely required to begin a study in the device to improve efficiency accompanied with mobility, which is executed by the fast hand-off as well as the safe authentication. For those reasons, this paper not only classifies various NEMO mobile scenarios into 7 ways, but also provides AAA authentication of each scenario, the authentication through the safety authentication and fast handoff authentication using F+HMIPv6 and the way to reduce both signaling volume and packet delays efficiently during the handoff.

참고문헌 (20)

  1. Mobility Support in IPv6, "D. Johnson", IETF, ~, pp.RFC 3775 (2004)
  2. Network Mobility(NEMO) Basic Support Protocol, "V. Devarapalli", IETF, ~, pp.RFC 3963 (2005)
  3. Fast Handover for Mobile IPv6, "R. Koodli", IETF, ~, pp.RFC 4068 (2005)
  4. Hierarchical Mobile IPv6 Mobility Management (HMIPv6), "H. Soliman", IETF, ~, pp.RFC 4140 (2005)
  5. Mobile IP Authentication, Authorization, and Accounting Requirements, "S. Glass", IETF, ~, pp.RFC 2977 (2000)
  6. AAA for Mobile IPv6, draft-dupont- mipv6-aaa-01.txt, Internet draft, "F. Dupont", IETF, ~ (2001)
  7. AAA for NEMO, draft-kwon-aaa-nemo-00.txt, Internet draft, "Y. Choi", IETF, ~ (2005)
  8. Hee Young Jung, "Fast Handover Support in Hierarchical Mobile IPv6", The 6th International Conference on Advanced Communication Technology, 통권 : 2, pp.551~554 (2004)
  9. 김미영, "AAA 기반의 인증을 이용한 HMIPv6 성능 개선 기법", 정보과학회논문지 : 정보통신, 32(5), pp.551~560 (2005), 한국정보과학회
  10. 최승준, "NEMO에서의 이동 시나리오 분류 및 빠른 핸드오버 성능 분석", 한국통신학회논문지B, 31(11), pp.987~996 (2006), 한국통신학회
  11. 노경택, "NEMO와 결합된 Hierarchical Mobile IPv6dptj 멀티캐스팅을 이용한 핸드오프 지원 기법", 한국컴퓨터정보학회논문지, 9(3), pp.171~175 (2004), 한국컴퓨터정보학회
  12. R. Jain, "Mobile Internet Access and QoS Guarantees Using Mobile IP and RSVP with Location Registers", in Proc, ICC’98 Conf, pp.1690~1695
  13. Thomas, R, "Influence of the mobile station on the performance of a radio mobile cellular network", Proc. 3rd Nordic Sem., paper 9.4 (1988)
  14. 김미영, "Mobile IPv6에서 AAA를 이용한 이동노드와 홈 에이전트간의 최적화된 인증 방안", 정보과학회논문지 : 정보통신, 30(6), pp.714~719 (2003), 한국정보과학회
  15. Threat Analysis on NEMO Basic Operations, "Souhwan Jung", IETF, ~, pp.draft-jung-nemo-threat-analysis-02 (2004)
  16. Threats for Basic Network Mobility Support (NEMO threats)”, "A. Petrescu", IETF, ~, pp.draft-petrescu-nemo-threats-01.txt (2004)
  17. Threat for Multi-homed Mobile Networks, "Seongho Cho", IETF, ~, pp.draft-cho-nemo-threat-multihoming-00 (2004)
  18. AAA Authorization Framework, "J. Vollbrecht", IETF, ~, pp.RFC 2904 (2000)
  19. Angelos Keromytis, "SOS: An Architecture for Mitigating DDoS Attacks", IEEE Journal on Selected Areas in Communications (JSAC), 22(1) (2004)
  20. 민병준,김성기,나용희,이호재,최중섭,김홍근, "서비스 거부 공격에 대비한 자원 재할당 및 서버 중복 방안", 정보처리학회논문지A, 10(1), pp.7~14 (2003), 한국정보처리학회

관련 논문AI추천

이 간행물의 다른 논문 (14건)