본문 바로가기
KERD
논문KCI 등재

Mobility Support Using Locator-Identifier Separation Protocol in 4G Mobile Communication Networks

2

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

The System Architecture Evolution (SAE) with Long Term Evolution (LTE) has been used as a key technology in 4G mobile communication networks. In the existing study to support mobility in SAE-based mobile networks, the Proxy Mobile IPv6 (PMIP) was considered and the Mobile IP (MIP) may be used for global mobility support with Internet hosts. However, the architecture of PMIP with MIP tends to induce large data transmission and route update delays in SAE-based mobile networks. To overcome these limitations, this paper proposes the Locator Identifier Separation Protocol (LISP)-based mobility management schemes in SAE-based mobile networks. For LISP mobility support, we introduce a Local Map Server (LMS) which can be implemented with the mobility management entity (MME) of SAE and used to perform the LISP identifier-locator mapping management for LISP hosts within a mobile network. As per the location of LISP Tunnel Router (TR), the proposed schemes are divided into the two specific schemes: a host-based scheme, in which the LISP TR is implemented at a mobile host, and a network-based scheme, in which LTE evolved Node B (eNB) performs the LISP TR functionality. By numerical analysis, the two proposed schemes are compared with the existing PMIP-MIP scheme in terms of data transmission and route update delays. From numerical results, we see that the proposed LISP-based mobility management schemes can give better performance than the existing PMIP-MIP scheme. In particular, it is shown that the network-based LISP mobility management scheme provides the best performance among the candidate schemes.

Abstract

The System Architecture Evolution (SAE) with Long Term Evolution (LTE) has been used as a key technology in 4G mobile communication networks. In the existing study to support mobility in SAE-based mobile networks, the Proxy Mobile IPv6 (PMIP) was considered and the Mobile IP (MIP) may be used for global mobility support with Internet hosts. However, the architecture of PMIP with MIP tends to induce large data transmission and route update delays in SAE-based mobile networks. To overcome these limitations, this paper proposes the Locator Identifier Separation Protocol (LISP)-based mobility management schemes in SAE-based mobile networks. For LISP mobility support, we introduce a Local Map Server (LMS) which can be implemented with the mobility management entity (MME) of SAE and used to perform the LISP identifier-locator mapping management for LISP hosts within a mobile network. As per the location of LISP Tunnel Router (TR), the proposed schemes are divided into the two specific schemes: a host-based scheme, in which the LISP TR is implemented at a mobile host, and a network-based scheme, in which LTE evolved Node B (eNB) performs the LISP TR functionality. By numerical analysis, the two proposed schemes are compared with the existing PMIP-MIP scheme in terms of data transmission and route update delays. From numerical results, we see that the proposed LISP-based mobility management schemes can give better performance than the existing PMIP-MIP scheme. In particular, it is shown that the network-based LISP mobility management scheme provides the best performance among the candidate schemes.

참고문헌 (14)

  1. Younghyun Kim, "Performance Analysis of Distributed Mapping System in ID", Locator Separation Architectures, 2014, pp.39, 223~232
  2. Dong Ma, "Network Selection and Resource Allocation for Multicast in HetNets", Journal of Network and Computer Applications, 43, pp.17~26 (2014)
  3. "Morgan Stanley Report: Internet trends"[URL]
  4. "GPRS enhancements for E-UTRAN access, Rel-12 Ver. 12.4.0", 3GPP TS 23.401, ~ (2014)
  5. "Technical Specification Group Services and System Aspects: Architecture Enhancements for Non-3GPP Accesses, V10.7.0", 3GPP TR 23.402, ~ (2012)
  6. S. Gundavelli, "Proxy Mobile IPv6, IETF RFC 5213, Aug. 2008", ~ (2008)
  7. Julien Laganier, "Mobility Management for All-IP Network", NTT DOCOMO TechnicalJournal, 11(3) (2009)
  8. Yuh-Shyan Chen, "A Secure Relay-Assisted Handover Protocol for Proxy Mobile IPv6 in 3GPP LTE Systems", Wireless Personal Communications, 61(4), pp.629~656 (2011)
  9. A. R. Prasad, "Mobility and Key Management in SAE", LTE, 2007, 165~178
  10. D. Johnson, "Mobility Support in IPv6, IETF RFC 3775,Jun. 2004", ~ (2004)
  11. D. Farinacci, "Locator", ID Separation Protocol (LISP), IETF RFC 6830, Jan. 2013, 2013
  12. D.Farinacci, "LISP Map-Server Interface, IETF RFC 6833, Jan. 2013", ~ (2013)
  13. D. Farinacci, "LISP Mobile Node, IETF Internet Draft", draft-meyer-lisp-mn-10, ~ (2014)
  14. Makaya, C, "An Analytical Framework for Performance Evaluation of IPv6- based Mobility Management Protocols", IEEE Wireless Communication, 7(3), pp.972~983 (2008)

관련 논문AI추천

이 간행물의 다른 논문 (12건)