본문 바로가기
KERD
논문KCI 등재

안전한 멀티캐스트 통신을 위한 연산과 저장 비용 효율적인 키 트리 관리 프로토콜

Computation-and-Storage Efficient Key Tree Management Protocol for Secure Multicast Communication

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

미래 인터넷은 다양한 네트워크들이 유기적으로 연결된 유비쿼터스 환경을 활용하여 다양한 서비스들을 제공 할 것으로 예상되며 멀티미디어 데이터 전송을 위한 멀티캐스트는 미래 인터넷에서 중요한 서비스 중 하나로 기대되고 있다. 멀티캐스트 서비스를 안전하게 제공하기 위해서는 허가된 사용자들에게만 멀티캐스트 서비스에 대한 접근을 허용하는 그룹 통신의 키 관리를 필요로 한다. 통신 대역폭은 제한된 자원이므로 그룹 통신을 위한 키 관리방식들은 키 갱신 시 발생하는 메시지의 수를 줄이는 것에 초점을 맞추어 왔다. 키 갱신 시 메시지 수를 줄이기 위해서 키 트리를 기반으로 하는 그룹 키 관리 프로토콜들이 연구되어 왔다. 그러나 키 트리 구조는 여러 키들을 저장하기 위한 공간과 복호화 알고리즘을 여러 번 수행하기 위한 연산 능력 및 전력이 필요로 한다. 특히 제한된 저장공간과 연산 전력을 가지고 있는 이동 통신 기기를 지원하기 위해서는 통신 비용뿐 아니라 연산과 저장 비용도 줄여야 한다. 본 논문에서는 안전한 멀티 캐스트 통신을 위해서 간소화된 관리 프로토콜과 함께 연산과 저장공간 효율적인 키 트리 구조를 제안한다. 그리고 제안된 프로토콜은 사용자의 수가 많고 한번에 키를 갱신하는 주기가 적당히 긴 경우에 매우 적은 통신 비용의 증가를 보상으로써 연산과 저장 비용을 50%정도 줄일 수 있음을 보여준다.

Abstract

The future internet is expected to provide various services by using ubiquitous environment which consists of various networks and a multicast service for multimedia data is emerged as one of key technologies in the future internet. To provide securely a multicast service in the future internet, a group key management for secure group communication is required to permit only group members to access the service. Since communication bandwidth is limited resources, most key managements for scalable secure multicast communications have focused on reducing the number of update messages, i.e. communication cost. To alleviate the scalability problem, key tree based group key management protocols have been proposed. However, the key tree structure requires memory space for storing several keys and processing power for several cryptography algorithms. Especially in mobile devices which are emerged in the future internet and with limited storage space and computation power, it is crucial to minimize the overheads of computation and storage as well as communication. In this paper, we propose a computation-and-storage-efficient key tree structure with a simplified management protocol for secure multicast communications. We show that our protocol can save 50% of computation and storage cost at the expense of a very small increase of communication cost as a tradeoff when the number of total members and the ratio of members leaving in a batch update interval are moderately large.

참고문헌 (21)

  1. H.Harney, "''Group Key Management Protocol(GKMP) Specification,'' RFC2093", ~ (1997)
  2. H.Harney, "''Group Key Management Protocol(GKMP) Architecture,'' RFC2094", ~ (1997)
  3. D. M. Wallner, "''Key management for Multicast: Issues and Architectures,'' RFC 2627", ~ (1999)
  4. X. S. Li, "''Batch Rekeying for Secure Group Communications", Proc. of 10th International World Wide Web Conference (WWW10) (2001)
  5. S. M. Ghanem, "''A Secure Group Key Management Framework: Design and Rekey Issues", Proc. of 8th IEEE International Symposium on Computers and Communication (ISCC) (2003)
  6. S. Rafaeli, "''A survey of key management for secure group communication", ACM Comput. Surv, 35(3), pp.309~329 (2003)
  7. D. A. McGrew, "''Key establishment in large dynamic groups using one-way function trees", IEEE Transaction on Software Engineering, 29(5), pp.444~458 (2003)
  8. R. Canetti, "''Multicast security: a taxonomy and some efficient constructions", Proc. IEEE International Conference on Computer Communication (INFOCOM) (1999)
  9. Y. Wang, "''An Efficient Key Management for Large Dynamic Groups", Proc. IEEE 2th Annual Conference on Communication Networks and Services Research (CNSR) (2004)
  10. J. Lin, "''Efficient Group Key Management Protocol with One-Way Key Derivation", Proc. IEEE Conference on Local Computer Networks (LCN) (2005)
  11. A. Hodjat, "'The Energy Cost of Secrets in Ad Hoc Networks (Short Paper)", Proc. IEEE Circuits and Systems Workshop (CAS) (2002)
  12. W. H. Desmond, "Dynamic Balanced Key Tree Management for Secure Multicast Communications", IEEE Trans. Comput, 56(5), pp.590~605 (2007)
  13. A. Tucker, "''Applied Combinatorics" (1995), John Wiley & Sons
  14. J. Snoeyink, "''A Lower Bound for Multicast Key Distribution", Proc. IEEE INFOCOM (2001)
  15. W. T. Zhu, "Optimizing the Tree Structure in Secure Multicast Key Management", Communications Letters IEEE, 9(5), pp.477~479 (2005)
  16. J. S. Lee, "Optimal Levelhomogeneous Tree Structure for Logical Key Hierarchy", Proc. IEEE Conference on Communication System Software and Middleware workshop (COMSWARE) (2008)
  17. C. K. Wong, "Secure group communications using key graphs", Proc. ACM Special Interest Group on Data Communications (SIGCOMM) (1998)
  18. J. Pegueroles, "Balanced Batch LKH: New Proposal, Implementation and Performance Evaluation", Proc. IEEE International Symposium on Computers and Communication (ISCC) (2003)
  19. J. Pegueroles, "Improved LKH for Batch Rekeying in Multicast Groups", Proc. IEEE Information Technology: Research and Education (ITRE) (2003)
  20. S. Xu, "An Efficient Batch Rekeying Scheme Based on One-Way Function Tree", Proc. IEEE International Symposium on Communications and Information Technology (ISCIT) (2005)
  21. X. B. Zhang, "Protocol Design for Scalable and Reliable Group Rekeying", Proc. IEEE, 2003, ~

관련 논문AI추천

이 간행물의 다른 논문 (12건)