본문 바로가기
KERD
논문KCI 등재

네트워크 기반 모바일 멀티캐스트 기술 구현 연구

Implementation of Network-based Mobile Multicast

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

초록

유무선 통합 환경에서 모바일 멀티캐스트 서비스를 제공하기 위한 망 기반의 이동성 제어 기술을 제안한다. 기존의 유니캐스트 서비스에서 이종 망간 고품질의 핸드오버를 지원하기 위하여 고안된 단말 이동성 제어 기술(AIMS:Access Independent Mobile Service)을 이용하여 멀티캐스트 데이터 전송이 가능하도록 확장한 기술로써 코어망의제어 계층과 멀티캐스트 데이터 전달 계층을 분리함으로써 안정적인 제어 메시지 교환과 신속한 멀티캐스트 전달 경로를 설정할 수 있으며 망 기반의 제어 구조를 통하여 단말의 기능 변경을 최소화할 수 있다. 또한 멀티캐스트 데이터를수신하는 단말이 다른 액세스망으로 핸드오버하는 경우 망에서 새롭게 멀티캐스트 전달 경로를 재설정함에 따라 멀티캐스트 그룹에 대한 재가입 절차를 생략함으로써 지연시간을 줄이고 고속의 핸드오버를 제공할 수 있다. 마지막으로제안된 망 기반의 모바일 멀티캐스트 제공 기능에 대하여 실제 실험실 환경에서 테스트베드를 구축하여 운용해 봄으로써 실제 네트워크 환경에서의 적용 가능성을 확인하였다.

Abstract

This paper proposes a mobility management scheme to provide multicast service in fixed-mobile converged environment. Using terminal mobility control scheme called AIMS (Access Independent Mobile Service) which supports unicast service for high quality handover procedure between heterogeneous networks, it is extended technology for support multicast transmission. The proposed scheme enables fast and reliable control message delivery by separating a mobility control plane from the multicast data transport plane in the core network. Also it employs the network-based handover controls to require the minimum modifications on terminal devices. When terminal is moved to another access network on service, it is possible to reduce handover latency time and to support fast adaptation because the network detects it and re-configures multicast delivery path. Finally, we implements and manages proposed mobile multicast scheme on laboratory level for the feasibility under real network environments.

참고문헌 (13)

  1. "IETF MULTIMOB WG"[URL]
  2. T. Um, "Mobility Management Framework for Multicast Communications in NGN", ITU-T Draft Recommendation Y.MMC, ~ (2011)
  3. "Generic frameworks of mobility management for next generation networks", ITU-T Recommendation Q.1707, 2008
  4. "Multicast Functions in Next Generation Networks", ITU-T Recommendation Y.2017, ~ (2009)
  5. 류원, "유무선 통합망에서의 품질보장형 이동성 관리 기술 구현 연구", Telecommunications Review, 18(4), pp.624~638 (2008), SK텔레콤
  6. Myoungju Yu, "A New Mechanism for Seamless Mobility Based on MPLS LSP in BcN", IEICE Transactions on Communications, 91(2) (2008)
  7. B. Fenner, "Protocol Independent Multicast - Spare Mode(PIM-SM)", RFC4601, ~ (2006)
  8. S. Bhattacharyya, "An Overview of Source-Specific- Multicast(SSM)", RFC3569, ~ (2003)
  9. H. Holbrook, "Source-Specific Multicast for IP", RFC4607, ~ (2006)
  10. B. Haberman, "Internet Group Management Protocol Version 3(IGMPv3)", RFC5186, ~ (2008)
  11. "XORP project"[URL]
  12. 조성균, "오픈라우터플랫폼을 이용한 멀티캐스트 구현", 한국지식정보기술학회 추계학술발표대회 논문집 (2010)
  13. "VLC Media Player"[URL]

관련 논문AI추천

이 간행물의 다른 논문 (10건)