본문 바로가기
KERD
논문KCI 등재

서명용 개인키 노출 탐지 기법

A Method for Detection of Private Key Compromise

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

PKI(Public Key Infrastructure)는 공개키 암호시스템을 안전하게 사용하고 관리하기 위한 보안 표준방식이다. 인터넷상의 전자 금융거래와 같이 안전하지 않은 채널 상에서 사용자의 전자 서명, 인증, 암호화 등과 같은 보안 기능이요구되는 환경에서 PKI를 채택하고 있다. 현재 PKI에서 소프트 토큰 기반의 개인키는 표준화된 저장소에 파일 형태로저장되어 있기 때문에 유출되기 쉬우며, 패스워드 기반 암호화 방식으로 보호되어 있으므로 전수조사 공격에 취약하다. 본 논문에서는 소프트 토큰 기반의 개인키 파일이 유출되더라도 패스워드 전수조사 공격에 확률적으로 안전한 서명용 개인키 노출 탐지기법을 제안한다. 제안 기법은 하나의 올바른 공개키/개인키 쌍과 n-1개의 위장(fake) 공개키/개인키 쌍을 사용함으로써 공격자가 패스워드 전수조사 공격에 성공하더라도 올바른 서명 값 생성 또는 인증 성공 확률을1/n로 낮춘다. 이는 공격자가 위장 개인키로 인증을 시도할 경우 이를 탐지하여 해당 인증서를 폐지하고 사용자에게 통지해 주는 기능도 포함한다. 마지막으로 기존 PKI 및 SSL/TLS를 확장하여 제안 기법을 사용할 수 있게 함으로써 추가 인프라 구축비용 없이 소프트 토큰 기반 개인키 저장 방식의 보안 강도를 높일 수 있도록 한다.

Abstract

A Public Key Infrastructure (PKI) is security standards to manage and use public key cryptosystem. A PKI is used to providedigital signature, authentication, public key encryption functionality on insecure channel, such as E-banking and E-commerce onInternet. A soft-token private key in PKI is leaked easily because it is stored in a file at standardized location. Also it isvulnerable to a brute-force password attack as is protected by password-based encryption. In this paper, we proposed a new method that detects private key compromise and is probabilistically secure against abrute-force password attack though soft-token private key is leaked. The main idea of the proposed method is to use a genuinesignature key pair and (n-1) fake signature key pairs to make an attacker difficult to generate a valid signature with probability1/n even if the attacker found the correct password. The proposed method provides detection and notification functionality whenan attacker make an attempt at authentication, and enhances the security of soft-token private key without the additional cost ofconstruction of infrastructure thereby extending the function of the existing PKI and SSL/TLS.

참고문헌 (19)

  1. C. Adams, "Internet X.509 Public Key Infrastructure Certificate Management Protocol CMP", RFC 4210, ~ (2005)
  2. GPU-based password cracking, "M. Bakker", Univ. of Amsterdam, ~ (2010)
  3. D. Bleichenbacher, "“GeneratingElGamal Signatures Without Knowing the Secret Key,” Advances in Cryptology, Eurocrypt'96", LNCS, 1070, pp.10~18 (1996)
  4. D. Cooper, "internet x.509 public key infrastructure certificate and certificate revocation list(CRL)profile", RFC 5280, ~ (2008)
  5. T. Dierks, "the transport layer security(TLS) protocol version 1.2", RFC 5246, ~ (2008)
  6. M. Dürmuth, "Evaluation of Standardized Password-Based Key Derivation against Parallel Processing Platforms", LNCS, 7459, pp.716~733 (2012)
  7. C. Ellison, "Ten risks of PKI: What You're Not Being Told About Public Key Infrastructure", Computer Security Journal, 16(1), pp.1~7 (2000)
  8. M. Just, "Addressing the problem of undetected signature key compromise", Proceedings of the Network and Distributed System Security Symposium (1999)
  9. P. Kelley, "Guess again (and again and again): Measuring password strength by simulating password cracking algorithm", IEEE Symposium on Security and Privacy(S&P), pp.523~537 (2012)
  10. H. Ong, "An Efficient Signature Scheme Based on Quadratic Equations", Proceedings of the 16th Annual ACM Symposium on Theory of Computing, pp.208~216 (1984)
  11. J. Pollard, "An Efficient Solution of the Congruence x2+ky2=m(mod n)", IEEE Transactions on Information Theory, 33(5), pp.702~709 (1987)
  12. RSA Laboratories, "Certification Request Syntax Standard", PKCS#10, ~ (2000)
  13. RSA Laboratories, "Password-Based Cryptography Standard", PKCS#5, ~ (2012)
  14. M. Weir, "Password cracking using probabilistic context-free grammars", IEEE Symposium on Security and Privacy, pp.162~175 (2009)
  15. KISA, "Digital Signature Certificate Profile", KCAC.TS.CERTPROF, ~ (2009)
  16. KISA, "Accredited Certificate Request Message Format Specification", KCAC.TS.CRMF, ~ (2009)
  17. KISA, "User Interface Specification for the Interoperability between Accredited Certification Authorities", KCAC.TS.UI, ~ (2012)
  18. Research on the Actual condition of Electronic Signature System usage(in Electronic Signature User), "KISA", KISA, ~, pp.KISA-WP-2012-0003 (2011)
  19. Accredited certificate user statistics, "Ministry of Security and Public Administration", ~ (2012)

관련 논문AI추천

이 간행물의 다른 논문 (21건)