CASPER: Congestion Aware Selection of Path with Efficient Routing in Multimedia Networks
0
조회
0
다운로드
2
인용
0
참고문헌
키워드
초록
In earlier days, most of the data carried on communication networks was textual data requiring limited bandwidth. With the rise of multimedia and network technologies, the bandwidth requirements of data have increased considerably. If a network link at any time is not able to meet the minimum bandwidth requirement of data, data transmission at that path becomes difficult, which leads to network congestion. This causes delay in data transmission and might also lead to packet drops in the network. The retransmission of these lost packets would aggravate the situation and jam the network. In this paper, we aim at providing a solution to the problem of network congestion in mobile ad hoc networks [1, 2] by designing a protocol that performs routing intelligently and minimizes the delay in data transmission. Our Objective is to move the traffic away from the shortest path obtained by a suitable shortest path calculation algorithm to a less congested path so as to minimize the number of packet drops during data transmission and to avoid unnecessary delay. For this we have proposed a protocol named as Congestion Aware Selection Of Path With Efficient Routing (CASPER). Here, a router runs the shortest path algorithm after pruning those links that violate a given set of constraints. The proposed protocol has been compared with two link state protocols namely, OSPF [3, 4] and OLSR [5, 6, 7, 8].The results achieved show that our protocol performs better in terms of network throughput and transmission delay in case of bulky data transmission.
Abstract
In earlier days, most of the data carried on communication networks was textual data requiring limited bandwidth. With the rise of multimedia and network technologies, the bandwidth requirements of data have increased considerably. If a network link at any time is not able to meet the minimum bandwidth requirement of data, data transmission at that path becomes difficult, which leads to network congestion. This causes delay in data transmission and might also lead to packet drops in the network. The retransmission of these lost packets would aggravate the situation and jam the network. In this paper, we aim at providing a solution to the problem of network congestion in mobile ad hoc networks [1, 2] by designing a protocol that performs routing intelligently and minimizes the delay in data transmission. Our Objective is to move the traffic away from the shortest path obtained by a suitable shortest path calculation algorithm to a less congested path so as to minimize the number of packet drops during data transmission and to avoid unnecessary delay. For this we have proposed a protocol named as Congestion Aware Selection Of Path With Efficient Routing (CASPER). Here, a router runs the shortest path algorithm after pruning those links that violate a given set of constraints. The proposed protocol has been compared with two link state protocols namely, OSPF [3, 4] and OLSR [5, 6, 7, 8].The results achieved show that our protocol performs better in terms of network throughput and transmission delay in case of bulky data transmission.
참고문헌 (24)
- S. Corson, "RFC2501 - Mobile Ad hoc Networking (MANET): Routing Protocol", ~ (1999)
- "Internet Engineering Task Force, Manet working group charter"[URL]
- W. V. Wollman, "Overview of Open Shortest Path First, version 2 (ospf v2) routing in the tactical environment", Proc. of IEEE MILCOM, 3, pp.925~930 (1995)
- Moy J, "RFC-2328 OSPF v2", ~ (1997)
- P. Jacquet, "MANET draft “draft-ietfmanet- olsr-02.txt", ~ (2000)
- T. Clausen, "Project Hipercom, INRIA, RFC-3626: Optimized Link State Routing Protocol (OLSR)", ~ (2003)
- T. H. Clausen, "The Optimized Link State Routing Protocol Evaluation through Experiments and Simulation", Proc. of Wireless Personal Mobile Communications, Aalborg, Denmark (2001)
- Anis Laouti, "Simulation Results of the OLSR Routing Protocol for Wireless Networks", 1st Mediterranean Ad-Hoc Networks workshop (Med-Hoc- Net) (2002)
- Satish Jamadagni, "OSPF extensions for flexible CSPF algorithm support, Draftsatish- ospf-cspf-support-00", ~ (2002)
- A. Qayyum, "Multipoint Relaying for flooding broadcast messages in mobile wireless networks", Proc. 35th Ann. Hawaii Int’l Conf. System Sciences (HICSS-35), pp.298~307 (2002)
- P.Jacquet,P.Minet,P.Muhlethaler,N.Rivierre, "Increasing reliability in cable free radio LANs:Low level forwarding in HIPERLAN", Wireless Personal Communications, 4(1), pp.51~63 (1997)
- Y. Yong, "GDOP results in all-in-view positioning and in four optimum satellites positioning with GPS PRN codes ranging", Position Location and Navigation Symposium, 2004 (PLANS 2004), pp.723~727 (2004)
- "Qualnet 4.5 Programmer’s Guide" (2008)[URL]
- "Qualnet"[URL]
- "QualNet 4.5 Multimedia and Enterprise Model Library", ~ (2008)
- "Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) Specifications", IEEE 802.11 Standard, ~ (1997)
- [URL]
- "RFC 791 Internet Protocol, DARPA Internet Program Protocol Specification", ~ (1981)
- E. Baccelli, "OSPF Multipoint Relay (MPR) Extension for Ad Hoc Networks. Draft-ietf-ospf-manet-mpr-04", ~
- Richard Ogier, "OSPF-MDR Position. Draft-ogier-ospf-mdr-position-00.txt", ~
- D. Katz, "Traffic Engineering (TE) Extensions to OSPF Version 2. Draftkatz- yeung-ospf-traffic-01"
- J.-L. Le Roux, "Requirements for Inter-Area MPLS Traffic Engineering,RFC 4105", ~ (2005)
- Mohammad S. Obaidat, "DEESR: Dynamic Energy Efficient and Secure Routing Protocol for Wireless Sensor Networks in Urban Environments", JIPS(Journal of Information Processing Systems), 6(3), pp.269~294 (2010), 한국정보처리학회
