VoIP를 위한 보안 프로토콜 성능 평가
Performance Evaluation of VoIP Security Protocols
0
조회
0
다운로드
4
인용
0
참고문헌
초록
VoIP 서비스는 인터넷을 이용하기 때문에 기존 침해 및 공격이 쉽게 이루어질 수 있는 문제점을 가지고 있다. 특히 VoIP를 통해 제공되는 서비스는 사용자의 프라이버시와 관련된 정보를 다루기 때문에 사용자 인증, 시그널링 메시지나 미디어 스트림의 암호화/무결성 등의 보안은 필수적이고 VoIP 전화기에 보안을 위한 프로토콜의 구현은 한정된 연산 및 저장자원, 성능을 고려한 구현이 요구된다. 이에 따라 본 논문에서는 시그널링과 미디어를 위한 보안 프로토콜간의 성능평가를 통해 이러한 고려사항을 만족하는 프로토콜을 확인하고자 한다. 시그널링 보안으로 TLS와 DTLS, 미디어 보안으로 SRTP와 DTLS, 키 교환 프로토콜로 MIKEY, ZRTP, DTLS를 구현하고 SIP 프록시 및 UA(User Agent)에 적용하여 접속 품질과 음성 품질에 관한 프로토콜간의 비교를 수행하였다. 성능 평가 결과 보안 프로토콜 적용으로 인한 음성 품질의 저하가 발생하지 않았지만 접속 품질의 경우 DTLS를 기반으로 하는 보안 프로토콜이 비교적 우수한 성능으로 측정되었고, DTLS는 UDP를 기반으로 시그널링과 미디어 경로에 모두 적용이 가능하기 때문에 VoIP 전화기의 한정된 성능과 자원 문제를 해결할 수 있는 것으로 나타났다.
Abstract
VoIP utilizes the Internet for the services, and therefore it is vulnerable to intrusions and attacks. Because provided services deal with information related to privacy of users, it requires high‐level security including authentication and the confidentiality/integrity of signaling messages and media streams. However, when such a protocol is implemented in a VoIP phone, the implementation can have limitations due to the limited resources. The present study purposed to implement VoIP security protocols and to evaluate their performance in terms of connection quality and voice quality by applying them to SIP proxy and UA (User Agent). In the result of performance evaluation, the application of the security protocols did not lower voice quality, but connection quality was high in the DTLS‐based security protocol. As the protocol was applicable to signaling and media paths based on DTLS, we found that it can be a solution for the limited resources of VoIP phone.
참고문헌 (30)
- 한국정보보호진흥원, "VoIP 정보보호 가이드" (2005), 한국정보보호진흥원
- ETRI 기술평가팀, "VoIP 기술 및 시장 동향" (2006), ETRI 기술평가팀
- 한상윤, "국내 통신사업자를 위한 제언:“국내외 VoIP 제반 서비스에 대한 동향 보고" (2005)
- 김태현, "주요 국가별 VoIP 제도 및 서비스 현황" (2002)
- J. Rosenberg, "SIP:Session Initiation Protocol”, RFC 3261", ~ (2002)
- M. Handley, "SDP:Session Description Protocol”, RFC 4566", ~ (2006)
- H. Schulzrinne, "RTP:A Transport Protocol for Real- Time Applications”, RFC 3550", ~ (2003)
- M. Baugher, "The Secure Real-time Transport Protocol(SRTP)”, RFC 3711" (2004)
- D. Wing, "Disclosing Secure RTP (SRTP) Session Keys with a SIP Event Package" (2007)
- J. Arkko, "“MIKEY :Multimedia Internet KEYing”, RFC 3830", ~ (2004)
- P. Zimmermann, "ZRTP:Media Path Key Agreement for Secure RTP", draft-zimmermann-avt-zrtp-06 (2008)
- T. Dierks, "The Transport Layer Security(TLS) Protocol Version 1.1”, RFC4346", ~ (2006)
- E. Rescorla, "“Datagram Transport Layer Security”, RFC 4347", ~ (2006)
- R. Stewart, "Stream Control Transmission Protocol”, RFC 4960", ~ (2007)
- H. Tschofenig, "Real-Time Transport Protocol (RTP) over Datagram Tran- sport Layer Security (DTLS)", draft-tschofenig-avt-rtp-dtls-00 (2006)
- Modadugu, N., "Extensions for DTLS in Low Bandwidth Environments", draft-modadugu-dtls-short-00 (2005)
- D.McGrew, "D. McGrew, “The use of AES-192 and AES- 256 in Secure RTP”, draft-mcgrew-srtp-big- aes-00, 2006", ~ (2006)
- Rescorla, E., "TLS Partial Encryption Mode", draft-rescorla-tls-partial-00 (2006)
- Blake-Wilson, S., "Transport Layer Security (TLS) Extensions", draft-ietf-tls-rfc3546bis-02 (2005)
- D. McGrew, "Datagram Tran- sport Layer Security (DTLS) Extension to Establish Keys for Secure Real-time Transport Protocol (SRTP)", draft-mcgrew-tls-srtp-02 (2007)
- "SIP Express Router"[URL]
- "Minisip"[URL]
- J. Rosenberg, "STUN-Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)" (2003)
- "OmniPeek"[URL]
- "ITU-T Rec. G.107"[URL]
- "ITU-T recommendation P.800", ~
- "WireShark"[URL]
- "Cain"[URL]
- "Zfone"[URL]
