본문 바로가기
KERD
논문KCI 등재

Approach towards qualification of TCP/IP network components of PFBR

1

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류원자력공학

초록

Distributed control system architecture is adopted for I&C systems of Prototype Fast Breeder Reactor, where the geographically distributed control systems are connected to centralized servers & display stations via switched Ethernet networks. TCP/IP communication plays a significant role in the successful operations of this architecture. The communication tasks at control nodes are taken care by TCP/IP offload modules; local area switched network is realized using layer-2/3 switches, which are finally connected to network interfaces of centralized servers & display stations. Safety, security, reliability, and fault tolerance of control systems used for safety-related applications of nuclear power plants is ensured by indigenous design and qualification as per guidelines laid down by regulatory authorities. In the case of commercially available components, appropriate suitability analysis is required for getting the operation clearances from regulatory authorities. This paper details the proposed approach for the suitability analysis of TCP/IP communication nodes, including control systems at the field, network switches, and servers/display stations. Development of test platform using commercially available tools and diagnostics software engineered for control nodes/display stations are described. Each TCP link behavior with impaired packets and multiple traffic loads is described, followed by benchmarking of the network switch's routing characteristics and security features

Abstract

Distributed control system architecture is adopted for I&C systems of Prototype Fast Breeder Reactor, where the geographically distributed control systems are connected to centralized servers & display stations via switched Ethernet networks. TCP/IP communication plays a significant role in the successful operations of this architecture. The communication tasks at control nodes are taken care by TCP/IP offload modules; local area switched network is realized using layer-2/3 switches, which are finally connected to network interfaces of centralized servers & display stations. Safety, security, reliability, and fault tolerance of control systems used for safety-related applications of nuclear power plants is ensured by indigenous design and qualification as per guidelines laid down by regulatory authorities. In the case of commercially available components, appropriate suitability analysis is required for getting the operation clearances from regulatory authorities. This paper details the proposed approach for the suitability analysis of TCP/IP communication nodes, including control systems at the field, network switches, and servers/display stations. Development of test platform using commercially available tools and diagnostics software engineered for control nodes/display stations are described. Each TCP link behavior with impaired packets and multiple traffic loads is described, followed by benchmarking of the network switch's routing characteristics and security features

참고문헌 (39)

  1. T. Sridevi, "Embedded system design for I&C of prototype fast breeder reactor", International Conference on Robotics, Automation, Control and Embedded Systems, 2 (2015)
  2. Srikantam Sravanthi, "Safety criteria and dependability management practices : a case study with I&C systems of prototype fast breeder reactor", Nucl. Technol, 201(2), pp.180~189 (2018)
  3. A.E.R.B. Safety Guide, Safety Systems for Pressurized Heavy Water Reactors, , AERB Mumbai India, 1~2, pp.AERB (2005), NPP-PHWR[DOI]
  4. A.E.R.B. Safety Guide, Computer Based Systems of Pressurized Heavy Water Reactors, , AERB Mumbai India, 6~17, pp.AERB (2010), NPP-PHWR[DOI]
  5. N. Sridhar, "Computer based systems for prototype fast breeder reactor", International Conference on Advancements in Nuclear Instrumentation, Measurement Methods and Their Applications (2009)
  6. M. Manimaran, "Software development methodology for computer based I&C systems of prototype fast breeder reactor", Nucl. Eng. Des, 292, pp.46~56 (2015)
  7. Technical Challenges in the Application and Licensing of Digital Instrumentation and Control Systems in Nuclear Power Plants, "IAEA", 13~, pp.NP-T-1.13 (2015)
  8. P. Parimalam, "Convenient and elegant HCI features of PFBR operator consoles for safe operation", International Conference on Intelligent Human Computer Interaction (2012)
  9. Aditya Gour, "Hardware & software implementation for real time computer based fresh subassembly handling system of PFBR", IEEE India Council International Conference (2019)
  10. M. Manimaran, "Real time computer for plugging indicator control of prototype fast breeder reactor", International Conference on Advancements in Nuclear Instrumentation, Measurement Methods and Their Applications (2013)
  11. Internet Protocol Specification, "Jon Postel", Information Sciences Institute, University of Southern California, ~, pp.RFC-791 (1981)
  12. Internet Control Message Protocol Specification, "Jon Postel", Information Sciences Institute, University of Southern California, ~, pp.RFC 792 (1981)
  13. Transmission Control Protocol Specification, "Jon Postel", Information Sciences Institute, University of Southern California, ~, pp.RFC 793 (1981)
  14. I. E. E. E. Computer Society, "IEEE Standard for Ethernet", Section 1 & 2, IEEE Std, ~ (2018)
  15. M. Manimaran, "Fault tolerant distributed real time computer systems for I&C of prototype fast breeder reactor", Nucl. Eng. Des, 268, pp.96~103 (2014)
  16. Wiznet, "NM7010Bþ Datasheet", 5~6 (2008)
  17. Aditya Gour, "Development of FPGA based TCP", IP communication module for embedded systems of nuclear reactors, 2020, ~
  18. "T.C.P.", I.P. Wiznet, Offload Platform - W3150Aþ Datasheet, 2019, pp.3~4
  19. Haoliang Lan, "Application-level packet loss rate measurement based on improved L-rex model", Symmetry, 11(4), pp.442~ (2019)
  20. Danyang Zhuo, "Understanding and mitigating packet corruption in data center networks", Conference of the ACM Special Interest Group on Data Communication (2017)
  21. Cardwell Neal, "Modelling TCP latency", Joint Conference of the IEEE Computer and Communications Societies (2000)
  22. Sharad Jaiswal, "Measurement and classification of out-of-sequence packets in a tier-1 IP backbone", Annual Joint Conference of the IEEE Computer and Communications Societies (2003)
  23. Hao Jiang, "Constantinos Dovrolis, Source-level IP packet bursts: causes and effects", ACM SIGCOMM Conference on Internet Measurement (2003)
  24. "Spirent, Network Emulator Datasheet", 3~9 (2021)
  25. Xena Networks, "CHIMERA Network impairment emulator Datasheet", ~ (2021)
  26. Ixia, "Predicting and Managing Network Impairments", 5~9 (2015)
  27. "Spirent, Spirent Test Center on C50 Appliance", ~ (2019)
  28. Keysight, "IxNetwork OverviewdL2", 3 Network Infrastructure Performance Testing, 2021, pp.3120~1106
  29. Xena Networks, "ValkyrieManager- Ethernet Traffic Generation & Analysis Software Datasheet", ~ (2021)
  30. Benchmarking Methodology for Network Interconnect Devices, "S. Bradner", 15~18, pp.RFC 2544 (1999)
  31. Spirent Communications, "The definitive guide to switch testing", Test Methodology Journal, pp.3~117 (2007)
  32. A. Guruprasad, "Security features in Ethernet switches for access networks", Conference on Convergent Technologies for Asia-Pacific Region (2003)
  33. Allied Telesis, "Create A Secure Network with Allied Telesis Managed Layer 3Switches", C613-16103-00 Rev A, ~ (2007)
  34. Wiznet, "W3150Aþ", W5100 Errata Sheet, 2015
  35. Wiznet, "Limitation Note - ARP Problem in the NLB Environment, 2018. Ver. 1.0", ~ (2018)
  36. V. Rajan Babu, "Testing and qualification of control & safety rod and its drive mechanism of fast breeder reactor", Nucl. Eng. Des, 240(7), pp.1728~1738 (2010)
  37. Nerea Fern"andez-Berrueta, "An overview of current IP network emulators for the validation of railways wireless communications", IEEE Access, 8, pp.109266~109274 (2020)
  38. Shaoqiang Wang, "Analysis and application of Wireshark in TCP", IP protocol teaching, 2010, ~
  39. Wei-jia Sun, "Ethernet switch-based security risks and defense method research", International Conference on Computational and Information Sciences (2011)

관련 논문AI추천

이 간행물의 다른 논문 (39건)