본문 바로가기
KERD
논문KCI 등재

블록체인과 TOTP를 이용한 사물인터넷 인증시스템

IoT Authentication System Using Blockchain and TOTP

0

조회

0

다운로드

3

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

이 논문에서는 블록체인과 TOTP(Time-based One-time Password Algorithm)를 이용하여 사용자 장치와 서비스 장치 사이의 지속적인 인증을 유지하는 단말기 인증 시스템을 제시하고 이 사물인터넷의 단말기로서 도어-록에 적용하여 실험하였다. 앞으로 IoT의 여러 장치들에 편리와 보안을 위하여 이 시스템을 적용할 수 있다. 사물인터넷(IoT, Internet of Things) 기술이 발전하면서 사물인터넷 장치들의 편의성과 보안성이 동시에 요구되고 있다. 사물인터넷 장치들은 저용량, 경량의 특징을 가지고 있으나 높은 연산량을 요구하는 기존의 인증기술을 적용하기 어렵기 때문에 사물인터넷 보안에 위협이 되고 있다. 최근 위변조가 불가능한 블록체인 기술로 보안성과 무결성을 제공하는 저장 플랫폼을 적용하였으나 단말기가 네트워크에 접속할 수 없을 때 블록체인을 이용한인증을 수행할 수 없다. 이 문제점을 블록체인과 TOPT를 이용하여 해결하는 시스템을 보여준다.

Abstract

In this paper, we propose the terminal authentication system using blockchain and TOTP(Time-based One-time Password Algorithm) to sustain a continuous authentication between user device and service device. And we experiment this system by using door-lock as a terminal of IoT(Internet of Things). In the future, we can apply this result to several devices of IoT for convenience and security. Although IoT devices frequently used everyday require convenience and security at the same time, it is difficult for IoT devices having features of the low-capacity and light-weight to apply the existing authentication technology requiring a high amount of computation. Blockchain technology having security and integrity have been used as a storage platform, but its authentication cannot be performed when the terminal cannot access any network. We show the method to solve this problem using Blockchain and TOPT.

참고문헌 (19)

  1. "ITU-T, Security framework for the Internet of things based on the gateway model, ITU-T Recommendation X. 1361", 4~ (2018)
  2. Slock.it, Inc, "BLOCK-CHAIN ENABLED SERVICE PROVIDER SYSTEM, US 2018", 0191714 A1, 2018
  3. "46halbe, Chaos Computer Clubs breaks iris recognition system of the Samsung Galaxy S8" (2017)[URL]
  4. Park. Byungju, "IoT industry trends and development prospects", Weekly Technology Trend, (1759), pp.14~23 (2016), IITP
  5. S. Keoh, "Securing the internet of things : A standardization perspective", IEEE Internet of Things Journal, 1(3), pp.265~275 (2014)
  6. "Chaos Computer Club breaks Apple TouchID" (2013)[URL]
  7. J. Padgette, "Guide to Bluetooth Security, NIST Special Publication 800-121 Revision 1", ~ (2012)
  8. D. M'Raihi, "TOTP: Time-Based One-Time Password Algorithm, RFC 6238", ~ (2011)
  9. S. Nakamoto, "Bitcoin: A peer-to-peer electronic cash system" (2008)
  10. A. Juels, "RFID Security and Privacy : A Research Survey", IEEE Journal On Selected Areas In Communications, pp.381~394 (2006)
  11. H. Torstein, "Security and Privacy in RFID Applications", pp.2006
  12. D. M'Raihi, "HOTP: An HMAC-Based One-Time Password Algorithm, RFC 4226", ~ (2005)
  13. "Hashcash - a denial of service counter-measure" (2002)[URL]
  14. N. Haller, "A One-Time Password System, RFC 2289", ~ (1998)
  15. Computer Emergency Response Team (CERT), "IP Spoofing and Hijacked Terminal Connections, CA-95:01", ~ (1995)
  16. Haller, N., "On Internet Authentication, RFC 1704", ~ (1994)
  17. "Hacker claims you can steal fingerprints with only a camera"[URL]
  18. "Face ID iPhone X 'hack' demoed live with mask by Bkav"[URL]
  19. "The Signidice Algorithm"[URL]

관련 논문AI추천

이 간행물의 다른 논문 (27건)