본문 바로가기
KERD
논문KCI 등재

개방형 ICT 환경을 위한 집중식 원격 보안 서비스프로비저닝 프레임워크 구성 방안

Smart Centralized Remote Security Service Provisioning Framework for Open ICT Environment

1

조회

0

다운로드

1

인용

0

참고문헌

키워드

주제분류학제간연구

초록

사물 간 통신기술인 M2M(machine to machine)은 각각의 구성 장치(사물)에 인터넷과의 연결성을 제공하면서 IoT 기술로 확장 발전되고 있다. IoT(Internet of Thing)는 수없이 많은 종류의 장치들이 인터넷 프로토콜을 이용하여 통신 서비스를 제공하는 하나의 트렌드를 나타낸다. IoT의 개념이 확산되면서 홈 내에 다양한 오브젝트가 정보 수집의 대상이 되고 있다. 최근 무수히 많은 다양한 장비들이 보급되면서 각각의 장비에 접근하는 방법이 너무 많아지고, 개발자로서 그들을 접근 제어하기 위해서는 무수히 많은 노력과 시간이 소비된다. 이러한 환경에서 다양한 응용 및 서비스를 창출하기 위해 보안은 중요한 요소가 된다. 본 논문에서는 자원이 제한된 장치 간 인증 및 데이터 송신 인증 시스템과 장치 간 인증을 고려한 Open M2M 환경에서의 중앙집중식 원격 보안 프로비저닝 프레임워크 방안을 제안하였다. 본 연구에서 도출된 인증 메커니즘 프레임워크는 온라인 개인정보뿐만 아니라 다른 기술과 서비스 환경에서의 개인정보 활용 사례에 적용할 수 있을 것으로 예상된다.

Abstract

Machine-to-Machine (M2M) communication provides each component (machine) with access to Internet, evolving into the IoT technology. IoT is a trend where numbers of devices provide the communication service, using the Internet protocol. As spreading the concept of IoT(Internet of Things), various objects become home information sources. According to the wide spread of various devices, it is difficult to access data on the devices with unified manners. Under this environment, security is a critical element to create various types of application and service. In this paper propose the inter-device authentication and Centralized Remote Security Provisioning framework in Open M2M environment. The results of previous studies in this task is carried out by protecting it with the latest information on M2M / IoT and designed to provide the ultimate goal of future M2M / IoT optimized platform that can be integrated M2M / IoT service security and security model presents the information.

참고문헌 (27)

  1. Bhattacharyya, "Lightweight mutual authentication for CoAP(WIP), Internet Draft, draft-bhattacharyya-core-coap-lite-auth-00", ~ (2014)
  2. Schmitt, "DTLS-based security with two-way Authentication for IoT-02, Internet Draft, draft-schmitt-two-way-authentication-for-iot-02", ~ (2014)
  3. Forsberg, "Protocol for Carrying Authentication for Network Access(PANA)", RFC 5191, ~ (2008)
  4. Hardt, "The OAuth 2.0 Authorization Framework", IETF, RFC 6749, ~ (2012)
  5. Dave Evans, "The Internet of Things-How the Next Evolution of the Internet is changing everything", Cisco IBSG, ~ (2011)
  6. Namje Park, "Implementation of load management application system using smart grid privacy policy in energy management service environment", CLUSTER COMPUTING, 17(3), pp.653~664 (2014), SPRINGER
  7. Rescolrla, "Datagram Transport Layer Security Version 1.2", RFC6347, IETF, ~ (2012)
  8. ETSI, "Machine-to-Machine Communication(M2M); Functional Architecture, Draft TS 102 690, V2.1.1", ~ (2013)
  9. ETSI, "Machine-to-Machine Communication(M2M); Service Requirements, Draft TS 102 689, V1.1.1", ~ (2010)
  10. Namje Park, "Implementation of Inter-VTS Data Exchange Format Protocol based on Mobile Platform for Next-generation Vessel Traffic Service System", INFORMATION-AN INTERNATIONAL INTERDISCIPLINARY JOURNAL, 17(10(A)), pp.4847~4856 (2014), INT INFORMATION INST
  11. H.Tschofenig, "The OAuth 2.0 Internet of Things (IoT) Client Credentials Grant, draft-tschofenig-ace- oauth-iot-00.txt", ~ (2014)
  12. Namje Park, "Inter-Authentication and Session Key Sharing Procedure for Secure M2M", IoT Environment, 2015, pp.18(1), 261~266[DOI]
  13. Namje Park, "Mutual Authentication Scheme in Secure Internet of Things Technology for Comfortable Lifestyle", Sensors, 16(1), pp.1~16 (2016)[DOI]
  14. oneM2M, "oneM2M_TR-0008-Security-V1_0_0", ~ (2014)
  15. oneM2M, "oneM2M_TS-0001-Functional_Architecture-V1.0.0 Baseline Draft", ~ (2014)
  16. 박남제, "안전한 모바일 RFID 리더를 위한 개방형 임베디드 소프트웨어 플랫폼 구현 방안", 한국통신학회논문지B, 35(5), pp.785~793 (2010), 한국통신학회
  17. oneM2M, "oneM2M_TS-0003-Security_Solutions-V-2014-08", ~ (2014)
  18. K. Oh, "Implementation of public key-based key distribution in wireless sensor network", Proc. KOSBE, pp.95~98 (2008)
  19. Namje Park, "Security and Privacy Mechanisms for Sensor Middleware and Application in Internet of Things (IoT)", International Journal of Distributed Sensor Networks (2015)
  20. Namje Park, "Mobile middleware platform for secure vessel traffic system in IoT service environment, Security and Communication Networks" (2015), John Wiley&Sons Ltd
  21. 이보성, "클라우드 서비스 유형별 개인정보보호 방안", 정보보호학회논문지, 25(5), pp.1245~1255 (2015), 한국정보보호학회[DOI]
  22. Park, N., "WIPI Mobile Platform with Secure Service for Mobile RFID Network Environment. In Proceedings of the APWeb Workshops 2006", LNCS, 3842, pp.741~748 (2006), Springer
  23. 김보, "모바일 앱 개인정보 침해현황 및 대응방안 (금융, 안드로이드 운영체제 중심으로)", 한국인터넷방송통신학회 논문지, 14(6), pp.267~272 (2014), 한국인터넷방송통신학회[DOI]
  24. 정윤수, "모바일 오피스 환경에서 스마트폰 사용자의 개인정보유출 방지 기법", 디지털융복합연구, 13(5), pp.205~211 (2015), 한국디지털정책학회[DOI]
  25. Park, N., "Customized Healthcare Infrastructure Using Privacy Weight Level Based on Smart Device", Commun. Comput. Inf. Sci, 206, pp.467~474 (2011)
  26. 최희식, "모바일 환경에서 개인정보 유출 방지를 위한 개선 연구", (사)디지털산업정보학회 논문지, 11(3), pp.53~62 (2015), (사)디지털산업정보학회[DOI]
  27. Park, N., "Implementation of Terminal Middleware Platform for Mobile RFID Computing", Int. J. Ad Hoc Ubiquitous Comput, 8, pp.205~219 (2011)

관련 논문AI추천

이 간행물의 다른 논문 (27건)