본문 바로가기
KERD
논문KCI 등재

로컬 IoT 네트워크를 위한 영역 기반 애드혹 네트워크 구성 기법

Zone based Ad Hoc Network Construction Scheme for Local IoT Networks

0

조회

0

다운로드

2

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

In this paper, we propose a zone based ad hoc network construction scheme which support ad hoc path between nodes in local IoT networks consisting of IoT devices with the constrained feature, such as low power, the limited transmission rate and low computing capacity. Recently, the various routing protocols have been studied to support ad hoc networking of local IoT environments. This is, because basis RPL protocol is deigned to be used for the connecting service with Internet through gateway, ad hoc path between nodes in local IoT networks is not supported in basis RPL protocol. Thus, in this paper, the proposed routing scheme provides both ad hoc path and Infra path through gateway, supporting basis RPL protocol simultaneously. Through simulation, we show that the proposed routing scheme with zone based path selection scheme improves the performance of the success rate of end-to-end data transmission and the end-to-end delay, compared to basis RPL protocol.

Abstract

In this paper, we propose a zone based ad hoc network construction scheme which support ad hoc path between nodes in local IoT networks consisting of IoT devices with the constrained feature, such as low power, the limited transmission rate and low computing capacity. Recently, the various routing protocols have been studied to support ad hoc networking of local IoT environments. This is, because basis RPL protocol is deigned to be used for the connecting service with Internet through gateway, ad hoc path between nodes in local IoT networks is not supported in basis RPL protocol. Thus, in this paper, the proposed routing scheme provides both ad hoc path and Infra path through gateway, supporting basis RPL protocol simultaneously. Through simulation, we show that the proposed routing scheme with zone based path selection scheme improves the performance of the success rate of end-to-end data transmission and the end-to-end delay, compared to basis RPL protocol.

참고문헌 (11)

  1. 신승혁, "IoT 환경에서 실시간 모니터링을 위한 웹 서비스 미들웨어에 관한 연구", 한국컴퓨터정보학회논문지, 20(9), pp.97~104 (2015), 한국컴퓨터정보학회
  2. Zhengguo Sheng, "Leung, V. C. M. Lightweight Management of Resource-Constrained Sensor Devices in Internet of Things", IEEE Journals & Magazines, 2(5), pp.402~411 (2015)
  3. 홍용근, "이동통신 네트워크에서 M2M 서비스를 위한 M2M 식별자 연구", 한국컴퓨터정보학회논문지, 17(11), pp.63~71 (2012), 한국컴퓨터정보학회
  4. Terminology for Constrained Node Networks, "Bormann, C", IETF, ~, pp.IETF RFC 7228 (2014)
  5. The Constrained Application Protocol (CoAP), "Shelby, Z", IETF, ~, pp.IETF RFC 7252 (2014)
  6. J-S. Youn, "The overview of IETF technology standard for IoT", INFORMATION AND COMMUNICATIONS MAGAZINE(Information and Communication), 31(9), pp.32~39 (2014)
  7. RPL: IPv6 Routing Protocol for Low-Power and Lossy Networks, "Winter, T", ~, pp.RFC 6550 (2012)
  8. Y. Xu, "Near optimal multi-application allocation in shared sensor networks", MobiHoC 2010, pp.181~190 (2010)
  9. D. Carels, "Support of multiple sinks a via virtual root for the RPL routing protocol", EURASIP J. Wireless Commun. Netw, 2014(91), pp.1~23 (2014)
  10. "NS3 Project"[URL]

관련 논문AI추천

이 간행물의 다른 논문 (22건)