본문 바로가기
KERD
논문KCI 등재

H.264 콘텐츠 스트리밍을 위한 효율적인 DRM 시스템의 설계 및 구현

Design and Implementation of Efficient DRM System for Contents Streaming based on H.264

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

멀티미디어 기기와 인터넷의 발달로 디지털 콘텐츠의 제작과 유통이 일반화 되면서 스트리밍 방식의 DRM 시스템이 중요한 위치를 차지하게 되었다. 기존의 스트리밍 방식의 DRM 시스템은 콘텐츠의 모든 데이터를 암호화함으로써 시스템에 많은 부하를 가져왔다. 본 논문에서는 데이터의 일부만을 암호화하여 시스템 성능을 극대화하고, 암호화된 콘텐츠를 네트워크 프로토콜에 독립적으로 전송할 수 있는 스트리밍 방식의 DRM 시스템을 제안하고, 제안하는 시스템을 구현하여 성능 분석한 결과를 제시한다.

Abstract

DRM system with streaming scheme has obtained it’s priority due to generalized production and distribution of digital contents by development of multimedia device and internet. Previous DRM system with streaming scheme over-burdened the system by encrypting every data of the contents. This paper presents DRM system with new streaming scheme that is able to independently transmit encrypted contents to network protocol and maximize system function by encrypting only certain parts of data. Also, performance is analyzed through designing and implementing the proposed system.

참고문헌 (14)

  1. 정연정, "MPEG-2 Streaming DRM 시스템 설계 및 구현", 정보보호학회지, 14(6), pp.75~81 (2004)
  2. 이진흥, "컨텐츠 스트리밍을 위한 안전한 DRM 시스템 설계및구현", 정보보호학회논문지, 13(4), pp.177~186 (2003), 한국정보보호학회
  3. Y. Zou, "H.264 Video Encryption Scheme Adaptive to DRM", IEEE Transactions on Consumer Electronics, 52(4), pp.1289~1297 (2006)
  4. "Internet Streaming Media Alliance, “ISMA Encryption and Authentication Specification Ver. 1.1,”", ~ (2005)
  5. RTP : A Transport Protocol for Real-Time Application, "H. Schulzrinne", ~, pp.RFC 3550 (2003)
  6. RTP Payload Format for MPEG-4 Streams, "B. Moore", ~, pp.RFC 3460 (2003)
  7. RTP Payload Format for MPEG-4 Audio, "-Visual Streams", Y. Kikuchi, 2000, RFC 3016
  8. T. Weigand, "Overview of the H.264", AVC Video Coding Standard, 2003, pp.13(7), 5650~5576
  9. "ISO", IEC 14496-10:2003, Information technology- Coding of audio-visual objects-Part 10: Advanced Video Coding
  10. "ISO", IEC 14496-15:2003, Information technology- Coding of audio-visual objects-Part 15: Advanced Video Coding
  11. "ISO", IEC 14496-12:2003, Information technology- Coding of audio-visual object-Part 12: ISO Base Media File Format
  12. "JVT Reference Software Version 9.5"[URL]
  13. AVC 표준의 소스 코드 분석, "H.264", pp.2007, 호요성
  14. AVC 비디오 압축 표준, "H.264", pp.2005, 정제창

관련 논문AI추천

이 간행물의 다른 논문 (4건)