Pre_Buffered 키스트림을 이용한 효율적인암호처리 구현
Efficient Implementation of Crypto Processing Based on Pre_Buffered Key Stream Method
0
조회
0
다운로드
0
인용
0
참고문헌
키워드
초록
모바일기기, 이동통신망, 유․무선 통신망의 발전으로 모바일 오피스 도입이 확산되고 있으나, 적절한 보안 대책선행이 요구되고 있다. 본 논문은 모바일 환경의 통신 구간 보안을 위해 H/W 토큰을 이용한 IPSec VPN 솔루션을구현함에 있어, H/W 토큰의 I/O 지연에 따른 성능 문제를 극복하는 방안으로 카운터 모드를 이용한 스트림 암호방식을 적용하되 키스트림을 버퍼링하는 방안을 제안하고, 버퍼링 방식이 IP 패킷의 가변 크기, 유실 및 비순차적인전송 환경에서도 적용 가능한 설계를 제시하고, 구현 결과를 버퍼링을 적용하지 않은 기존 방식과 성능 비교를 통해제안한 방식의 효율성을 증명한다.
Abstract
Mobile devices use VPN solution to transfer information securely through open network in mobile office environment. Inthis paper, we propose Pre_Buffered mechanism that improves the throughput of IPSec VPN using low performance H/Wcrypto Token. Pre_Buffered method precompute key stream, store them in Buffer and use them in IPSec engine for IP packetprocessing. Moreover, Design, analysis, and experimental results prove the efficiency and feasibility of our proposed method.
참고문헌 (15)
- S. Kent, "Security Architecture for the Internet Protocol", RFC 4301, ~ (2005)
- T. Dierks, "The Transport Layer Security (TLS) Protocol Version 1.2", RFC 5246, ~ (2008)
- D. Naccache, "Cryptographic smart cards", IEEE Micro, 16(3), pp.16~24 (1996)
- S. Kent, "IP Authentication Header (AH)", RFC 4302, ~ (2005)
- S. Kent, "IP Encapsulating Security Payload (ESP)", RFC 4303, ~ (2005)
- C. Kaufman, "The Internet Key Exchange (IKEv2) Protocol", RFC 4306, ~ (2005)
- NIST, "Advanced Encryption Standard (AES)", FIPS PUB 197, ~ (2001)
- Morris Dworkin, "Recommendation for Block Cipher Modes of Operation : Methods and Techniques", SP 800-38A, ~ (2001)
- R. Housley, "Using AES Counter Mode With IPSec ESP", RFC 3686, ~ (2004)
- P. Urien, "SSL in smart card", Proc. of Networking and Computer Science PHD days ("Journees Doctorales Informatique et Reseaux"), JDIR 2000 (2000)
- M. Badra, "Toward SSL integration in SIM SmartCards", Proc. of Wireless Communications and Networking Conference, pp.889~893 (2004)
- P. Urien, "EAP-TLS smartcards, from dream to reality", Proc. of Applications and Services in Wireless Networks, pp.39~45 (2004)
- C.H. Yang, "An Integration of PKI and IC cards for IPSec", Proc. of Sympoisum on Cryptography and Information Security (2004)
- P. Urien, "Tandem smart cards: enforcing trust for TLS-based network services", Proc. of Applications and Services in Wireless Networks, pp.96~104 (2008)
- CISCO Systems, "Voice Over IP - Per Call Bandwidth Consumption", Tech Notes, Document ID : 7934, ~ (2006)
