고정IP 기반의 IPv6를 이용한 사물인터넷 제품 추적 및 재고관리 시스템 제언
The Proposal of IoT products tracking and inventory management system using IPv6 based on static IP
0
조회
0
다운로드
3
인용
0
참고문헌
키워드
초록
IPv4 주소가 고갈됨에 따라 한계점을 해결하기 위해 나타난 IPv6 주소체계가 서서히 다양한 분야에서 활용되고있다. 최근에는 다양한 사물과 네트워킹 할 수 있는 사물인터넷(IoT) 제품들이 등장하기 시작하였다. 사물인터넷이많은 분야에 점차 적용되고 네트워킹 기술이 포함된 전자기기 보급이 증가함에 따라, 각 기기마다 IPv6의 IP주소를부여받게 될 것이다. 사물조차도 주소를 가지게 되면서 IP주소 관리시스템이 더욱 중요하다. IP주소를 가지고 있는전자기기가 더 이상 사용되지 않고 있을 때, 그 전자기기의 IP주소를 추적 및 회수하기 위한 보완된 물류관리시스템이 필요하다. 본 논문에서는, 사물인터넷 제품에 각각 고정된 IPv6의 IP주소를 할당하여 이러한 IP주소와 네트워크를 기반으로 한 위치기반서비스를 이용하여 각 제품의 현재 위치를 추적하고, 창고 내의 제품을 관리하고자 한다. 필요시 IP 주소를 회수할 수 있는 새로운 물류추적 및 재고관리 시스템을 제언한다.
Abstract
The IPv6 which solved the exhaustion problem of IPv4's IP address is going to be used for many kinds of industries. As a result, there are some products which can be connected to other connectable things, it called Internet of Things (IoT). With growing new propagated products including networking, each product can get an IP address of IPv6, which means it is possible that things also have their own IP addresses. Thus, IP address management system is more important and needs tracking and collecting system for unused products with IP addresses. This study suggests new distribution tracking and inventory management system for IoT products, which offers a current location of things and manages stocks in the warehouse with the static IP address and the location-based service.
참고문헌 (29)
- M. Weiser, "The Computer for the 21st Century", ACM SIGMOBILE Mobile Computing and Communications Review, 3(3), pp.3~11 (1999)
- Gartner, "2012 Gartner's Hype Cycle for Emerging Technologies", ~ (2012)
- "MarketandMarket"[URL]
- DataNet, "IPv4 allotment, actually termination", ~ (2011)
- ITU Internet Reports 2005, Internet of Things, "ITU", ~ (2005)
- "IERC (European Research Cluster on the Internet of Things)"[URL]
- The fundamental plan of machine to machine basis construction, "Korea Communications Commission", ~ (2009)
- Tae-shik Shon, "Security trends of IoT (Internet of Things) in Cloud Computing", Journal of the Korea Institute of Information Security and Cryptology, 22(1), pp.20~30 (2012)
- "M2M service requirements standardization", TTAK. KO-06.0301, TTA, ICT Standardization Committee, ~ (2012)
- Ho-won Kim, "IoT technology and security", Journal of the Korea Institute of Information Security and Cryptology, 22(1), pp.7~13 (2012)
- IoT primary plan, "Ministry of Science, ICT and Future Planning", ~ (2014)
- Chol-shik Pyo, "IoT technology trends", The Journal of Korean Institute of Electromagnetic Engineering and Science, 25(4), pp.49~58 (2014)
- "IoT technology and convergence service workshop", The Institute of Electronics and Information Engineers: M2M, 2014, ~[DOI]
- Dong-il Lee, "Integrated IP address management system based on IP agents", 석사, pp.2013
- S. Deering, "Internet Protocol Version 6(IPv6)Specification", RFC 2460, ~ (1998)
- A. Conta, "Internet Control Message Protocol(ICMPv6)for the Internet Protocol Version 6(IPv6)Specification", RFC 4443, ~ (2006)
- T. Narten, "Neighbor Discovery for IP Version 6(IPv6)", RFC 4861, ~ (2007)
- Ji-soo Oh, "A Study on Privacy Issue for IPv6 Stateless Address Autoconfiguration", The 35th Conference of the KIPS (2011)
- Seong-goo Kang, "A Response Mechanism for Denying DoS Attacks abusing IPv6 Address Auto-configuration", ProceedingsⅠof The Korean Institute of Information Scientists andEngineers, 31(2), pp.493~495 (2004)
- 정연기, "IPv6 환경에서 호스트 탐색 및 네트워크 접속 차단 에이전트 시스템", 멀티미디어학회논문지, 14(1), pp.144~152 (2011), 한국멀티미디어학회
- CISCO Visual Networking Index: Global Mobile Data Traffic Forecast Update 2013-2018, "CISCO", ~ (2014)
- IPv6 focus Internet of Things technology trends, "Kee-hun Sung", Korea Internet & Security Agency, ~ (2014)
- 남선미, "위치기반서비스(LBS)의 규제와 시장 활성화에 관한 연구", 인터넷정보학회논문지, 15(4), pp.141~152 (2014), 한국인터넷정보학회[DOI]
- Hee-chan Lee, "Design and Implementation of IP address management system", ProceedingsⅠof The Korean Institute of Information Scientists and Engineers, 32(2), pp.232~234 (2005)
- 배상욱, "IPv6 호스트 접근제어를 위한 IPv6 주소관리서버의 설계 및 구현", 정보과학회논문지 : 정보통신, 41(1), pp.13~21 (2014), 한국정보과학회
- Kyoung-jun Lee, "IoT and business opportunity : smart things like omnipotent rice cooker adding recipe, bring about function revolution", Donga Business Review, 159~ (2014)
- 정창훈, "위치 기반 서비스를 위한 동적 위치 인지 기법", 한국산학기술학회논문지, 15(7), pp.4562~4572 (2014), 한국산학기술학회[DOI]
- Korea Communications and Commission, "The law of location information protection, use, and so forth (abbreviation:Location information law)", ~ (2014)
- 김순석, "RFID 기술을 이용한 제품 재고관리 및 위치추적시스템", 보안공학연구논문지, 5(5), pp.381~392 (2008), 보안공학연구지원센터
