본문 바로가기
KERD
논문KCI 등재

신뢰성 있는 단방향 데이터 전송 시스템 설계

Design of a Reliable Data Diode System

0

조회

0

다운로드

2

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

단방향 전송 기술에서 해결해야 할 이슈들 중에 한 가지는 TCP 기반의 데이터 전송에서 발생하는 패킷 손실을 줄이는 것이다. 잘 알려진 에러 수정 기법들을 활용해서 패킷 손실을 줄일 수 있다. 하지만, 기존의 여러 기법들을 활용한다고 하더라도, 링크 에러와 버퍼 오버플로우에 의한 패킷 손실은 여전히 발생할 수 있다. 본 논문에서는 신뢰성 있는 단방향 데이터 전송 시스템(RED, REliable Data diode)을 제안한다. RED는 기존의 단방향 전송 기술과 마찬가지로TCP 기반의 데이터 전송을 지원하기 위해 TCP 프록시 기법을 활용한다. RED 송신시스템은 TCP 패킷의 지연 전송을 활용하여 버퍼 오버플로우에 의한 패킷 손실을 줄일수 있다. 또한, RED 송신시스템은 패킷의 중요도 및 여유 자원을 고려하여, RED 수신시스템에게 다수의 동일한 패킷을 복제 및 전송함으로써, 단방향 전송 링크에서의 링크 에러에의한 패킷 손실을 줄일 수 있다.

Abstract

One of the issues, which is dealed with in undirectional data transmission technology, is reducing the packet loss in TCP based data transfer. We can decrease the packet loss by using several well known error correction approaches. Although we utilize those previous approaches, the packet loss by both link errror and buffer overflow could be occurred. In this paper, we propose the RED(REliable Data diode). RED also uses the TCP proxy approach for supporting the TCP based data transfer which is similar with the existing unidirectional data transmission technologies. The RED transmission system could alleviate the packet loss caused by buffer overflow by exploiting the delaying transmission of TCP packets. Furthermore, in order to reduce the packett loss caused by link error in the unidirectional transmission link, the RED transmission system transmits one or more duplicated packets to the RED reception system by considering both the remaining resources and packet importance.

참고문헌 (29)

  1. "Wiki: Unidirectional Network"[URL]
  2. M. H. Kang, "The pump : A Decade of Covert Fun", Proceedings of 21st Annual Computer Security Applications Conference, pp.352~360 (2005)
  3. David M. Goldechlag, "Several Secure Store and Forward Devices", Proceedings of the Third ACM Conference on Computer and Communications security, pp.129~137 (1996)
  4. "Receive-only UTP cables and Network Taps" (2004)[URL]
  5. "Waterfall One-Way"[URL]
  6. "Dual diode"[URL]
  7. H. Okhravi, "Data diodes in support of trustworthy cyber infrastructure", Proceedings of the Sixth Annual Workshop on Cyber Security and Information Intelligence Research (CSIIRW), pp.231~234 (2010)
  8. R. Mraz, "Concurrent Data Transfer Involving Two or More Transport Protocols Over a Single One-Way Data Link", US Patent No. 8,139,581, ~ (2012)
  9. C. A. Nilsen, "Method for Transferring Data from an Unsecured Computer to a Secured Computer", US Patent No. 5,703,562, ~ (1997)
  10. Lin Honggang, "Research on Packet Loss Issues in Unidirectional Transmission", Journal of Computers, 8(10), pp.2664~2671 (2013)
  11. J. Menoher, "All Data Diodes Are Not Equal" (2013)
  12. Fox-IT, "Fox DataDiode: A Pereferred Solution for high-security real-time electronic unidirectional data transfer between networks" (2008)
  13. A Design of Unidirectional Security Gateway for Enforcement Security and Reliability for Transfer Data, "Y. Heo", The Korean Institute of Communications and Information Sciences, 827~828 (2016)
  14. K. Kim, "Physical One Direction Communication Device and Method Thereof", Korea Patent No. 10-1593168, ~ (2016)
  15. "IEEE 802.3-2012. The Standard for Ethernet", ~ (2012)
  16. "IEEE 802.11-2007. IEEE Standard-part 11: wireless LAN medium access control and physical layer specifications", ~ (2007)
  17. Jon Postel, "“Transmission Control Protocol,” RFC 793", ~ (1981)
  18. M. Allman, "“TCP Congestion Control,” RFC 2581", ~ (1999)
  19. M. Elaoud, "Adaptive Use of Error-Correcting Codes for Real-time Communication in Wireless Networks", Proceedings of IEEE Infocom'98, pp.548~555 (1998)
  20. 안종석, "이동 무선 네트워크의 전송 성능 향상을 위한 적응적 FEC 알고리즘", 정보처리학회논문지C, 9(4), pp.563~572 (2002), 한국정보처리학회
  21. S. Choi, "IEEE 802. 11MAC-level FEC scheme with retransmission combining", IEEE Transactions on Wireless Communications, 5(1), pp.203~211 (2006)
  22. S. S. Chakraborty, "An ARQ scheme with packet combining", IEEE Communications Letters, 2(7), pp.200~202 (1998)
  23. S. S. Chakraborty, "An adaptive ARQ scheme with packet combining", IEEE Communications Letters, 3(2), pp.52~53 (1999)
  24. H. Dubois-Ferriere, "Packet combining in sensor networks", Proceedings of ACM SenSys, pp.102~115 (2005)
  25. P. S. Sindhu, "Retransmission error control with memory", IEEE Transactions on Communications, COM-25(5), pp.473~479 (1977)
  26. A. Bakre, "I-TCP : Indirect TCP for mobile hosts", Proceedings of 15th International Conference on Distributed Computing Systems (ICDCS), pp.136~143 (1995)
  27. R. Cohen, "Using proxies to enhance TCP performance over hybrid fiber coaxial networks", Elsevier Computer Communications, 20, pp.1502~1518 (1998)
  28. H. Jiang, "Passive Estimation of TCP Round-Trip Times", ACM Computer Communication Review, 32(3), pp.75~88 (2002)
  29. B. Constantine, "“Framework for TCP Throughput,” RFC 6349", ~ (2011)

관련 논문AI추천

이 간행물의 다른 논문 (24건)