본문 바로가기
KERD
논문KCI 등재

리눅스 의사난수발생기의 구조 변화 분석

An Analysis of Structural Changes on the Linux Pseudo Random Number Generator

0

조회

0

다운로드

0

인용

0

참고문헌

키워드

주제분류컴퓨터학

초록

모바일 기기나 임베디드 기기 등의 운영체제는 대부분 리눅스 커널을 기반으로 동작한다. 이러한 운영체제는 암호 키와 보안 기능 등 시스템 운영에 필요한 난수를 리눅스 커널에 요청한다. 안정적으로 난수를 제공하기 위해, 리눅스 커널은 내부에 전용 의사난수발생기를 탑재하고 있다. 최근에 이 의사난수발생기에 대대적인 구조 변화가 이루어졌다. 그러나 대대적인 변화에도 불구하고 새로운 리눅스 의사난수발생기의 구조에 관한 안전성 분석 결과가 발표되고 있지 않다. 본 논문은 새로운 리눅스 의사난수발생기의 안전성을 분석하기 위한 사전 연구로서 이러한 구조 변경을 살펴본다. 추가로 변경 전과 변경 후의 차이점을 암호학적 관점과 성능 관점으로 구분하여 비교하고 안전성 분석이 필요한 요소를 식별한다. 이 결과는 새로운 리눅스 의사난수발생기 구조에 관한 이해를 제공하여 안전성 분석의 토대로 활용될 수 있다.

Abstract

The operating system (OS) of mobiles or embedded devices is based on the Linux kernel. These OSs request random numbers from the Linux kernel for system operation, such as encryption keys and security features. To provide random numbers reliably, the Linux kernel has a dedicated random number generator (Linux Pseudo Random Number Generator, LPRNG). Recently, LPRNG has undergone a major structural changes. However, despite the major changes, no security analysis has been published on the structure of the new LPRNG. Therefore, we analyze these structural changes as a preliminary study to utilize the security analysis of the new LPRNG. Furthermore, the differences between before and after the changes are divided into cryptographic and performance perspectives to identify elements that require security analysis. This result will help us understand the new LPRNG and serve as a base for security analysis.

참고문헌 (19)

  1. B. Barak, "A model and architecture for pseudo-random generation with applications to", dev, Proceedings of the 12th ACM conference on Computer and communications security, pp.2005[DOI]
  2. Y. Dodis, "Security analysis of pseudo-random number generators with input:", dev, Proceedings of the 2013ACM SIGSAC conference on Computer & communications security, pp.2013[DOI]
  3. Z. Gutterman, "Analysis of the linux random number generator", 2006 IEEE Symposium on Security and Privacy (S&P’06), pp.371~385 (2006)
  4. F. Coichon, "Entropy transfer in the linux random number generator, RR-8060", INRIA, 26~ (2012)
  5. The linux pseudorandom number generator revisited, "P. Lacharme", ~, pp.Cryptology ePrint Archive, Paper 2013 (2012), 251
  6. Y. Yeom, "Probability distribution for the linux entropy estimator", Discrete Applied Mathematics, 241, pp.87~99 (2018)
  7. N. Heininger, "Mining your ps and qs : detection of widesperad weak keys in network devices", 21st USENIX Security Symposium, pp.205~220 (2012)
  8. S. H. Kim, "Predictability of android openssl’s pseudo random number generator", Proceedings of the 2013 ACM SIGSAC conference on Computer &communications security, pp.659~668 (2013)
  9. D. Kaplan, "Attacking the linux prng on android: weaknesses in seeding of entropic pools and low boot-time entropy", 8th USENIX Workshop on Offensive Technologies (2014)
  10. T. Yoo, "Recoverable random numbers in an internet of things operating system", Entropy, 19, pp.113~ (2017)
  11. BSI, "Documentation and analysis of the linux random number generator, version: 5.9", ~ (2024)
  12. ISO, "ISO", IEC 18031: Information technology – security techniques. random bit generation, 2011
  13. M. Matsumoto, "Twisted GFSR generators", ACM Transaction on Modeling and Computer Simulation, 2(3), pp.179~194 (1992)
  14. M-J. Saarinen, "The blake2 cryptographic hash and message authentication code (MAC)", RFC 7693, ~ (2015)
  15. J-P. Aumasson, "SipHash: a fast short-input PRF", Proceedings of the International Conference on Cryptology in India, pp.489~508 (2012)
  16. Y. Nir, "Chacha20 and poly1305 for ietf protocols", RFC 8439, ~ (2018)
  17. E. Barker, "Transitioning the use of cryptographic algorithms and key lengths", National Institute of Standards and Technology, ~ (2019)
  18. H. Krawczyk, "HMAC-based extract-and-expand key derivation function (HKDF)", RFC 5869, ~ (2010)
  19. E. Barker, "Recommendation for Random Number Generation Using Deterministic Random Bit Generators", National Institute of Standards and Technology, ~ (2015)

관련 논문AI추천

이 간행물의 다른 논문 (14건)