본문 바로가기
KERD
논문KCI 등재

공개키기반 사용자인증과 암호화를 적용한 영상회의 스템 설계 및 구현

Design and Implementation of Public key-based Video Conference System for Authentication and Encryption

0

조회

0

다운로드

1

인용

0

참고문헌

키워드

주제분류공학

초록

본 논문에서는 최근 대두되고 있는 화상회의 시스템에 대하여 사용자 인증 및 암호화를 지원하는 공개키 기반 인증서기반의 영상회의 시스템을 설계, 구현하고 이에 대하여 기술한다. 공개키 기반 인증서를 사용함으로써 영상회의 참여자에 대한 인증을 강화하며, 대칭키 시스템을 이용하여 영상회의 정보를 보호함으로써 여러 가지 악의적인 접근을 차단할 수 있다. 본 논문에서는 국내 공인인증 규격에 따르는 인증서를 적용한 트랜스포트 계층 보안 프로토콜을 구현하고, 미디어 암호화를 위하여 대칭키 암호화 알고리즘인 DES, 3DES, AES등을 적용할 수 있도록 영상회의 시스템을 설계 구현하였다. 본 논문은 사용자 인증 및 영상회의에 대한 정보를 보호하기 위하여 대칭키로서 트랜스포트 계층을 보안하는 것과 사용자의 불법 인증을 방지하기 위하여 공개키 기반의 인증 시스템을 두어 사용자의 신원을 확보할 수 있다. 암호화를 위한 세션 키의 분배는 P2P일 경우 IKE 방식의 키 분배 프로토콜을 사용하며, 1:N 등 다자간 사용자일 경우 공개키 기반의 암호화 키 분배 방식을 따라 보안 프로토콜에 의하여 안전하게 분배된다.

Abstract

This paper describes the design and implementation of the video conferencing system using public key infrastructure which is used for user authentication and encryption. Public key infrastructure reinforces the authentication process for conference participant, and the symmetric key system blocks malicious access to information and protect conference control information. This paper shows the implementation of the transportation layer secure protocol in conformity with Korea public key authentication algorithm standard and symmetric encryption algorithm (DES, 3DES and AES) for media stream encryption. In this paper, we deal with two ways of protecting information:transportation layer secure protocol secures user authentication process and the conference control information; while public key-based authentication system protects personal information of users when they connect to the network. When distributing the session keys for encryption, Internet Key Exchange is used for P2P communication, and secure protocol is employed for 1:N multi-user communication in the way of distributing the public key-based encryption key.

참고문헌 (16)

  1. "Diffie-Hellman Key Agreement MethodIETF RFC 2631" (1999)
  2. "^Announcing the Advanced Encryption Standard" (2001), Federal Information Processing Standards Publication
  3. "Visual Telephone Systems and Equipment for Local Area Networks which Provide a Non-Guaranteed Quality Service" (2000)
  4. "Visual Audio Tool", Lawrence Berkery Laboratory
  5. "Media Stream Packetization and Synchronization Non-Guaranteed Quality of Service LANs" (2000)
  6. "RTP Payload Format for JPEG-compressed VideoRFC 2035" (1996)
  7. "Control Protocol for Multimedia Communication" (2001)
  8. "ISecurity Encryption for H-series Multimedia terminals" (2001)
  9. "A Description of the RC2Encryption AlgorithmIETF RFC2268" (1998)
  10. "Cryptography and Network security" (1998), Prentice Hall
  11. "TLS Essentials:securing the web Wiley" (2000)
  12. "암호학의 기초" (1999), 경문사
  13. "The TLS Protocol Version 1.0ETF RFC2246" (1999)
  14. "The Secure Real-time Transport Protocol SRTP IETF RFC 3711" (2004), Inc.
  15. "Planning for PKI" (2002), John Wiley^Sons
  16. "New Directions in Cryptography", 1t-11(6) (1976)

관련 논문AI추천

이 간행물의 다른 논문 (37건)